Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Cadillac Owners: Problems & Solutions

1235

Comments

  • jaymannjaymann Posts: 3
    I have been dealing with this problem now for over a year. The car - it seems at no know reason, time or purpose begins to rev extremely high - over 3,000 RPMs at times. I have to shut down engine - restart it at least three times - and seems to reset itself after 3rd restart. But, will eventually do this again.

    It also has been know to do the opposite, where the idle will fall so low that it will stall - again for no know reason or problem.

    I have had the Throttle Position Sensor (TPS), Idle Air Control (IAC), the related wiring all replaced and rechecked over four times. The TPS and IAC were both replaced 3 times.

    I'm at a loss. It has cost me over $2,000 and I still have the exact problem when I started. No one knows what to do - including myself.

    Has anyone had similar problems and solved it? If, please HELP! Thanks
  • jaymannjaymann Posts: 3
    I own a '97 STS and have always used regular gas - approx. 87 octane. Car has nearly 160K miles.
  • I just replaced the entire suspension system (air ride) on my 94 Eldo with an aftermarket, a good fix but cannot remove the message on the computer "service ride control", trying to find out how!!
  • I have replaced the air ride system on a 94 eldo and cannot remove this message,
    Any solutions out there? :cry:
  • I have gone through 3 of these for about $175 each because the small black plastic finger button starts falling out.
    Extremely poor design as so many things on this model.
    Any way to repair this problem?
    Thank you. :P :lemon:
  • vic8vic8 Posts: 13
    Place the key in your egnition and turn it on.Dont start the engine.Place two fingers,one on the off switch and the other on the red heat button,on your climate control.Hold both buttons down until the computer turns on,you'll see a lot of lights go on,once this happens take your fingers off.Now the trouble codes will start coming up.you will probaly see history codes,meaning prior and current,meaning at present.
  • vic8vic8 Posts: 13
    Can anyone tell me,how to go about changing the rear spark plugs and wires on my 1997 Caddy Deville.The front four look to be easy.Thanks! :confuse: image
  • blkhemiblkhemi Posts: 1,717
    I recently inherited a '97 DeVille D'Elegance from my grandmother with only 27k miles on it(I know, she didn't drive it anywhere). My problem is this; the car's ride level is fine with say me and a front passenger. But put an adult in the back seat, and the car 's rear end drops drastically. I can hear the compressor trying to air the shocks up, but once under way, the car drops back down again.

    The "Service Suspension" light hasn't appeared. But once the load has been taken off, the car's ride height/level returns to normal. Could it be true that this car needs rear shocks already? I see a lot of older DeVilles (94-99) that have the "droopy butt". Is this something relative to this model. I say this because my '03 DeVille DTS doesn't have this problem. Even the base and DHS models were absent of this. Other than that, the car is flawless. It still has the new car smell. It will prbably remain that way as this car requires premium as opposed to regular for my DTS, and @ $3.60/gal as of yesterday, I don't think I'll be driving it any time soon. In advance, any help would be appreciated.
  • During the four years I have owned this Cadillac have had one problem after another..When starting cold, engine really noisy and shakes..dealer cleaned carbon, problem keep returning. Also burns oil, one quart per l,000 miles, dealer says this is normal..Leaks antifreeze..dealer wants $875 to fix small leak, tires wear out every 20,000 miles, 3 of the 4 power windows have stopped working..Dealer wants $625 per window to fix with new motor and more if find additional problems. First and last Cadillac I will own. I am not use to car problems like this. We drive Ford Windstars at work. Get 250,000 plus miles from these with virtually no mechanical problems or oil use.
  • cddydhscddydhs Posts: 1
    Can you tell me how to remove the front door panel driver side from my 2001 DHS I have all the snap in clips removed.Im trying to avoid damage. Thanks
  • sjw2131sjw2131 Posts: 1
    I have seen a couple STS's 99-2000 and they seem to shift really hard into drive from park. the whole motor seems to bounce back and forth and i can see the transmission bounce beneath the car as well. when i saw the first one like this i thought there must definately be something wrong with it but then now ive seen two more like this. is this normal for this model/years???
  • rockyleerockylee Wyoming, MichiganPosts: 13,994
    Do any of you know if the Northstar once it springs a mild leak, is still fixable. Will the leak get worse, and the rsult is the engine deemed scrap. I believe some have said yes in the past. I think. I have a friend with a 95' Eldorado with about 125K on it and it's leaking a lil' bit of oil. It's mild now, and some have told me it will get worse and their is nothing one can do to stop it. Is this true ?

    If any of ya'll want to comment feel free. I went to the search window that the hosts provided me and found nothing.

    I'm just trying to help a friend out.

    Rocky

    P.S.

    Luckily I haven't heard similar problems on 99' and up STS Northstars.
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    It depends where the leak is. If it's the notorious "engine seal" leak, which results in a leak in the unusual split engine block design of the Northstar, then the only solution is a major disassembly of the car and engine. I am told this requires about 18 hours of shop time. Most often, this leak occurs after 100K miles, but much early mileage have been reported.
  • bill86bill86 Posts: 7
    Police lady- in my opinion no oil change is needed between seasons, as was needed many years ago. Your car probably uses 5-30 oil which is all-season, and should be changed when the car's info system says so. It will tell you when the oil life has 10% remaining. In my experience that is around 10,000 mi. Today's cars run cleaner and the oil is better.
    My 1993 Cad sts called for oil changes at about 5500 mi, and after over 200,000 mi it runs fine and uses no more oil than when new. Hope this helps. I think changing oil at 3000 mi is a waste except for the changers.
  • wfeindtwfeindt Posts: 1
    Does anyone out there ever heard of a cad. made of stainless steel, no matter what year?
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    57 & 58 I believe had stainless steel roof and fender skirts, that's about it, in the Brougham model.
  • bartender2bartender2 Posts: 2
    I may have posted my question in the wrong forum,so i'll try here. 1992 deville ,i only have two brakes, rt front and left rear the other two get no brake fluid at all any help would be great, thanx bartender.ps i think my question is on one of the other forums in greater detail
  • dmp3dmp3 Posts: 1
    I own a '99 Cadillac Deville and when I start my car, the power immediately goes out on everything. I try to start it again and it's dead as a doornail. I give it a few minutes and it starts up. I was driving into work and all of a sudden the car dies - no power. While waiting for AAA to arrive, I hear my antenna going down and was able to start my car. The time lapse was about 15 minutes. Any idea what could be wrong??
  • blkhemiblkhemi Posts: 1,717
    The early 80's Eldo's had the stainless steel roof, but I've never heard of a whole car made out of it from Caddy.
  • scott1121scott1121 Posts: 4
    I have the same vehicle and just had my head gasket blow. I was sitting idle in traffic and all of a sudden the bells started going off and the computer screen said "Engine Overheating - Idle Engine". I put the vehicle in neutral and just as I did the bells when off again and this time the screen said "Low Coolant - Engine Overheating - Stop Engine". I immediately put the car in a parking space 6 feet away and turned off the engine. When I did, I heard a bubbling sound in the coolant reserve tank. I got out and on the ground was a huge puddle of milk-chocolate colored, milkshake thickness fluid. After towing to the shop, the initial diagnosis is blown head gasket - external failure. It just turned 100k miles last week and had all the service done as required on a 2003 CTS. Cadillac is refusing to help so far saying that since I have over 100k miles it's out of their abilty to assist, I have 101k miles not - come on guys. I'm going to have it towed to a Cadillac Dealer and have them tear it down and do a full diagnosis.
  • auto007auto007 Posts: 5
    Hi,

    Anyone have any ideas where to get 1 factory 22" Escalade 07 FACTORY wheel/tire? It appears according to my local dealer this is a special order item that takes 2 days to get updated on availablity that could be months?

    It's hard to believe this and any insight on how to obtain it faster would be great!

    Thanks
  • Look under your dash, there should be a small handle just exposed beyond the driver kick panel. If may be sticky if its never been used.

    Sometimes, I have found my brake will stick, try cycling the tranny between park and drive a few times.
  • philly500philly500 Posts: 2
    want to drop a big block olds in my 69 caddy conv is this possible i know my eldo had a 350 olds rocket the 472 in my caddy is a pain to get parts for and of course i threw a rod on sat any feedback would be very helpful

    thanx
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    Doesn't make sense to me. You'll spend a lot of $$ getting everything to fit (it's not a common conversion after all) and you'll lose considerable value on your car to boot. And if you put an Olds 350 in there you will lose a LOT of horsepower (from 375 to 250). And if you use an Olds 455 you will gain but a few HP if you find the most powerful 455 (which will not be cheap to buy).

    Sounds like a no win situation on all counts. Can't think of a good reason to do it---if I could, I'd tell you.
  • 1rubyd1rubyd Posts: 2
    I have a 97 Cadillac Catera. I was just informed yesterday that my left head gasket is leaking antifreeze. I was also told that it will cost me $3K to get this fixed. I am tired of paying money for this car. Any suggestions? My car is not running hot, but damn, when that light comes on to tell me that I'm low in antifreeze, it freaks me out. HELP, PLEASE. My gaskets and not blown so that should be hope for it. HEEEEELLLLLPPPPPPP! :cry:
  • emonteroemontero Posts: 1
    i own a 1994 sts the service engine light came on and now the car will go into reverse or drive very hard and it shifts late thru gears when i`m driving
  • mantagmantag Posts: 47
    Really have not had any major work until recently. Smelled oil coming from the engine - not lights came on, no dripping. Tool in into caddy service - engine half seals were bad - had to drop engine. found a broken engine mount(rubber bushing)could be why I did feel some engine vibration. All told for those to items - $1600 or so. Really hate to think about looking but...with all this talk about the expensive repairs, what else is coming down the road? Whats this about the 'service suspension soon" message, etc. Thoughts??

    Currently have 67k
  • cadilatercadilater Posts: 2
    is there any problems with the ethanol mix in the gas? I went to a station that posted that the gas was 10% ethanol.
  • cadilatercadilater Posts: 2
    hi,

    just going through some posts and found yours from "05. But, was wondering if this problem continued and/or you found out the problem/solution. I have an 03 CTS and it seems that the radio cuts out occasionally for about one second. Hopefully that isnt a long run problem.
    thank you, Mike
  • bill86bill86 Posts: 7
    I believe ethanol up yo 15% is OK for recent cars as yours- check with a Cadillac service dept to make sure. (In Calif most gas has ethanol for emissions (and/or to keep the corn farmers happy) and I think 10%.)
  • Check http://users.elknet.net/mts/index.html for some great tune-up parts for the 472/500 engines, including rebuild kits, and complete engines.
  • Check on ebay; often you see singles for sale there of various Cadillac wheel take-offs from dealers.
  • m1miatam1miata Posts: 4,556
    Are there any of the engine choices to avoid due to reliability issues for the CTS?
    -Loren
  • I would prefer one of the newer 2.8L or 3.6L engines. They are a new design, have good power, and seem to have terrific reliability (so far).
  • Hi i just got a 2005 escalade ext. i love it but wanted some feed back from anyone who has owned one. also i wondered if anyone know where to get gadgets cheaper for it as well?? any info appreciated.. thanks
  • kirainmtkirainmt Posts: 4
    Try e-bay or compare though online stores using Dogpile.com
  • stevewhitstevewhit Posts: 4
    Hello
    I need some help! My '91 Deville with the 4.9 is running very rough and skipping. It seems to run rich when it is acting up but will run really good sometimes. It doesn't seem to matter if it is hot or cold. I have replaced the plugs, cap, wires, and ignition module. It doesn't have any codes set in the computer. It is not hard to start. Sometimes the roughness is there from the start and sometimes its not. It's intermittent, but is getting worse. The exhaust is very black and the mileage is down. I suspect a bad injector. But would an injector come and go? Anyone had this kind of problem before? Any and all ideas greatly appreciated.
    Steve in SC
  • What I have done to this point is verify that I have a voltage supplied to the distributor with the key turned to the start position. It is not the +10 or greater that the book recommends but it is around 9.4 volts. I am using this to disqualify the keyswitch to be bad. I do thank you for your input and I have to admit that at one point I thought it to be the key itself. Any more ideas would be welcomed.

    Thanks,
    Keith
  • crick1mcrick1m Posts: 2
    having problems with car dying and will not restart. It acts like it wants too start, I give it gas but acts like it is not getting enough to start. This has happened twice, had it towed home, as soon as it was dropped off the flat bed it started up both times......... was not too happy, got any ideas could sure use some. :cry:
  • bigdeanbigdean Posts: 2
    can anyone please tell me what service ride control might mean? the car dosen't ride any different. thanks for any help
  • crick1mcrick1m Posts: 2
    ;) I have had the same message pop up on my 93 eldorado. I have been told it could be low air in the tires or the shocks. take your pick I guess. Could be wrong Just telling you what I was told.
  • bigdeanbigdean Posts: 2
    thanks for replay, just tires rotated I'll have shocks. thank you again
  • m1miatam1miata Posts: 4,556
    Have them check the crankshaft position (CKP) Sensor. I had a problem on an Olds. 98 Regency a long time ago, but the '93 Eldo. can have the same problem. And it sounds all to familiar.
    Just tell them to check it out. Should not be too expensive a repair, say what $150? They fooled around with Mass Air Flow Sensor, and Programmable Operation Modules and such, and it still quite running ever so many thousand miles. Take it in and it ran. Well they finally did the crankcase sensor thing - the CKP or whatever so called, it ran.

    Go in a tell them you are a crankcase and need a new sensor. :mad: No, maybe not. Seriously, it could be what is doing this. - Loren
  • mywheelsmywheels Posts: 1
    Please help! Does anyone know how to unlock the theft system on a 2003 Cadillac CTS? I had recently taken my 03 CTS to the mechanic because it was leaking motor oil from the rear main seal. After the transmission was pulled down the rear main seal was replaced on the motor and the job was done but the transmission locked up and the Service theft system appeared. The car starts, but the transmission does not move. Please advice...
  • kirainmtkirainmt Posts: 4
    Usually when you get that light it means that a strut has failed electrically and needs to get replaced or your air ride just messed up once. I would recommend that you get an ASE certified tech to diagnos the codes or check for the codes at:

    http://myweb.accessus.net/~090/dtcobd1.html#pcm

    It may turn out to be a sensor but without checking the codes, clearing them and then diagnos the one that comes back you won't know for sure.
  • adeliaadelia Posts: 1
    My mechanic who services mainly Cadillacs is an independent. He can get no information from the dealer in town regarding the clicking or clacking sound issuing from the center dashboard area. He has replaced a couple of the doors on the automatic airconditioning/heating system and currently working on another. He is aware of several similar problems in cars in his care. Is there a service bulletin dealing with this annoying problem? My mechanic does buy these service bulletin books but cannot find this particular problem.
  • I had a battery drain that puzzeled us for a while. Then when in the garage I heard motor running while car was sitting still in garage. Hadn't been using it that day. The factory built in stabelizer or equalizer for leveling car while pulling boat had a hole in pneumatic hose and system was trying to stabelize itself ALL THE TIME...to no avail, even when the car was not running. A real drain on the battery when it wasn't being charged. Just got the hose replaced and all was fine.
  • What did you find out? My Cadillac Sedan de Ville always starts, but occasionally a SERVICE THEFT SYSTEM light reads across dash and some computer cuts the fuel supply and the car turns off. At other times it drives beautifully, and everything works well. After four days of this Start engine, SERVICE THEFT SYSTEM readout, and shut off of engine routine, I had AAA tow my car into Cadillac dealer. Upon delivery, it worked fine for dealer; and in 10 days of observance there it only replicated that problem activity once. Otherwise drove fine. Strange thing: IT NEVER CREATED ANY CODES ON HISTORY READ OUT related to this problem. So after 10 days, I drove it home. Currently works fine, but I'm scared to take car anyplace. Wrote to Rick Wagoner CEO of GM about status. Asked for sollution. GM Designee called me on phone and said she'd look into problem. She called next day and had no solution. Indicated no GM technicians, designers or engineers were aware of any Cadillac anywhere of having this problem. Same story at my local dealer. My car is one in a million? During second phone call, GM Designee offered me $1000 towards purchase of new Cadillac. I don't want to buy a new Cadillac. I requested this $1000 be applied to replacing my Instrument Control Panel Module Is that the computer which was at fault??? Nobody knows. GM Designee said No, offer was only for purchase of new Cadillac, not for repairing mine. I said Not acceptable solution. I want mine fixed RIGHT! So....hagen03, Did you get your car diagnosed and successfully repaired? HELP!
  • I have found one fuse box under the hood, but am wondering if there is another. I know some have placed them in the trunk, but I wanted to know before I started in. I'm having to repair the wipers and I'm hoping the motor isn't bad and it's just a fuse to save my customer money.
  • My problems started with a "Check Coolant Level" message that appeared on my DIC when I knew the coolant tank was full. Later the gas gauge started moving up and down without correlation to the amount of fuel in the tank (it went from half full to full within five minutes when I knew the tank was nearly empty - I first thought I had invented a gasoline refining car, but that seemed a bit unlikely). The next issue was the instantaneous and average mileage indicator, which was anomalously high. I am guessing some computer module has gone bad. Is there a module that controls the gas gauge, the coolant indicator, and the instantaneous mileage? Do I just have two sensors that went bad at the same time? I would appreciate any advice.
This discussion has been closed.