Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Ford Escape Hybrid Brake Problems

PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 9,334
Discuss your braking issues here

Edmunds Moderator

Silver 2012 Nissan Versa Hatchback & White 2019 Nissan Rogue S

Need some roadside assistance? [email protected] - or send a private message by clicking on my name.

Just purchased or leased a vehicle? Write your own vehicle review

«134

Comments

  • I've had my Escape Hybrid since Nov of '04. Several months after buying it the car was making a horrible noise. I took the car into the shop and their hybrid mechanic came driving with me. He thought it was a problem with the rear braking system. He took it in and cleaned the brakes and pads, etc. It was only a temporary fix. I had the car in the shop last week for the same noise. This time they replaced all the rear tire componotes. Unfortunately it's started making the noise again. I just got off the phone with the shop and they are going to call Ford's Hybrid line...Is anyone else having problems? The noise is a high pitched noise that comes and goes when it wants and seems to only happen when I make right turns.

    Erin
  • stevewastevewa Posts: 203
    My suspicion is this is not being caused by the rear disk brakes, but rather by the "drum in hat" parking brakes. I've had it happen a couple of times, on the second occurance I was able to silence it with a quick pull and release of the parking brake handle.

    I believe Ford may have a TSB out on the parking brakes in rear-disk equipped '05 Escapes (all the 4wd models have rear disks in '05).
  • Hi

    I have had scary brake noises coming from the driver's side rear wheel. A high pitched repeating squeal - mpore noticeable at lower speeds. The breaks were reground (car was 2 months old). This solved the problem for about 2 days. Rhe noise started again. The service manager heard the noise - then I has to go to work. When the car was moved to be serviced the noise mysteriously vanished and they didn't do anything. Luckily the noise hasn;t come back. However I do continue to hear a low pitch nopise that I am assuming is the car re charging? Any thoughts.

    Also I am underwhelmed witht my mileage.
  • stevewastevewa Posts: 203
    I've had that squeal. Next time it happens try pulling up on your parking brake handle (hold the button in) and quickly release it again. The problem appears to be the parking brake shoes hanging up.
  • I have my Hybrid in the shop right now for this same brake noise...a very loud intermittant squeaking from the rear tires at slow speeds. I'd appreciate any info on how your problem was resolved as so far my local dealer is clueless.

    Also, has anyone experienced this problem...I made an appointment with the dealer for service and dropped it off at the appointed time. The dealer called later in the day and told me that the "one Hybrid mechanic" had not shown up that day and that I'd just have to wait for him to come back to get the car serviced. Meanwhile, I have no car and they're not offering to pony up for a rental.
  • I just got back my 2005 hybrid escape after taking it in 5 times in 2 months. The ford dealership just put in a new master cylinder and hopes this will take care of the problem. This is not my 1st problem with this car. It kept stalling when driving and they had to reprocess the computer system. When is a car a lemon??
  • Karen_SKaren_S Posts: 5,092
    This article may be helpful for you.

    Getting Some Lemon-Aid From Your Lemon Maker
  • gagricegagrice Pahrump, NevadaPosts: 31,439
    When is a car a lemon??

    Each state has different laws. The main thing is document every visit and keep all paper work. It is not as easy as you may think to get rid of a lemon.
  • I've had my Escape Hybrid for one month as of August 30 and have experienced a high pitched squeal on two occasions, both times as I was returning home after extensive highway driving (1.5 hours and 5 hours); the squealing occurred as I was travelling more slowly (approximately 40-50km/hr) in a residential neighbourhood and was not breaking. It would seem to be heat-related and not associated with the act of braking. I have not had it into the shop yet for initial servicing so cannot comment on dealership's ability to cope with the problem.

    My gas consumption is 8.0 L per 100km; how is that comparing with others real life experiences?
  • I have had my 2007 Escape Hybrid for 2 months and have had no problems so far. In fact, I think the brakes are excellent. They saved me from a potential accident yesterday! Best of luck.
  • raewynraewyn Posts: 5
    Brake Failure

    Yesterday as I was driving at 40 miles an hour on a commerical strip the brake warning light on our 2006 Ford Escape Hybrid suddenly flashed at the same time that the brakes completely failed. Just missed a number of cars but was able to get into a parking lot, shift to low, and run uphill into a curb. 45 minutes later no light and the brakes were working fine. The dealer is baffled. Anyone else with experience with this. I'm wondering if it has any relation to the catasrophic brake failure of the Mercury mentioned above.

    thanks
  • testestestes Posts: 13
    Hard to diagnose It could be a similar issue. My problem turned out to be a combination of the Smart Junction Box and they replaced the master cylinder as well. I have not had any recent problems. I am up to 8300 miles and doing fine. My last issue was the warning light that sporadically turned on, and it turned out to be the hydraulic system had not been properly bled. Have your mechanics reach out to the Mercury Dealership in Shrewsbury, MA service department. Tell them Tillman sent you. These guys are top of the line and they have authored service bulletins on the Hybrid from the experiences with my MMH.
  • raewynraewyn Posts: 5
    Thanks for the suggestion to go to the folks in MA. I real lifeline to try as two days in the mechanics here in CA are baffled. They seem to be stumped that they can't get the computer codes to reveal anything.
  • I had the exact same problem this week in a new 2007 model with less than 2000 miles on it. Barely made it to the side of the road TOTAL brake failure. Dealer says the computer failed. Waiting on a back ordered part at this stage, but to tell you the truth, I'm not sure I want to drive the thing again. Anyone know of a recall? Or a way to bring this to Ford's attention nationall?
  • mschmalmschmal Posts: 1,757
    visit www.safercar.gov

    Mark.
  • Thanks so much. I'm sorry you've had the same problem but its great to know I'm not the only one. Could you tell me which part you are ordering and which dealer has your car. Perhaps my dealer here in Santa Barbara will call them and get the lowdown on this problem. I'm going to pursue the website at safergov as well to see how we get to Ford national.
  • Yes. I don't have the name of the part but they described it as the computer that controls the brakes. It was on backorder and they finally got it in, bled the brake lines, the service manager drove it for a day, everything fine. It's Lou Sobh Ford in Decatur, Ga, and the service manager is Billy. Have you approached your dealer about replacing the vehicle? I'm starting to think we will. I can't put kids in that car any more, too shaken, and get this... we got the car back yesterday after 1.5 weeks waiting on this part--- and I'm on my way to work at 6am and the brake light comes on again and the service brake light. This time, however, the brakes did not fail. But it's clear we still have a problem. I'll have to get it in there again after Thanksgiving. This is horrifying. Please feel free to email me directly if you want more info on the [email protected]
  • dsteakdsteak Posts: 18
    i've had my escape for 18 months. i have the squeaking problem, but also, the other day the "service brakes" message popped up and the brake warning light came on. i took it in, and they claim there's no information in the car's computer regarding this message, so it probably didn't happen. i had the car serviced, and drove it home. the next day, the message came on again along with the warning light. when they serviced my car, they said the brakes are fine. anyone else have this issue?
  • testestestes Posts: 13
    I had the exact same problem after they replaced my braking system... It turns out you have to bleed the brakes 100% (99.5% will not work) or the light keeps coming on. Have them call the tech at Sentry West Lincoln in Shrewsbury, MA. They can tell them all about it. Good luck.
  • dsteakdsteak Posts: 18
    Thanks for your response. Did this ultimately fix the problem? My dealer won't call Sentry, saying they're not allowed, they have to go through Ford engineering, who apparantly don't know how to fix this?

    MY LAST FORD.
  • Hello All,

    I have been reading alot about the Ford Escape Hybrid and have had some issues with the brakes of my vehicle...

    I work for a local organization and we have quite a few of the SUVs in our Fleet... Recently due to a number of complaints they pulled the WHOLE Fleet of the Ford Escape Hybrids off the road due to Brake Failures... mine being one of them. It turns out that in a fleet of hybrids over 30, at least 7 of the vehicles had some sort of failure... a couple of which were 2nd or 3rd time issues. and a few resulted in accidents...

    Ford has reviewed all of the vehicles in the fleet and will be issuing a letter saying its safe to drive. They say that they have found "No Codes" showing any kind of failure in the braking system... but Im not an idiot! I know that when my foot goes to the floor to stop, the truck should stop... which it didn't! I have had to make many panic stops in the truck previously and never had a problem before... until recently... the brakes did return a few hundread meters down the road at a stop light... but no lights showed on the dash and no abs kicked in... Thank god the person in front of me moved before I hit them.

    My vehicle is my office for atleast 8Hrs a day and I put on it, anywhere from 100 to 250 Km a day at work and the majority is City Driving.

    Please tell me that I am not an idiot... or that this is not an isolated incident or if you know what the problem is... or if you have had this happen to you.

    Thanks in advance for your help and comments...
  • mecheng1mecheng1 Posts: 161
    My local County Park Service owns a 2006 FEH as part of their vehicle fleet. They are frustrated because they have had to send it back to the dealer a few times for braking issues. I get the feeling that the dealership and Ford are not sensitive to "bad press" that this can cause - because they never seem to fix the problem.

    Braking "by-wire" is a relatively new concept for mass produced cars. My guess in that the Technicians are not as adept at finding these electical and computer software issues (especially when diagnostic codes are not forthcoming). [The design of the mechanical portions of the brake system seem to be fine.] From reports of previous FEH brake problems, I suspect the component known as the "Smart Junction Box". Not a trivial part that Ford would replace unless it was proven to be "bad".

    To address your question: You are not an idiot for wanting confidence in your braking system. Unfortunately, having someone commute in the vehicle (who understands the "brake-by-wire" system) my be what it takes to get to the root cause of the problem. Have the dealer monitor TSBs that are issued by Ford for ones related to FEH brakes. Be safe. :D
  • dsteakdsteak Posts: 18
    The issue I have is the "Service Brake System" message displays, and the ! Brake Light comes on. I've had it into Ford 3 times, and they tell me there's no codes in the system, the brakes are fine, they have no idea what the problem is. I took a picture of the dashboard to prove it to them that this was happening. They said they contacted Ford Engineering about this, but that was 4 months ago and I haven't heard anything back.

    I have not had break failure (yet) but am worried that this is the next thing that will happen. Did you have this problem prior to brake failure?

    A previous post said that his dealer in MA fixed this problem by bleeding the brakes (100%). The dealer I brought it to bled the brakes but not 100% (they said they couldn't do that) and wouldn't call the other Ford dealer to discuss how they fixed it.

    My next step is Ford customer service, file a complaint and take it from there. I don't suspect any help there however. Don't know what else to do.
  • mecheng1mecheng1 Posts: 161
    Yes - I would start contacting as many Ford customer services contacts as you can find. ("District", "Region", "Corporate" - however they are organized)

    There may be some room for confusion on the discussion of bleeding the brakes. Are we clear on what the dealer in MA did? Did they: remove and replace 100% of the brake fluid? or, did they bleed the brakes to remove 100% of any air trapped in the brake lines and components? or, both?
  • testestestes Posts: 13
    The problem I had with my Mercury's brakes was a two step repair. I took it in a few times, and the the light would turn off. With the light off, there are not codes to read. I finally had an opportunity to take it in while the light was on, a an error message was found. The first problem was jumper harness (see parts list below) that had to be replaced along with the master cylinder. Here are the notes from my service invoice:

    Could not verify concern, self test ABS module Codes C1524, C1323. Perform Pinpoint test told to replace ABS module. Sock and Check Oasis and call the hot line, told about the Jumper Harness to install. And to try that first. Day two install the jumper harness. Clear all codes and Road test Ok at this time Hot line ID 6ECEN007.

    The parts used to repair the vehicle are listed below:

    2219D11 Solenoid Valve Block / HCU - remove and install or replace (2C065/2C215/2C219/2c266/2C286) _ L 26 W

    1 7M6Z*2c286*A control Asy - ABS Hydraulics
    24 PM*1*C Fluid - brake
    1 5M6Z*2140*B Cylinder Asy - Master
    2219D Anti-lock brake system Diagnosis - l 26 w

    After they replaced all these parts, I had to take it back in for, due to the brake light coming back on. This second step of the repair is when they bled the brakes... after they replaced the ABS Hydraulics. That is when the brakes had to be bled 100%. They had done a good job of bleeding, if you were only doing hydraulic work. However, with the regenerative portion of the brakes in the system, they bled them a little more. This is how it was explained to me. I have not had any additional problems with this particular issue. Hope this helps.
  • dsteakdsteak Posts: 18
    This is great information. However, the dealer I take my care to tells me they can't do this work unless the directive comes from Ford engineering. They say they're not allowed to call this other dealer. I don't understand why Ford doesn't have this information since it's been a known problem for 2 years. I'm frustrated. Been trying to contact Ford but not getting any response yet.
  • mecheng1mecheng1 Posts: 161
    "Ford engineering" and the "Hot line" mentioned in the service description are the same thing. Your dealer is allowed to call the Hot line and reference the earlier (Hot line ID #) resolution if they feel they have a similar diagnosis. :D
  • rearend2rearend2 Posts: 1
    Hi All, This Braking Problem is VERY FUSTRATING!!! :mad:

    I have one of the fleet vehicles :lemon: that is listed above... we have had a meeting with FORD and durring the meeting all Ford could say is how great the braking system for the hybrid is and how everything is run by the computer and how if there is a problem there must be a code!

    However when we asked about what is going on with our vehicles and why there have been 5 reported incidents of no brakes durring a pannic stop... their answer was that since there is no codes there can't be a problem... no codes no problems...

    When we told them about all the reported incidents discribed here on the net... all they can say is that you can't believe what you read on the internet.. and that this is the first they have ever heard of this type of problem... seems hard to believe (13% of the FEH in the fleet have had an incident) and there is no problem :surprise: ...

    SO, according to Ford, none of you people exist that have had similar brake problems! I guess that 6 pages of comments must not exist either! :confuse: It also must mean that no one is reporting these problems to Ford... what is the protocol that a dealer must follow then?

    Im VERY FRUSTRATED!
  • richdeanrichdean Posts: 2
    My 2007 Escape Hybrid 2WD is at Maxwell Ford in Austin right now for a similar problem to what is reported earlier in this thread. The rear brakes partially lock on whenever it is wet out and I've set the e-brake. You can clearly hear the metal-on-metal sound for several miles before it stops.

    Of course the problem stops by the time I get it to the dealer since they're 5 miles away. The SA @ Maxwell says they can't fix problems they can't hear. Since they started with the attitude of "there is no problem," I have little confidence in them at this point.
  • richdeanrichdean Posts: 2
    Well Maxwell Ford has refused to fix the problem with my brakes. They say that because the computer doesn't show a problem, there is no problem. They also claim that the problem is that "you are driving around with the parking brake on."

    Right. Every few days I ignore the "your brake is on" idiot warnings the car gives off.

    The SA was also exceedingly condescending to my Ivy League educated wife (the SA told me, "oh, sweetie, she's trying as hard as she can, but the poor thing can't describe problems very well"). Never mind that my wife helps me fix our vintage cars. :-\

    Don't ever go to Maxwell Ford in Austin.
  • keleeykeleey Posts: 2
    Hey everyone. I'm new to all this.. I have a 2006 FEH that I bought back in Dec. 2005. Since then I have had not 1 but 2 COMPLETE brake failures. By the grace of God I did not get into a car accident either time.. The first time they replaced the wiring harness then 7 months later it happened again. This time they replaced the ACU unit. I have filed a complaint with NHTSA, Ford and the dealership. I am requesting a but back on the are b/c I am scared to death to ever drive it again. Ford had told me they will not buy back the car. Has anyone had this problem? Gone through the steps for a buy back? Any advice I would really appreciate it. I can't get behind the wheel of that car again and I don't know where to go from here? Thanks
  • dsteakdsteak Posts: 18
    after a few months of going back and forth (4 times), and with help from ford customer service, i got ford to service the vehicle for the emergency brake light coming on and the service brakes message coming on. they did the following, apparantly according to ford engineering instructions :

    removed ground 102 and 104, clean brackets, bolts, and body, replace both ground wires. removed and cleaned brackets, bolts and body for grounds 102 and 104. removed the abs module connector and removed and replaced the ground 102 and 104 wires. installed all removed parts and cleared codes and retested.

    funny thing is, they said there were no codes and could not verify that there was a problem, even though i gave them a picture i took of the dashboard with the problem showing.

    anyway, since 3/20, the lights have not come on again, but i can't help but be nervous everytime i apply the brakes. before i have to stop, i always pump the brakes to make sure they work.

    :surprise:
  • keleeykeleey Posts: 2
    Thanks for your reply.. When mine was serviced(which it's at the dealer now) there were codes that showed up. And they say they have it fixed this time. Well that's what they told me last time. I know how you feel about being nervous. That is why I am refusing to take the car back. I can't take the chance that this will happen again. I may not be as lucky as I was the 2 times it has happened. I am not going to endanger my life or anyone else. Have you tried to get a buy back? Just wondering. Thanks
  • dsteakdsteak Posts: 18
    i haven't had the problem with brake failure, and geez i hope i don't. i don't know if it's the same issue or not. but i worry that it's going to happen.

    i don't imagine they would buy the car back. ford is in trouble. maybe the ceo would, since he's been paid an $18M bonus and Ford lost $12B last year.
  • marie12marie12 Posts: 2
    I am so pleased that I found this discussion board and so sorry to hear you all have the same problem I do. I too have experienced brake failure in my SUV four times now. I have a 2006 with 37,000 miles. (do alot of driving) I am scheduled to take the car to Ford Dealer on Monday and am planning to bring in all these comments. I do wish we could be heard by Ford somehow. There should be a recall.
  • marie12marie12 Posts: 2
    This is a web site I just posted a comment on and explained the braking problems. It lists several recalls for the Ford escape just not for the brakes yet. If enough postings are made to this site, maybe someone will hear us. Worth a try..
  • simmisimmi Posts: 7
    I bought my Ford Escape 2008 Hybrid only 3 weeks ago. Saturday I planned a trip with my boyfriend and my dog and suddently while driving, the brake and ABS light came on and there was hardly any brake in existence. Luckily I had no accident but we had to get towed to the dealership. My whole weekend was messed up.

    My car was supposed to be ready on Monday but they said that the part (mastercylinder) was not there yet. I called today on Tuesday and it still is not there. How disapointing.
  • Here's another FEH brake failure story. Sounds like we have all been very lucky. I was only going about 20-25 miles an hour when I lost mine completely. Both the ABS and the brake light came on. I was able to get the car off the road and stopped with the emergency brake. I shut the engine off and when I turned it back on again I had brakes. I am working about 80 miles away from home so I took it to the closest dealer. They have had it 3 days now. They have only told me so far that the computer said it was a "main switch" for the brakes. The car has a little over 15,000 miles on it and this is the first trouble I have had except for an annoying brake grabbing every time it rains or there is heavy dew in the morning! Of course the dealer has always told me there is nothing wrong with the brakes and never writes it on the receipt. From what I am reading here, though, I have a sick feeling they might be related. I haven't decided what I am going to do yet - I live in PA and we have a Lemon Law so I will probably go through the Better Business Bureau. I have no confidence in this vehicle now because it doesn't seem that Ford has a handle on it. Has anyone had a resolution?
  • mecheng1mecheng1 Posts: 161
    Sorry to hear about your brakes going out completely. From the posts I have read, it appears that many of the brake failure problems are solved by replacing the master cylinder.

    The "grabbiness" is probably not related to the failure...it is inherent to the hybrid design. In slightly wet conditions the brake surfaces stay wet until the FEH is close to stopping. At that point the computer switches the braking from the regenerative system (MG1) to the old fashion hydraulic brakes...and the brake force increases until it feels like it grabs too hard. In non-hybrids, the offending moisture on the brake surfaces is dissappated during the heavy portions of initial braking and are practically dry at the point just before the vehicle stops (where, on the hybrid, you should be feeling the "grabbiness")

    A good solution on wet days is to perform all of your first few stops with the transmission selector in "N"-neutral. This shuts off the regen braking and forces regular hydraulic braking...which should dry off the braking surfaces. Stops after that should not be grabby. If it occurs again, hard braking or braking in "N" drys off the braking surfaces again.

    Good luck and be safe. :D
  • Thanks for the info - I'll try that. They replaced the solenoid valve on my car but could not/would not guarantee the problem is fixed. However I did notice this morning (I just got it back from the shop) that the brakes did not grab like they usually do. I have no confidence in this car. I don't feel that these SUVs are getting repaired and I get the feeling Ford is sticking their heads in the sand. Can you say PINTO! There are at least 4 complaints filed on NHTS - Office of Defects Investigation (safercar.gov)but unfortunately there evidently aren't enough complaints yet (or no one's gotten killed yet!)as nothing is being done.
  • mschmalmschmal Posts: 1,757
    Couldn't that be a good thing? Maybe it shows that the problem is not wide spread and correctable.

    Maybe your dealer corrected it.

    At my dealer, none of my hybrid customers ever complained about the mechanical function of the car. Or have I heard of a complain from anyone else in the dealership or other customers.

    I am not saying you are imagining the problem. However try to have a little faith. Remember that you can always go to another dealer.

    Mark
  • I've had my 2008 FEH for a month now. I've noticed that when using the brake the vehicle doesn't slow down right away. I've had to press hard on the brakes to stop the car. I actually got a ticket for overshooting a stop sign because when I pressed on the brakes, nothing happened! I thought I'd have heart attack. So far, I've driven over 900 miles in this car so, I'm very comfortable driving it and am familiar with some of its little quirks. At first I thought that I just needed to get used to the brakes and weight of this car. Now, I don't think so. It doesn't do this all the time though, but when it happens it can be quite scary. I've even bought a doggy seatbelt for my pup to keep her from sliding off the seats when this happens. I hope this is an easy fix or better yet user-error (I doubt it). Be safe!
  • To all of you that have and or had brake problems - were they resolved? Do you feel the car is finally fixed? Did any of you have a brake failure after the solenoid valve block was replaced? I'm trying to gain some level of confidence in this vehicle but when Ford doesn't want to admit there is a problem and the dealership won't guarantee it won't happen again . . . . Any thoughts?
  • My brake problem has been fixed since then. My car was in the shop for 4 days though and since then (2 month) I have not had a brake problem again. I did however have my engine light come on and the thermostat, after having the car only 2 month. The dealer fixed it really quick by replacing the thermostat and I had the car back with 2 days. So I am really dissapointed about the car. I've had the brake problem after 3 weeks and the engine problem after 2 month. I am on edge right now and just waiting what comes next. I really love the car but having these issues with a brand new 2008 Escape Hybrid upsets me.

    I particpated in a focus group last week and the engineers from Ford were there. I had an opportunity to tell all good and bad so this was great. Hopefully they will listen and do something about it.
  • after experiencing catastrophic brake failure in my 10 month old feh we never used it again!!! ford never admitted there was a problem, and we refused to take back the car. we were lucky that after six months the ford dealership sold it. i admire folks who have the courage to trust the car after experiencing brake failure...i felt way too wimpy to go thru that a second time! so...i completely understand your reticence in getting behind that wheel. just hope that at some point ford acknowledges what's going on. good luck.
  • This morning,after travelling about 300 feet from start-up,in my 2006 Escape Hybrid,I heard a beep, then the brake light goes on and stays on until I get to my destination, another 3 miles travelled to work. The vehicle has about 8,900 miles driven. It's the same "beep" sound I hear when I engage the emergency brake. I tried this, thinking the emergency brake was still on - not disengaged. The light stayed on. A week ago, this "similar" problem happened - this time, right when I started the vehicle until I shut it off, 3-4 miles away. I went to the dealership that Saturday. They told me that the computer said I had a "grounding" problem. Has this problem happened with anyone else; Yes - what was the corrective action taken by the dealership. I'm not sure the problem has to do with the Emergency Brake; I'ld like to pinpoint the problem before servicing. What's funny is the problem doesn't always happen when I've driven the Hybrid - it's intermittent.
  • dsteakdsteak Posts: 18
    this was the problem i had. check post #34.
  • I bought my 2008 Escape Hybrid two days ago, on 11/16/07. I had driven it 30 miles when my wife and I went to Charles Town, WV, about 35 miles from home. When we tried to start the car to come home, the engine would not start. There was a warning message that said "Regen Brake Disabled". I called the Ford 24/7 road service, but they could not find me in the computer. I was able to convince them that I needed a tow, and when they could not find a tow company in Charles Town, the permitted me to do so and they would reimburse me. Now I am waiting for the dealer to come to my house to get the car.

    Any ideas what happened? I love driving the Escape (all 70 miles so far) but I am worried about this.
  • rnargrnarg Posts: 27
    I have a 2008 FEH with 900 miles and 30 days old.

    One of the first things I noticed while driving is the fact that FEH's have poor performing brakes even when they are working as they are supposed to. They just don't bring the vehicle to a stop in the same amount of distance that other vehicles I drive on a regular basis do. (One of those vehicles is a 2004 F150 V-8 Lariat which has excellent solid stopping ability) The 2 other vehicles I drive on a regular basis all have very good stopping ability and have disc brakes on all 4 wheels. My experience with disc brakes (including the F150) has been that they tend to dirty your wheels immediately with black brake dust that must be cleaned often to prevent buildup on the wheels. This of course is just an appearance issue and has nothing to do with performance, but I have also noticed that although the FEH has 4 wheel disc brakes it DOES NOT produce the brake dust probem, and that's great for keeping the wheels clean, BUT could it be that the FEH poor stopping performance (as pointed out in several car magazine tests) is due to the type of disc pads that Ford is using? Could it be that the disc pads are extremely hard (thus producing very little brake dust) compared to others, and as a result the stopping ability is affected? (Seems to me the harder the disc pad the less wear and production of brake dust, but the harder disc pad won't have the stopping ability as that of a softer one) (sort of the same with tires-----the better stopping performance tires that have soft tread, wear out a lot faster but help in better road hugging performance as compared to conventional ones)

    Could it be that the hard type disc pads being used are required due to having something to do with the needs of the recharging system?

    My point here is that in my opinion on a scale of 1-10 (where 10 is best) the FEH stopping ability would score about a 4 compared to other vehicles, and I suspect this low score may have something to do with the hardness of the factory equipped disc brake pads.
  • Most likely our Escapes come with ceramic brake pads which last much longer and have low dusting.

    Our brakes deffinetly feel differently than a normal car because the first portion of the brake pedal travel activates the regenerative braking which is using engine braking to slow the vehicle. If you apply more pressure than the actual hydralic brakes will start to kick in. I have not tried this yet but if you just crammed on the brakes you should see that the brakes work pretty well due to the fact that we have 4 wheel ABS. I will admit though that the brakes do feel spongy, you should get used to the feel though after a while.
Sign In or Register to comment.