Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Have you recently leased or purchased a Lexus sedan or SUV? If so, a reporter would like to talk to you. Please reach out to [email protected] by Wednesday, December 19 and the Edmunds PR team may connect you with the journalist.
Have you recently purchased (not leased) a subcompact sedan (such as a Toyota Yaris, Honda Fit, Chevy Sonic or Ford Fiesta)? If so, a reporter would like to talk to you. Please reach out to [email protected] by Wednesday, December 26 and the Edmunds PR team may connect you with the journalist.
If you experience loading issues with the login/register form, please completely disable ad blocker or use an incognito or in-private window to log in.

2002 Trooper - 12V Plug is not working in both front and back

dejajitdejajit Posts: 9
edited April 2014 in Isuzu
I am original owner of 2002 Trooper. This SUV has been a very dependable vehicle for last 7 years but I have a small problem now.

12V Plug is not working in both front and back. I am not sure if this is something that would be covered under Isuzu's 10 yr warranty.

Please help me debug.

Comments

  • tidestertidester Posts: 10,059
    What have tried running off the plugs and did you test the plugs with a volt meter?

    tidester, host
    SUVs and Smart Shopper
  • dejajitdejajit Posts: 9
    I tried a car vacuum in another car and it worked. It does not work in my trooper.

    Also my GPS charger does not work.

    No, I did not try with a volt meter. I don't have one.
  • tidestertidester Posts: 10,059
    In that case, either the plugs aren't wired up properly or both fuses have been blown. If they had worked previously then check out the fuses.

    tidester, host
    SUVs and Smart Shopper
  • dejajitdejajit Posts: 9
    It was the fuse. Thanks a bunch!
This discussion has been closed.