Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Colorado and GMC Canyon ABS Fault Issues

1789101113»

Comments

  • yumabradyumabrad Posts: 1

    did anything every get done about the abs fualt light issue, have a 06 i got new and this has been a pain in the [non-permissible content removed] for me,

  • i have a 04 Colorado 2wd. I have recently gotten the abs issue that is on the drivers side. I have actually discovered the problem with mine. The abs tone ring is magnetically held to the rear of the bearing. The ring got loose and pushed itself off the center. Finding this after replacing bearing and sensor naturally. I am trying to resolve by super gluing ring into place. Will post again if problem resolve with instructions on repair.

  • There's two different problems. First one, the front hubs have sensors built into them and sensors go bad around 120k miles or so and need to be replaced. Witch is a.expensive part for some reason and a lil bit more work to fix then most vehicals. But alot of other vehicals need same fix. Secondly, my dash gave me a abs light and displayed abs fault. Did some research and troubleshooting. I already replaced both hubs cause I know better.if one.was.bad  just to.replace the other so I knew that wasnt the problem. Lite came off and.on at different times for no.reason. I fixed it by cleaning all my grounds. Headache/frustrating to figure out but all is good now! :-)Know what you don't know.  I got my colorado 5years ago from someone who hit head on with a tree. The front of engine was in the tree. Replaced front bumper, hood and fender and still running strong.good luck to every one. It's not that difficult as it seems.
  • buz5buz5 Posts: 5
    mittens1 said:

    I have a 2004 colorado same problem. i have been dealing with it for about 2 yrs. had it checked out there is something wrong with the wheel speed sensor most likely in only 1 wheel. mine is the drivers front. something about the seal bad allowing dirt, water to set off this censor also could be a problem. hoping chevy will do a recall I have heard several complaints about this poblem. hope this helps u out

  • buz5buz5 Posts: 5
    I have 2006 Colorado replaced front brakes had rotors turned. The abs light came on.Changed censor on left front did not work.Changed wheel bearing that came with censor. No more problems. Now if abs stops working stops working .I don't know about that. Ask autozone if they can check ABS codes.
  • buz5buz5 Posts: 5
    lvfrank said:

    It seems that all you hear about is resetting the computer, but still the intermittant ABS fault will return with no ryme or reason, and then if you pull over, turn the vehicle off, and start it again, the error goes away. I am tired of this error. The mechanic tells me that it is not hurting the brakes or my safety, but I have had both hubs replaced at my cost, and have had the sensors replaced twice--again at my cost. Does anyone have a new Idea or is it just reset the computer. Tired of this--- It seems that this error effects more than me, maybe GM and Chevy should look at Customer Service and suggest a recall......

  • buz5buz5 Posts: 5
    Might notneed to replace both. I think Autozone can check ABS code. I replaced left front on my 2006 Colorado censor would not work. Replace bearing that came with censor no more problems. Lot have trouble when replacing just censor.
  • eljameseljames Posts: 2
    Hello a_rod68 could you tell us where ABS grounds are located?, to clean them out because I did the same everyones have done and still light coming om and off...
  • eljameseljames Posts: 2
    a_rod68 said:

    There's two different problems. First one, the front hubs have sensors built into them and sensors go bad around 120k miles or so and need to be replaced. Witch is a.expensive part for some reason and a lil bit more work to fix then most vehicals. But alot of other vehicals need same fix. Secondly, my dash gave me a abs light and displayed abs fault. Did some research and troubleshooting. I already replaced both hubs cause I know better.if one.was.bad  just to.replace the other so I knew that wasnt the problem. Lite came off and.on at different times for no.reason. I fixed it by cleaning all my grounds. Headache/frustrating to figure out but all is good now! :-)Know what you don't know.  I got my colorado 5years ago from someone who hit head on with a tree. The front of engine was in the tree. Replaced front bumper, hood and fender and still running strong.good luck to every one. It's not that difficult as it seems.

    Hello a_rod68 could you tell us where ABS grounds are located?, to clean them out because I did the same everyones have done and still light coming om and off...
  • john10567john10567 Posts: 4
    edited August 2015
    I have a 2005 Z71 Colorado with the same problem. My light has been on and off for a few years. I changed sensors and a front hub. The light stays off for a week or two then intermittent until it stays on steady. It's been to a dealor and a private garage and no one can figure it out. I know my
    mileage is high but i intend on keeping it. It's a good truck but GM should stand by their product and make the truck safe.
  • fabisx123fabisx123 Posts: 1
    edited December 2015
    My 2004 Z71 4x4 just out of the blue has a ABS Fault warning on the instrument panel. I was driving and lost all power...no radio, headlights, wipers. When I got it to a safe place to pull over. I turned the vehicle off, waited a minute and restarted. The error was gone. I haven't driven the truck in days...so today I went to start it and the error code happened again and headlights, radio EVeryThing Lost power again! Chevrolet should have a Recall on this issue....I googled it and found Tens of Thousands of other people who are reporting the same issue. This is definitely a Safety ISSUE and should be repaired by Chevrolet. From reading this post they have been aware of this issue for YEARS. I reply from Chevrolet is Appreciated
  • Have a 2004 GMC Canyon Z 85 with same abs issue. Have also had the brake warning light come on sometimes also. Now a new problem. Twice I have went to apply the brake and the pedal went right yo the floor with no resistance. After several pumps would suddenly firm up. Worked for a dealership and never had this happen before.If it was a master cyl. failure should not firm back up and act normal. No one seems to know what this might be. I feel it may all be related. Have not replaced the hubs, sensors and bearings yet because it does not appear to fix the problem.
  • I bought a 2006 Chevy Colorado Crew Cab  (80k miles) almost two months ago. The stock radio had eaten someone's CD so i got a Pioneer installed at Best Buy. The day it was installed, i turned on the truck and my ABS fault came one. Not only that but the blinkers on the dash turned on (solid) and my windshield wipers started on their own. That issue hadn't happened again but my radio started cutting out so Best Buy had me bring it back yesterday. They took the radio out, said it needed an update and shouldn't happen again or they'd replace it. The radio started cutting out on the way home. That night while i was driving, all of my dash lights came on (check engine, seatbelt, battery, ABS, blinkers, etc)so i started to pull over. The brakes locked up and it was very difficult to slow down and steer. Since then my lights have been wonky and the ABS fault comes on off. I've unplugged the battery, pumped the breaks in park, and unplugged and replugged all the fuses under the hood. My question is, does anyone else have this issue or did Best Buy potentially mess something up? 
  • I also have the same problem :(
  • markseemarksee Posts: 29
    So I bought a scan tool from Harbor Freight with ABS and it's telling me the right rear wheel speed sensor is bad. Search as I may I don't find a listing for wheel speed sensors in the rear. Does the rear ABS use the speed sensor on the transfer case?
  • thecardoc3thecardoc3 Posts: 4,331
    Was the code C0055? BTW Codes don 't tell you what part is bad, they tell you what test failed. Plus you cannot rely on the code description in aftermarket scan tools, always look up the code description in service information.
  • markseemarksee Posts: 29
    The codes are C0035, Rt. rear wheel speed sensor open or shorted. And U1064, Lost communications with body control module. Keep in mind I have the ABS2 relay unplugged so the ABS pump won't run.
  • My 2004 Colorado has been displaying ABS FAULT intermittently for over a year now. When it first happened I brought to the dealer and the LF Sensor was replaced. The FAULT was back in immediately. Returning it to the dealer, I was told that there was no memory of any faults, and the pulsing I was experiencing was due to warped rotors. They could not duplicate the ABS FAULT. Leaving frustrated, my goal was to drive it until the fault came in hard. A year later it is still intermittent. I recently had the rotors and pads replaced. I took it back to the dealer last week and talked to the general manager. He said he would arrange for a GM engineer to take a look at it and call me back by noon. I never got the call. On my Colorado, the ABS activates without applying brakes and then a few seconds later it chimes and the ABS light comes on and I read the ABS FAULT as it repeatedly scrolls. It usually happens after I have driven for about 5 miles, shut it down for 15 minutes and then re start it. ABS usually activates when pulling out of parking lot going at a speed of 5 to 10 MPH. I have had the ABS activate at 30 MPH once. I'm afraid that it will activate when I need an emergency stop and will result in going through the trunk of the vehicle in front of me. I have sent an email to GM customer service and have not received a response.

    The abs module is faulty and needs to be replaced.
  • markseemarksee Posts: 29
    I pulled the ABS2 relay on mine until I get it fixed. That keeps the ABS pump from running and causing an unexpected loss of braking. Just be aware if you get in a skid you will have to pump the brakes yourself like the good 'ol days.
  • 2006 GMC Canyon SLE Crew Cab 4WD. Replaced right front rotor, caliper and pads due to spongy pedal with caliper piston and pin sticking causing premature pad and rotor wear. Now ABS Fault illuminating with intermittent ABS pump activation. Planning to replace both hub/wheel bearing/ABS sensor assemblies as well as left front caliper, rotor and pads this week. Anxious to see if this resolves ABS Fault warning. Tending to agree that this should be a GM recall after reading 13 pages of similar complaints...but not holding my breath that GM will do ANYTHING about it. Probably time to start looking at a Toyota.
1789101113»
Sign In or Register to comment.