Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Impala Climate Control/AC/Heater

1234568»

Comments

  • My AC works but if I have it on the max setting I get an unbearably loud clicking noise so I just move it down a notch below max setting and the clicking stops.

  • I have the same issue with my 2008 chevy impala

  • sgoodie66 said:

    I have an 05 Chevy Impala and the A/C works great but when heat is engaged I only get heat from the passenger side of the vehicle, regardless of the setting on the dual climate control...Others have the same or similar problem but no one can pinpoint the solution. Can someone please help???

    have u tried the air flow actuator, my 2005 impala doing same thing im gonna try this first
  • i have a 2005 impala, and the heater is not blowing hot air, I have checked coolant levels, and they are fine, bled coolant lines, not sure exactly how to back flush the system, or what I'm looking for on the actuators, I'm a single father of four and can't afford to put it in the shop. Please help.



  • monty5283 said:
    I am replacing the heater control panel on the dash since many lights are burned out. The replacement part only has 2 screw holes, 2 push in tabs, and one plug-in wire strip. I NEED TO KNOW HOW TO REMOVE THE HEATER CONTROL PANEL ! :( MONTY5283

    HeLPPPPPPPPPPPPPPPPPPPPPP
    I HAVE A PROBLEM WITH MY 06 IMPALA AC. SOMETIMES BUT OFTEN, WHEN I HAVE CAR TURNED ON BUT ON PARK OR AT A LIGHT, OR STOP SIGN MY AC STOPS BLOWING COLD AIR AND HOT AIR COMES OUT, AND THE LIGHT FOR AC TURNS OFF AND WHEN I PRESS BUTTON TO TURN ON AC ALL IT DOES IT BLINKS LIKE 2 OR 3 TIMES AND AC DON'T TURN ON, SOMETIMES IT DOES. BUT AC STAYS ON OR BLOWS COLD AIR ONLY WHEN I RUN THE CAR. WHAT COULD BE MY PROBLEM, PLS HELP. HAVE A 1 YR OLD DAUGHTER AND THIS AC PROBLEM IS WORRYING ME MOSTLY BECAUSE OF BABY, BECAUSE AC TURNS OFF RANDOMLY WHEN CAR IS AT PARK SHIFT OR WHEN I'M AT STOP SIGN OR LIGHT.

  • I have 2007 Chevy Impala SS and the heat blows hot on the driver side and cold on the passenger side. Also while I was driving the windows started fogging up and wouldn't clear unless I wiped them (it was like I was wiping water) Please help!!!
  • jayscangjayscang Posts: 1
    I have an 06 Impala SS- 122000 miles- a/c did not work- had diagnosed-bad compressor- also day before I brought it in for repair- radiator tank split... all warranty repairs but now after repairs- a/c works intermittently- light on a/c button flashes and goes from hot air to cold air- had dealer check-found some codes for loose connections- reset codes and all was ok for a week- now worse than ever... any suggestions?
1234568»
Sign In or Register to comment.