Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Lincoln town car - electrical issues

mickster7mickster7 Louisville Posts: 7
edited February 2017 in Lincoln
Shorted out the driver side door chime button , now I have no interior lights (dome lights etc) no power door locks, no power mirrors and my keyless entry(key fob) doesn't work. Checked all fuses and there aren't any blown. Is there a relay or something somewhere? Anyone have any ideas? If this is familiar to anyone please let me know.

Comments

  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,248
    edited February 2017
    How about the fusible links? Have you checked those? You may need to scare up a wiring diagram and see how these failed systems all connect, and at what point.

    THIS SITE might have the diagram.

    MODERATOR --Need help with anything? Click on my name!

    Share Your Vehicle Reviews Here

  • mickster7mickster7 Louisville Posts: 7
    Not sure of any other than between the battery and alt. Can you give me an idea of where to look for one that might control the dome, mirrors, power locks etc?
  • mickster7mickster7 Louisville Posts: 7
    Yeah I've got a repair manual and can read schematics but haven't found anything relating to my problems
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,248
    edited February 2017
    So the schematics don't show any inline fusible links?

    The symbol would look like this:



    The single or double lines indicate the duty rating for the fusible link.

    MODERATOR --Need help with anything? Click on my name!

    Share Your Vehicle Reviews Here

  • thecardoc3thecardoc3 Posts: 4,926
    @mickster7 How are you checking the fuses?

    The door locks and courtesy lights share several power supplies. Fuses 11 and 17 in the instrument panel fuse block should have power to and through them at all times. Fuse 6 should be hot in accessory or run, and fuse 8 should be hot in the run position.

    There is also a 30amp circuit breaker in the under hood fuse block. If those all have correct power to and through them, then testing would have to move to the remote keyless entry module behind the right side of the dash.
  • mickster7mickster7 Louisville Posts: 7
    As far as fuses I pulled each one and looked thru them, haven't resorted to checking the continuity yet, I have to say my brain is a bit scrambled with this because it seems like lots of little things are wrong all at one time. BTW, when I hit the power lock button it causes the headlights to flash. Several people have told me it seemed like the lighting control module but I can't find it on the car and my research leads me to believe only 95's and up had a LCM. I also have realized other on going problems I've had with it in the last few months such as: won't stay running during cold start without keeping my foot on the gas, digital gauges are out of calibration(except the trip/s, average econ, engine temp, and the ext temp) Over a period of 3days the battery went from useful to straining to turn the motor over, then it went dead and refused a charge(started it maybe 4x a day ech day and drove it plenty each time) so I replaced it. The anti-lock light comes on and beeps occasionally for no obvious reason , And it has lost 4mpg of my average gas mileage (of course that's according to the gauges, I use the average economy and trip to estimate how much gas I've got and it's correct 9 times out of 10) And my windshield wipers won't go into their "park" position down out of site when they're off. But they weren't working at all until about a month or so ago when I replaced the wiper module, I came across one at the junk yard so I grabbed it and they work fine now except for the park thing. So can you see why I've gotten a bit overwhelmed lol? I'm at the edge of my knowledge of auto electric so in a couple of weeks I'm going to put it in the app if I haven't figured it out yet.
    So just to recap the current issues:
    -no dome light
    -wipers don't hide when they're off
    -heater won't change to floor setting is stuck on upper vents only
    -no power locks
    -when I push the driver side door lock button it makes the headlights flash on
    -battery went bad seemingly all of the sudden but was most likely at the end of its life
    -no power mirrors
    -gauges are out of calibration
    -keyless entry stopped working along with the dome light, power locks, mirrors etc
    -diagnostic port doesn't communicate with testers(just remembered that) although it does seem to spit out codes with the paper clip method, going to attempt to test it later today after I take it to autozone to verify the port doesn't work properly. Seems to me like all these things have to point mainly at one culprit. If any ideas pop up let me know and we'll discuss it, Thanx for any input.
  • mickster7mickster7 Louisville Posts: 7
    One more thing, when I found the wiper mod at the junk yard I also found a keyless entry control mod (if that's what it's called) so brought it home and changed it but it didn't make a difference. Key remote still doesn't unlock or lock the doors.
  • mickster7mickster7 Louisville Posts: 7
    I'm going to check the voltage at those fuses next and it'll be sometime early this afternoon, and maybe it'll show me a problem I should've found already but wasn't thurough enough with early on, and hopefully I'll find a starting point for further troubleshooting. I think all I need is to get just a bit of clarity back so I can press on. In the meantime I'd still like to hear any thoughts or ideas so bring em on! And sorry that last post was so long but just had to get the info out there ya know......
  • mickster7mickster7 Louisville Posts: 7
    Fixed everything but the wiper problem, the # 17 fuse has no continuity thru it, it doesn't łook blown unless you hold it up next to a fuse that you know is good, had to use the voltmeter to find it. Looked at the fuses two dozen times over these past weeks but I should've put the meter on it to begin with. The only thing now is that the dome lights won't go off lol. Yes I've checked to make sure the dome light switch is off and all doors are closed, WTF? lol
Sign In or Register to comment.