Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Toyota Camry: Problems & Solutions

1679111299

Comments

  • snowmansnowman Posts: 540
    I think 3K is kinda early for max gas milage. If I were you I would wait until 5K.
  • edwardh5edwardh5 Posts: 130
    Does anyone know the name of the shock absorber looking device thats mounted atop the motor and stabilizes the Camry 4 cyl engine?On passenger side
    Its like a kind of motor mount but more to stabilize front and back motion. About 8 inches long - rubber grommets and bolts on each end.
  • tkl2tkl2 Posts: 6
    Edwardh5, the device you describe according to my Haynes manual is called a "Engine Moving Control Rod". It is a steel rod with rubber bushings on both ends inside big round steel eyes.It limits the front and back motion of the top of the engine, Hope this helps!
  • captainjcaptainj Posts: 31
    If I find anything out, I'll post it here, and many other places as well (that's the internet for ya).
  • Hi there,

    Well, I currently own a 95 Corolla DX and am planning for a used Camry, pre 1997, preferrebly a XLE V6. Before I sign on the dotted line, I will look into Carfax and other reports.

    Question: There is a 1993 Camry Le V6 with 75K and odd miles on the market now along with a 1996 V6XLE (which I am not interested 'cuz of cigarette odor in the car, otherwise this car looks great).

    Toyota tells me that they do NOT have the service information on their system and hence they cannot tell me about timing belt replacement and important stuff like that. They told me to talk to the original owner and then speak to their mechanic - this is out of question and cannot be done.

    Any advice or suggestions or comments??? Better yet, if you know anyone selling, let me know.

    Thanks

    S
  • 210delray210delray Posts: 4,721
    I'd say if you can't verify the timing belt was changed, along with other items at the 60K or 75K service intervals, then you'll have to assume they weren't done.

    Just figure that into the price you ultimately pay.
  • sebring95sebring95 Posts: 3,241
    I believe the manual on my 92 V6 recommends 80K mile changes on the timing belt. If that is also true on the 93 (should be, they are identical) good chance it wasn't done. Cost around $200. You may want to consider changing the water pump at this age also, probably another $125. I wouldn't hesitate buying that car assuming the price was right of course! My 92 is pushing 185K with only normal maintenance. We like it better than our 97 V6.
  • armtdmarmtdm Posts: 2,057
    I believe my manual says 60K timing belts.
  • wsommarivawsommariva Posts: 157
    My neighbor has a Corvette. His remote unlocks my doors. (2000 Solara) The dealer says they can't do anything about it. Any ideas? Is the dealer correct?

    Thanks
  • edwardh5edwardh5 Posts: 130
    Any idea how to diagnose this??

    94 Camry, 4 cyl, automatic 90k miles, - very very slight clunk noise from front on moving from a standstill, wheels pointed straight ahead. If you let the car move a foot or two and slowly mash on accel, no clunk. No clunk at any other speeds.

    Ideas??
  • wilcoxwilcox Posts: 584
    Just a guess. Otherwise driveline?
  • Hello Guys. I have a question concerning half shafts for a 91 Camry. (2.0 4cyl) I hear that there are 2 kinds of shafts for this year/model. What do I need to look for to differentiate between the two? Also how difficult is it to replace them?

    In addition, I need to know where motor mounts are located (the same vehicle)....Where are they located and what is the difficulty for replacing them?

    Thanks in advance!!!!
  • rjacobirjacobi Posts: 3
    I owned a 1995 4 Cyl Camry. I had frequent problems.

    Brakes:
    The most irritating problem was the groaning and grinding in the front brakes. I took it to the Honda dealer several times and he could not fix it. He finally told me it was caused by metallic brake linings (the government outlawed asbestos, he said) and there was nothing he could do about it. I finally turned the rotors myself and installed NAPA brake pads. No more problems. Are Toyota pads low quality? If I could fix the problem, why couldn't the dealer?

    A/C:
    The A/C compressor would rumble each time it came on. The dealer replaced the belt, tightened the compressor and finally replaced the compressor. Nothing helped. He told me it was because the government outlawed R12 and the new freon R134a made compressors rumble. I never could fix the problem. Never knew what was causing it.

    Smoking:
    The engine started smoking at 30,000 miles. The dealer replaced the valve guide seals. The engine started smoking again at 66,000 miles (I had a 60,000 mile warranty). This time he told me that it was my fault because I did not change the oil and the engine was sludged up. The engine was, in fact, full of sludge. I was able to prove by documentation that I had changed the oil and filter every 2500 miles. He claimed that the lube shop used inferior filters. I researched the issue and proved that the aftermarket filters were comparable to Toyota OEM filters. So, the dealer reluctantly fixed the problem again after I talked to the Toyota District Ombudsman about the problem.

    Rattle:
    The dash rattled. I had the dealer fix it several times, but it would return after about 8,000 to 10,000 miles. Never did figure out how to fix it permanently. The rattle was to the left of the driver near the door post under the dash.

    Transmission:
    The transmission started leaking at 40,000 miles. It was the pan gasket. I had the dealer change the fluid and filter and install a new gasket. About 6,000 miles later, it started leaking again. He tightened the bolts and it stopped. At 68,000 miles the transmission started leaking again at the gasket. Enough was enough. I sold the car.

    My question is this: Has Toyota owned up to any of these defects? Since I sold the car, I have learned that many people are having these same problems.
  • sebring95sebring95 Posts: 3,241
    The problem with the brakes was Honda pads on a Toyota. Or do you mean a Toyota dealer? I've had much better luck with Toyota pads than Napa so hmmmmmmm. I usually get 80-100K out of my front pads. The one time I didn't use Toyota pads (Napa) they squealed constantly so I put Toyota pads back on. Only hear grinding noises first thing in the morning which is normal oxidation from sitting overnight.

    Some of the 4cyl do have valve guide problems. The only thing it seems to do is smoke a bit during start-up. I've seen them with 200K and still doing the same thing so it's not like the engines about to blow up.

    I don't think any of your problems are big defect issues. You just got a somewhat problematic one. I mean they sell 300,000 a year and if it was a huge issue it would be very obvious. There is probably 2 or 3 million of these things on the road, you'd see them lined up on the berms. I've put over 400K on 3 different Camrys and have spent very little on repairs. Going to buy my fourth when the redesign comes out in the fall as long as I can get heated seats:)
  • 210delray210delray Posts: 4,721
    Seems like your problems weren't all that serious except the sludging. Recommend you re-post your story in "Engine Sludge?" It mostly concerns Toyotas. Yours seems to be the only one where sludging occurred despite frequent oil changes AND you actually got Toyota to pay for it. We'd love to hear more details.

    I had the blue smoke on startup and my valve stem seals were replaced under warranty ('97 Camry 4-cylinder at 57K miles). I had no sludge though.

    Auto transmission pan gasket leaked? How many cars of any make/model with auto trannies go more than about 50-60K without some kind of leakage ?
  • armtdmarmtdm Posts: 2,057
    My auto tranny in the 92 SE V6 I have does not seep or leak fluid. I have used synthetic since 25,000 when the filter was replaced, since then I just pull the plug and drain and fill every 30,000

    However, I cannot say the same about oil seepages. Valve covers which I seemed to have stopped by tightening the bolts but now may have a seal seepage but I have 132,000 on the engine.
  • yudyud Posts: 2
    I have a 96 Toyota Camry LE and recently I noticed that there is a creak sound coming from the whole interior body of the car, especially the front area, whenever I change the speed of the car or go over a bump. It seems to me that this strange sound didn't come up until the timing belt was changed by a toyota dealer. I am just wondering if anyone knows what the problem is. Thanks a lot.
  • fivespeedfivespeed Posts: 42
    That creak noise you hear may be cause by stress received from improper lift hoist application at service shop. Improper lifting can break body welds. When large uneven surface is encountered, the damaged frame will emit a "stress" noise.
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    Might be the pads that insulate the top of the McPherson struts...since you have no upper a-arms, the struts attach to the frame/body at their upper point and must flex at that point. So the "cup" or whatever various manufacturers put up there can wear out and you could get creaking, thumping, etc as the strut is stressed over bumps.

    Just a thought...one of many possibilities.
  • edwardh5edwardh5 Posts: 130
    My clump noise as I started off with a 94 4 cyl Camry on light throttle was a broken front motor mount, you could stop the car in gear and hold the brake and give it some gas and see the engine lift up. The dealer test drove the car with me and said thats it. They implied that they see a lot of these broken. Replacement is $110 for parts and 150 labor, $276 total. That fixed it.
    They probably fail since they sit right next to the exhaust pipe and get "cooked" all the time.

    Anyone else seen this problem???
  • Well, I think I am on the endless car search. I was going to get a 94 Accord, had financing done, and at the last minute the lady decided not to sell the car. So, off I was again, and I found a 94 Camry XLE V6. Green, leather, nice car. Drives great *much better than the accord did* and sooo quiet. The accord was 7400 with 110K on a 4 cyl auto. This camry has 103K on it. When I first went there, a salesman said 8500 for it, but they would prob take an even 8K.

    Well, I took it to the local toyota dealer to have it inspected. Nothing major, recommended the timing belt replaced which I figured ($250), tranny service (70), coolant flush (50), Top engine cleaning (70), and replacing the power antenna assembly (260). I don't really know if this car needed all this work now, except for the belt which is a definite. Well, I took it back and the new salesman I talked to would not go lower than 8K at all. So I told him I would see and give him a call.

    Well, I went to work (I work at a BMW dealership and I would get one from them, and could get a great deal, but all that ever gets traded in is 97 BMW's or so, which are just a little out of my range lol) to get a carfax and some advice. They're advice is to not buy this car from a "dirt" lot. . They said that this dealership gets most of its cars as the rejects for the major lots (and this one was bought from a Mercedes dealership in a near buy town). So, do you guys think this would be a problem car? Should I avoid it and just find something else, wait till someone actually trades in a camry for a BMW, or what? Any advice would be great!
  • armtdmarmtdm Posts: 2,057
    will not keep any car, even their own brand, on the lot with over 60,000 miles, they just wholesale it. So just because it came from a Mercedes dealer means nothing, the mileage is probably why they wholesaled it. At 103,000, timing belt only if not done at 90,000 but hard to tell. Also, if you are doing the timing belt possibly the water pump. Yes, tranny fluid should probably be changed also. Look for any oil leaks around valve covers, especially way in the rear on a V6.
  • nygregnygreg Posts: 1,936
    The 92 4cyl camry has two different shafts (with CV joints). Mainly they are different lengths. $65 each for remanufactured. Easy to install, however, when I needed to install mine I didn't have the time. Had them installed by local garage. Cost ~$325 including shafts. I assume you are hearing the clicking noise when turning sharply and accelerating. Hope my reply is not too late.

    -Greg
  • guevinjguevinj Posts: 15
    The driver's side seat belt on my '98 Camry is extremely uncomfortable to wear. The belt seems to tighten as I'm driving, like a vice grip on my chest. Loosening it manually does not help, as soon after, it is tight against my body again. I don't mean "snug", I mean "tight". The dealer has already replaced both front seat belts under warranty (they said there was a technical service bulletin on them and put in "longer length" seatbelts). When I complained they still weren't comfortable to wear, and asked if they could "adjust" the tension mechanism on them, I was told there was no such adjustment, that it was a self-contained unit, and that they would have to order me new ones AGAIN. Are they feeding me a line of bull? Has anyone else had this problem with '98 (or other year) Camrys? The dealer doesn't see the problem and are ordering me a new pair "just to satisfy me". I think the next pair is going to be the same way. I'm to the point now that the belts are just so uncomfortable, that I'm not going to wear them... and I don't want to do that. Help!
  • 210delray210delray Posts: 4,721
    The dealer is right about the tension mechanism - there is no way to adjust it (this is true of any belt).

    I suggest you try (test drive) other '98 - '01 Camrys and see if they are the same as yours. If so, then there's nothing that can be done, except possibly getting a "seat belt extender," free from Toyota, which is really intended only for people who are too large to fasten the belt.
  • airclareairclare Posts: 1
    I have a 98 Camry. I've seen a few references in the message board about a grinding noise when braking, which is exactly what I've been experiencing. I've also noticed several technical service bulletins on this on the NHTSB website. I took it to the dealer and because it was slightly over the 36K warranty, I had to pay $130 to have the rotors turned. Three weeks later, the noise is back. Besides the awful noise, and the fact that it scares passengers, is there a safety issue here? How many complaints must there be before they do a recall? Any effective strategies for getting a permanent fix (and preferably at dealer/manufacturer cost)?
  • edwardh5edwardh5 Posts: 130
    94 Camry.
    The light on the dash ( the one that has a symbol of a car with light coming from the rear of it) is on. It comes on when the brakes are first applied, and it stays on. The manual says this is caused by a brake light bulb being burned out - I have replaced both of them - what to try next?

    Any idea where the relay is that turns this bulb ob the dash on, is?
  • logitech1logitech1 Posts: 32
    Hello, guys:

    I am wondering how fast the speed meter can react when you apply
    the gas pedal normally? My 90 Camry V6 with A/T has shifting
    problem: up shift from gear 1 to 2 is not smooth. The harder
    you apply the gas pedal, the smoother feel you get. But you
    can still feel it. Except from 1 to 2, other up shiftings,
    include all down shiftings are normal. Is this so called harsh
    shift or early shift or something else?

    One symptom I find is the speed meter. I notice the up shift
    from 1 to 2 happenes when the speed meter points to zero (apply
    gas pedal normally), that is even the speed meter indicates the
    speed is zero (the real vehicle speed is not zero for sure), the
    1 to 2 up shifting happens! Is this normal for Camry? I checked
    my friend's 88 Prelude, when he apply his gas pedal normally, the
    1 to 2 up shifting happens at about 15 km per hour (according his
    speed meter). Is there a problem of my Vehicle Speed Sensor?

    By the way, how many speed sensors inside my vehicle? Some said
    one, some said two. one is inside the instrument panel, just behind
    the speed meter, and another one is on the transmission, is this
    correct?

    What I thought is there are mutlple controllers in charge of
    transmission shiftings. Speed sensor is one of them. if the speed
    sensor faild or misbehave, other controllers take over of shifting
    controls. Since the speed at gear 1 is slow, I can feel the shifting
    is not smooth.

    I guess something wrong with the speed sensor: normally, speed sensor
    senses the real speed, if the real vehicle speed is 10KM/hour, the
    speed sensor senses 10KM/h, and send the right signal (e.g. 2 Volts)
    to speed meter. But somehow the speed sensor is not working correctly,
    it senses 10KM/h but it sends the wrong signal (e.g. 1 volts) to the
    speed meter, or it senses 2KM/h and sends 1 volts to speed meter or
    other controllers.

    What do you guys think?

    Can you guys give me some idea about this problem?

    Thanks in advance!

    -Travis
  • logitech1logitech1 Posts: 32
    Engine type: 2VZ-EF
    Tranny Type: A540E

    do you guys know how many speed sensors inside my
    vehicle? Alos where are them? Can I just replace
    or take it off by myself?

    thanks
  • logitech1logitech1 Posts: 32
    I have a 90 Camry V6 with A/T. My car
    has trouble when it shifts from 1 to 2.

    Let me start with what the problem is: I feel the car shifts from
    1 to 2 is not smooth, very rough. other up-shifting and down-shiftings
    are just fine, not matter if the engine is hot or cold. I also noticed
    there is something abnormal of the speed meter. When the 1-2 up shifting
    happens, the speed meter needle points to zero, certainly, the real
    vehicle speed is not zero. after the 1-2 shifting happens, the speed
    meter needle just goes up like normal. is this correct or is this normal
    for a camry? I notice my friend's prelude (A/T), when his needle points
    to about 15KM/hour, then the 1-2 upshifting happens.

    as I said before, I found there are some articles talking about
    1-2 harsh shifting in this board. mostly like something wrong
    with the check ball inside the valve body, or bad accumlator spring or
    by adjusting thortte cable. So, I took my car to two AAMCO transmission
    dealership in Toronto. after they checked the vehicle, the first
    dealership told me, if I spend $300-$600 CADs, they can fix it, then
    I asked them to do it. guess what? they did what they suspect,
    but the problem is still there! anyway, they did charge me anything,
    and told me if I spend $1500 canadian dollars, they guarantee to
    fix it. The car is 11 years old, I just don't want to speed too much
    money on that. So I went away. This morning, I took my car to the
    second AAMCO transmission dealership, tell them what the problem is,
    and tell them what I suspect as well as what I found on the internet,
    damn, he just didn't listen to me, when I said I also notice something
    not correct with the speed meter, he responsed: "The internet didn't tell
    you this?". anyway, anothe guy checked my car, and said the transmission
    need to be rebuild, which will cost $1900 candian dollars plus other parts!
    then I told this guy is the valve body ok? is the spring ok? he said
    he tried to adjust shift timing, it didn't work. so he said the problem
    is not the check ball nor the spring, coz when he change the shift timing,
    the shift points should change, but they didn't change. do you guys think
    this is correct? BTW, he said he changed the shift timing, when I drove
    back my car to work this morning, I noticed the 1-2 up shifting is little
    bit smoother than before, also other up shiftings are kind of late, but that's
    my feeling, I am not so sure about that.

    I wonder can I adjust shifting timing by myself? Can I check my speed sensor
    by myself? anything else I can do before I send my car to another garage to
    repaire?

    AAMCO gave me a bad impression, because I have went to the second AAMCO
    transmission garage two weeks ago, after a short road test, the guy told
    me nothing wrong with the transmission...then after two weeks, I sent my
    car to them again, they said I need to rebuild my tranny for $1900+ to fix
    the problem...Damn, are they specialists? I will never trust AAMCO again
    especially the one on 2941 Eglinton.

    BTW, I did a simple road test according to Tony's suggestion in this board:
    put gear in "L", drive it to 20km/h, then shift the gear to "2", I feel the
    shock.

    any suggestions are welcomed!

    BTW, any of you guys from Toronto? can you suggest somewhere I can go to fix
    my tranny? It's too difficult to tell the mechanic what I think the problem
    is, they just don't want to listen to you.

    Thanks!
  • godfather2godfather2 Posts: 13
    Just bought an 86 Camry LE 5-speed with only 112k miles for $2200. Bought this car because, for some weird reason, I really like the boxy body style. IMO, it has a way cool vintage look to it. Anyway, do any of you have anything good or bad to say about this particular model year of the Camry? So far, I really like the way she rides. She's a strong runner with decent clean looks (for a 15 year old car). Hope to have her another 100k miles!
  • I have had the habit of filling my gas tank until it literally runs out. I've had Corollas, Camrys, an Avalon, and Toyota Trucks, all pre-2000 models, and have always done this. I recently bought a 2001 Camry CE and on two occasions after filling the car and parking, when I started driving the next day it has stalled, misfired, etc. Thinking the problem was water in the gas, I ignored it the first time and the problem cleared up in a day or so. On the second occasion I added water remover to the gas, but that didn't clear it up quickly, so I went to the dealer. He said with the new vapor system introduced in 2000, you could not "overfill" the tank, otherwise the sensors in the tank sensed gas going to the engine--when it really wasn't--thus resulting in power loss and fuel starvation. I still think it was a water in gas problem, but the dealer swears otherwise. And the gas station (a major supplier, not discount) where I purchase gas, not surprisingly, denied that anyone else had complained. Has anyone else had a similar problem with 2000 and above Toyota models?
  • 210delray210delray Posts: 4,721
    I'd suggest not letting the tank get too low, say at or below the empty mark, before you fill up.

    And when you do fill up, stop after the pump shuts off automatically.

    Then see if you still have the problem.
  • The dealer also recommended that I cut off the pump when filling right after the first click, or a few pennies after that to roundup. I do quite a bit Interstate driving and so as to get as far as I can on a tank I've always filled it to the rim. And while I've only had this car since late February I had never noticed the problem when out on the road. Perhaps it has something to do with filling it all the way up, and then if I park it for a day or two, and if it warms up, the expansion of vapor/liquid in the tank overtakes the sensors. That might explain why with Interstate driving I never see the problem because the gas is used fast enough such that the expansion is irrelevant, even if it does warms up. But I will stop overfilling just to see if that eliminates the problem.
  • paharganj1paharganj1 Posts: 3
    My 87 Camry stalls when there is humidity in the air. This generally happens when I drive for about 1-3 miles after starting the car for the first time in the morning and then have to stop at a traffic light. I can restart the car but it stalls many times before taking off. It seems to move slowly if I don't press the gas paddle but stalls if I try to pick up speed. I spent $300 on an engien cleanign and full service last year (plugs, wires, rotor etc) but the problem is back yesterday in rain


    Any ideas?


    http://www.SalesCircular.com - no more buying newspapers for store circulars

  • dleungnycdleungnyc Posts: 41
    Have you check the distributer? Sounds like moisture is getting into that area and shorting out the current to the spark plugs.
  • captainjcaptainj Posts: 31
    In case it helps anyone:
    I have been getting ~21 mpg average. It has something to do with a starting problem. When it starts, sometimes it sounds bad, I think it is leaking gas into the engine while it is sitting for long periods of time (like overnight), and then when I start it, there is extra gas in there so one of the cylinders isn't firing smoothly and thereby causing the engine to start up rough and sound bad. The low mpg correlates with the amount of times it starts bad. The mpg has come up to 28 mpg at times, and it almost always started normally. So, all the people telling me that 21 mpg was normal (4-cylinder automatic) were wrong of course. So, I think some kind of fuel injector seal is leaking slowly when the car is off.
  • dplachtadplachta Posts: 109
    I love my 1992 Camry LE V6, but lately the power door lock on the passenger side requires two or three button pushes to get the door to lock. I'd like to fix this and wonder if anyone else has had a similar problem.

    What part do you buy and how hard was it to install?
  • kyle25kyle25 Posts: 2
    The turning signals on my 98 Camry XLE blink extra fast whenever my headlights are on. It used to be just my right turning signal, but now they both act this way. They blink at normal speed when I drive in daytime with the headlights off. Does anyone know what causes this and how to fix this problem?
  • I have a 1990 Camry Station wagon (118K Miles) that has generally served me well until I got pulled over couple of days ago because my tail lights are not working. It seems that everything else lights up normally (side lights, headlights, etc.)and the brake lights work just fine. The bulbs were OK and the fuse appears to serve several other functions that all work. When I used a multimeter to check the bulb holder, there was no juice coming through on the tail light portion of the dual circuit (brake lights power up OK). I'm new in town and the local mechanic already charged me $26 and wants another $80 to just "check it out". Any ideas?

    Also, does this model have dual sets of brake/taillights? The owners manual sort of hinted at that (had two different diagrams) but I couldn't readily determine if a second set exists on the hatch next to the back up lights (and are completely on-working, including brake lights) or they are not relevant.

    Thanks for any help.
    MUR
  • quangtranquangtran Posts: 8
    Ever since January 2001, the rear valve top gasket of a V6 engine replace due to oil leak, the gas paddle has a fine vibrate like you have your feet on a motor shaver when the car running around 30-40 mile. I brought it in couple on week later and tell them about it and they said it is impossible that replacing the top valve gasket has anything to do with it. It turns out that the mechanic did not put the return break line hose correctly that let it rest on the gas paddle cable and other missing bolts. It was better after they fixed that. Now 2-3 month later I notice the car still has the vibarartion but a little less around the speed 40-60. This vibration irritated and make my feet numb. I am planing to bring it in but I was afraid they won't notice the vibration that I am talking about. I don't have confident with this dealer mechanic. I am not going to mention other small problems I had with this car. Anyway the same gasket is leaking again that I was schedule to bring it in again. This is the seven time I has to bring the car in for this gasket related problem.
  • armtdmarmtdm Posts: 2,057
    Yea, I have had this problem over the years but I have taken to torque the bolts myslef. Two rears ones are tough to get to but can be done with some arm twisting. Mine were amazingly loose and could almost tighten by hand. Anyway, currently not seeping oil.
  • I have a 92 Camry 4 cl. I am having problems similar to those described in mag #310, and #384. When turning there is a bump that I have to overcome (more than one if I turn sharply) and the steering does not return properly (I have to help it back to center), I found no responses to the previous messages and wondered if it was definitively the rack or the power steering pump?

    Has anybody got help on that one. Or have the previous 2 mag writer had theirs fixed. If so what was it.
  • Can anyone tell me when is the proper time to use the overdrive and when you should turn in off in an automatic V4? I'm assuming that since a light comes on in the dash when it's turned off, you're supposed to leave it on most of the time. Is that correct?
  • froto25froto25 Posts: 14
    The left signal has started blinking very fast on my 98 Camry v6 XLE. The fast blinking only occurs when the headlights or fog lights are on. I have looked for a burnt out bulb, but found none. Has anyone else had this problem and fixed it? Thanks.
    PS kyle25 have you been able to repair your signal? Mine just started doing this two days ago at 44,000 miles.
  • 210delray210delray Posts: 4,721
    Generally, the overdrive should be turned off (button depressed) only when descending longish downgrades to provide engine braking (that is the engine helps to keep the car from gaining too much speed), and reduces wear and tear on the brakes.

    I had the fast-flashing turn signal also (it was the left front bulb). I solved it by removing and reinstalling the bulb -- apparently it wasn't making good electrical contact.
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    Also you should turn overdrive off for city driving or on long upgrades. Overdrive is an economy gear, not a power gear, so if you are hill climbing in overdrive you are stressing the engine.
  • What maintenance should be done on a 1993 Camry at 200k miles? It is a 4cyl with a 5 speed manual tran. It's been running great
  • edwardh5edwardh5 Posts: 130
    The sludge freaks will tell you thats impossible - it must have sludged up by now.

    What was your oil change interval?
    And who did it?
  • 3000 mile interval on average for oil changes, though, I've only had the care since 140k miles.
This discussion has been closed.