Are you shopping for a new vehicle and having trouble finding one, or have you been waiting a long time for a factory order? A reporter would like to speak with you; please reach out to [email protected] by Tues. 5/11 for more details.

Engine dies when I turn off the climate control

tomthumb47tomthumb47 virginiaMember Posts: 1
edited September 2020 in Ford
Here's a weird one: 2004 Expedition. Runs great except when I turn the climate control off (the 12:00 or "0" position). Engine dies unless I immediately turn it back to heat or cooling.

Additionally, we either get great AC (with no temp control) or non-AC (HEAT), again with NO temp control. Doesn't matter where you set the temperature control, it either blows exclusively cold with the AC on, or blows HEAT with the AC not on - no in between.

Thanks for your input.

Comments

  • thecardoc3thecardoc3 Member Posts: 5,427
    The second part of your description is the easiest to confirm and analyze. You didn't specify if this is "automatic" climate control or "manual" but both systems share the same base strategy which is attempting to control to the desired temperature. The Automatic system lets you select the desired temperature with a specific numerical value while the manual system does the same thing but relies on what the driver feels. Either way loss of that control means the feedback system for temperature control has a problem and needs to be tested and repaired.

    The stalling/cutting out might be related in some fashion to the temperature control but it more than likely is not. All you really have provided at this point is information that a shop would need to go out on the road and attempt to experience the condition. In doing that what I would be looking for would be what is the commanded versus actual idle speeds? When the engine stalls does it cut right out or can I keep it running with the throttle? How does being in gear versus Park/Neutral affect the symptom? What is fuel trim doing during a stall event? Is there any other data that I can observe that would suggest it is related to the stalling? This information plus seeing if there are any trouble codes setting in any modules would be the basis from which to start analyzing the condition. If you could give me this information I could start to narrow the focus.
Sign In or Register to comment.