Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Mazda 626 Troubles

1568101150

Comments

  • Leaky valve-cover gaskets don't generally lead to greater problems, but the unwanted oil bath is not at all kind to the spark-plug wires, and given the cost of those wires, it might even be cost-effective to have those gaskets replaced.

    The G signal does interact with the pulse generator, so that seems plausible enough about the Hold light. (I thought NE1 was code 2, but I could be wrong.)

    Actually, given the exchange rate, that sounds fairly cheap for a distributor. Nothing makes oxygen sensors sound cheap, alas. :)
  • whackowhacko Posts: 96
    The "check engine" light has just lit up in my 94 626 and the mechanic did a diagnostic test and said that it was a "crankshaft positioner sensor" problem. What exactly does that mean and what could possibly be the worst case scenario regarding this problem? The non-dealer mechanic didn't really seem too sure how to explain it to me. I think it's because he didn't really know either is my guess.
  • This little gizmo reads the crankshaft rotation and sends its results to the engine computer, which uses the data to help determine engine timing. Basically, it sits outside the crankshaft pulley and watches it turn; there's about a 1.5-mm air gap between the sensor and the pulley. Since this isn't the only sensor in play, the engine might still be running fairly well, but you still probably ought to replace the thing. It's doubtful that anything else will happen as a result of this failure.
  • And, in the message currently numbered as 351, I was - NE1 is definitely code 4. Next time I'll read the table. :)
  • fromatozfromatoz Posts: 15
    Maybe not the right place to post my question, but I know you guys must know the answer.

    I often drive my car to beach with my girlfriend and she always likes to sit in the car and listen to the music - oh, it's Sarah Mclachlan's Angel and she repeats it again and again for hours. It's romantic, but sometime I have to worry about the durability of the battery. If it goes dead, we will be left there in late night without any help in close reach. Does someone here know normally how many hours a full-charged battery can run with only the CD player and speakers on?
  • izippyizippy Posts: 7
    Thank's for your advice, it's greatly appreciated.
  • sharon27sharon27 Posts: 3
    I just picked up my new (2000) 626V6 yesterday (yippee!). I like it as much as I did before paying for it, but on my way home on the highway the steering seemed to be acting weird. On a straight road there's about an inch of play in the wheel that I don't remember from my test drive. Is this simply a less tight steering system than I'm used to from my Jetta or is it a problem? If it's a problem, does anyone know if it's a common one?

    Thanks for any help or general advice for a new owner (other than to tell me I made a mistake, which it would do me no good to hear at this point).
  • qbrozenqbrozen Posts: 26,449
    An inch of play doesn't sound right at all. My '99 certainly doesn't have it. After 33,000 miles, my steering is still as tight as day 1. If nobody else here has a different experience with their steering, I would have the dealer check it out.

    '10 Equinox LS; '08 Charger R/T Daytona; '67 Coronet R/T; '14 Town&Country Limited; '18 BMW X2. 49-car history and counting!

  • haroldhx1haroldhx1 Posts: 14
    The problem came this morning. When I tried to lock the doors, I found the power door lock didn't work, and the car alarm couldn't turn on. Then, I found that the door-open warning light stays on even all the doors are closed tightly, and the radio and clock have no power to them. I am sure they worked fine yesterday. Previously, if I walked out the car without turn off the head light, there were some beeping sound to alert me. Now, there was no sound anymore. One funny thing is, if I turn on the head light, all the locked doors will pop released except for the driver-side one. I feel frustrated by this seven years' old car. Everything seems to go wrong during the last few days. Any help, please?
  • fritz1224fritz1224 Posts: 398
    You have been a great help to a lot of people on this board. I don't own a 626 but so what. You still have my respect. Hope you can put up with the uninformed and less than stupid questions.
  • Dear Sharon: There should be no slop in the steering whatsoever; get this thing back to the dealer and demand that he find out what's gone wrong between the wheel and the rack.

    My guess on Harold's new electrical woes is that the alarm system has gone south. Look how many things tie to it: the door locks, the door-open indicator, even the headlights (which blink if the alarm is set off). This doesn't explain the radio, exactly, but it's the best I can do without a circuit tester.

    Oh, and thanks, Fritz. Since I've owned two, that means between the two of us, we've averaged one apiece. :)

    And for the life of me, I can't figure out how long it will take to drain the battery without, um, actually draining the battery. I have gone about 55 minutes with no ill effects, but that's a long way from "hours".
  • izippyizippy Posts: 7
    In my case where the dealer says I need a new distributor, is it not possible to repair or must the whole unit be replaced.
  • Can't be done - at least, not for less than the cost of a new one.


    Trussville Mazda down in Alabama (which used to be Roebuck Mazda when it was somewhere else in Alabama) used to sell the ignition module, which is integrated with the distributor, separately - and by mail, yet. I dont know the current price, but its got to be less than the price of a whole distributor. It might not hurt to drop them a line - they're on the Web at www.trussvillemazda.com - and see if it's worth it to attack the problem piecemeal.

  • whackowhacko Posts: 96
    Should I gamble it? As I've noted in earlier posts, I've got a 94 626/V6 that I just bought w/99K miles. I don't have the service records so I'm not sure if the previous owner has changed the timing belt at the recommended 60K mark. Being that the 2.5L V6 engine is a "non-interference" engine, it will not bend the valves if the timing belt goes. Nonetheless, I would appreciate any opinions regarding whether or not I should go ahead and change the timing belt anyway, or just risk it and drive it until it snaps. By the way, are there any 626 owners out there who have been lucky enough to put more than 100K miles on the original timing belt?
  • nbpetenbpete Posts: 1
    Hi,

    I have a '97 626 LX (canadian) V6 2.5 litre.
    Sometimes, while pressing the accelerator, at low speeds, less than 80 km (50mph) an hour, I will hear a "rattling" almost vibration-like sound coming from underneath the car. The sound will stop immediately after I release the gas pedal or if I disengage OD (although sometimes it happens while OD is disengaged as well, but it always stops if I'm in OD and then disengage it).

    The problem seems sporadic. Sometimes a week will go by with no noise, and then it starts again. When I do have this noise, it only lasts for a few seconds, then will disappear for the rest of the drive.

    I'm concerned, but not worried. Should I be worried?
  • qbrozenqbrozen Posts: 26,449
    i haven't experienced this problem on my Mazda, but it sounds to me like you may have something loose on your exhaust. Maybe a heat shield, maybe a bracket. It is vibrating when you hit a certain resonance with your engine speed. Disengaging OD will change your RPMs, and, therefore, change the engine's resonance.

    Crawl under there and bang some things around and see if any of its loose. Sometimes that won't even help, though, because it may not be loose enough for you to move by hand. but, its worth a shot. If you find out that's what it is, its nothing to worry about, just annoying.

    '10 Equinox LS; '08 Charger R/T Daytona; '67 Coronet R/T; '14 Town&Country Limited; '18 BMW X2. 49-car history and counting!

  • I wouldn't risk it - even if the valves don't bend, you're still stranded. Besides, the manual in my '93 said quite clearly that the V6 was the engine likely to suffer damage if you didn't change the belt, and the '94 engines were unchanged except for emissions tuning, so I have some doubts about all those copied-from-one-another charts on the Web.
  • I see someone got to this before I did, and better still, he's probably right. This sounds very much like a loose exhaust component.
  • ian18ian18 Posts: 133
    Just wanted to relate my experience with my wife's 1993 626ES, 5 spd. Last year after having the engine light go on and off for about a year I replaced both oxygen sensors (at about 65,000 miles). Went with Bosch O2 sensors from carparts.com and they work great. WIth coupon, I got them for less than $50 each. The also seemed to be better quality than the OEM and have had no more engine code problems.
    Also had to replace the distributor at about 60,000. It was horrendously expensive, no alternative but from dealer. I have now seen that a rebuilt one is available from either www.expressautoparts.co or www.autoparts.com.
    Fortunately car has been troublefree since then, now at 80,000 miles.
  • whackowhacko Posts: 96
    Have you changed the timing belt in your 93 626 yet with 80K miles? If you haven't, is it because you feel confident that they'll last much longer than the recommended 60K interval?
  • ian18ian18 Posts: 133
    Yes, I had the timing belt changed at 60,000 miles as recommended in owners manual. There seems to be no choice and the Mazda dealer cost was not too unreasonable.
  • whackowhacko Posts: 96
    I just recently replaced the struts and CV joints in my 94 626. However, there is now an annoying and intermittent tapping noise when I make left turns. I know that there's a lot of "a-bone connected to the b-bone" stuff underneath the front end of the car. Could that intermittent tapping noise be the cause of something else that needs to be replaced?
  • qbrozenqbrozen Posts: 26,449
    See if one of the brake dust shields is loose. Interestingly enough, I just saw something like this come up on the Protege board and that was the cause.

    '10 Equinox LS; '08 Charger R/T Daytona; '67 Coronet R/T; '14 Town&Country Limited; '18 BMW X2. 49-car history and counting!

  • whackowhacko Posts: 96
    Actually, in regards to my post #372, it should read "clunking noise" rather than tapping. You can actually feel the "clunk" underneath the front end of the car when making a left turn.
  • The thing about front-end noises is, you get rid of some, you get to hear the ones that you couldn't hear before.

    "Brake dust shield" makes sense to me, especially since they're fairly easy to shake loose if you're working around axles. Besides, if you had any other serious suspension problems, they'd have tried to sell you the pertinent parts along with the new struts.
  • whackowhacko Posts: 96
    But wouldn't a brake dust shield make noise all of the time? The clunking noise I'm hearing is intermittent. It especially only does it when the car has been sitting awhile, like in the morning when I go to work. Then, when it warms up, it stops doing it. Very strange.
  • So when it gets warm, something's bigger than it used to be, and therefore doesn't fit so loosely, and therefore doesn't make the same noise.

    And let's face it, brakes produce a lot of heat, and it's gotta go somewhere....
  • sharon27sharon27 Posts: 3
    Thank you bgrozen and windophobe6 for you responses regarding steering wheel play on my new 626LX V6 5-speed. I took the car back to the dealer and discovered that the steering wheel had been installed off-center, thereby causing more play than there should have been. I was afraid I was going to get one of those "I don't see anything wrong here" (read: it's all in your head) -type responses, but they were very helpful. Steering is now fine.
  • goffda1goffda1 Posts: 1
    Can anyone help or have suggestions as to how to fix a window rattle? I have a 1988 Mazda 626 DX. The back right window has a constant rattle to it when driving on rough pavement, railroad tracks, etc... When you press on it from the inside, it stops. I had more than one person say that I needed to tighten the window on its track before it falls down completely and possibly break. I took the door panel off and I can only see to screws which tighten the window to the device which hold the window. Both screws just seemed to spin w/o tightening. Is there more to it than just the two screws? I would appreciate anyone's help as this is rather annoying and irritating. Thanks.

    Dave G.
  • qbrozenqbrozen Posts: 26,449
    I'm not familiar with the inside of the door, but if there are 2 screws that are supposed to be tightened in there and they are spinning, then they are stripped. If that's the case, then you have a problem.

    Did you try rattling the window when you had the door panel off? Is the noise coming from the bracket or is it coming from the top of the window where it is inside the track at the top of the door?

    If its at the top, then either the weather stripping in the window track is worn down, or its gone altogether. Replacing it should fix the problem. The new rubber will hold the window in place and keep it from rattling.

    '10 Equinox LS; '08 Charger R/T Daytona; '67 Coronet R/T; '14 Town&Country Limited; '18 BMW X2. 49-car history and counting!

  • mengilesmengiles Posts: 1
    Feb 00 had Transmission rebuilt
    Sep 00 had o2 sensors replaced
    Mar 01 transmission gone again...just got it back from the shop. That is near $4000 in repairs in a year. mileage is high (125k) ARGH.
  • tim110tim110 Posts: 1
    I just bought a used 95 626 4 cyl automatic. It test drove great. Ten days after I bought it the Overdrive off light began flashing and it began shifting very hard, almost violently, between 1st & 2nd gear. While driving I push the Overdrive button and it appears to be working as it downshifts at high speeds, so why the flashing? Before this went bad the light would not flash but stay solid when the overdrive was off. The transmission fluid level was a little low which I filled but there is no difference. My independent mechanic said that it did have a recently new transmission about 20K miles ago. The car only has 50K miles on it. Has anyone had this happen to them?
  • indydaveindydave Posts: 3
    I just bought a 2000 626 DX with around 30K miles. The RPM jump from 3000 to 3500 before shifting from 2nd to 3rd. Anyone else have troubles like this? Taking it to dealer tonight, any idea how long they might have it? Thanks.
  • Look again. (Or maybe that's the WebCrossing spell-checker up to its old trix; either way, Mazda didn't sell a DX version of the 626 in 2000, at least in the US.)

    A jump in RPM of this size suggests to me that the direct clutch, which cuts in once you hit third, isn't engaging as fast as it ought to be - or alternatively, the SS2 shift solenoid (I'm assuming this is the LA4A-EL tranny) isn't switching fast enough.

    On the other hand, at least with the four-cylinder, 3500 rpm is a good shift point. :)
  • This was the fourth-generation 626's way of telling you that something was screwy and the transmission was lapsing into fail-safe mode until you got it fixed: in general, either you had a transmission problem, or you had an electrical system problem for which the transmission was unable to compensate.

    Your first order of business should be to have any codes pulled. (The automatic 626 was switched to OBD II in '94, I believe, so you'll need a scan tool.) This should identify the crapped-out component, which could be electrical or an internal tranny part.
  • indydaveindydave Posts: 3
    Actually it is an LX not DX and I just got a call from the dealership, my car needs a new transmission, not just a belt or single part a whole new transmission. Am I justified in requesting a loaner car until my car is ready? I feel I am. Thanks.
  • They're not just going to hand you a set of keys unless you pester them about it. (2001 models have loaners covered under roadside assistance.)

    And it has been Mazda policy for some time to replace any transmission that requires any repair beyond a routine seal, pump or gasket replacement, even if it is only a single part that's gone troppo.
  • whackowhacko Posts: 96
    The intermittent clunking sound coming from underneath my 94 626 ended up being a defective CV joint that the tire company installed. They simply replaced it, and the problem is gone. Way cool...
  • I hope they ate the price of the replacement, too. CV joints, even rebuilt (and I swear by rebuilt), ain't cheap.
  • fromatozfromatoz Posts: 15
    A couple of times I shifted the gear from 'D' to 'P' or 'R' when the car still hasn't been fully stopped (in slow motion). And I can hear some strange noises from the gearbox if I do so. May I ask experts such as Windowphobe6 if this is harmful to the car?
  • On the other hand, it's not likely that you'd tear up the gearbox with "a couple of" incidents.

    There is a single reverse clutch (I'm using the CD4E as the example here, but others are similar) that engages only when the R position is selected, and all the other clutches are out of position. Of course, if you're not stopped yet, the other clutches aren't yet out of position. The results are pretty much what you can expect when you try to put two things in the same place at the same time.

    Shifting to P while moving tries to lock up all those parts, and if they're still moving, they will provide resistance, which contributes to wear, be it on the parking pawl or on the gearset. Neither of these is something you want.

    If you have to take the thing out of gear for some reason while you're moving, there's always Neutral.
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    yes, he's right, only I'd be even more adamant about warning you not to do that anymore! You will definitely break something sooner or later, especially shifting into Park...you're gonna break that pawl right off and depending on your transmission, it might be tough to repair while still in the car (dunno, never tried on that make and model).
  • haroldhx1haroldhx1 Posts: 14
    During my last 6-7 short trips, the checkengine light of my Mazda 626 4cyl car lighted up four times. At the first two times, I just ignored it and the light went off after 2-3 minutes. The last two times, I felt afraid, and stopped the engine and restart. I couldn't expect when it will come on, but I feel that when I push the gas a little harder at 2nd gear, it's likely to light up. I didn't feel anything unusual during driving. I went to four gas stations this morning. Some said they can find the problem only if the light stayed on. Some said it might be emission. In the last one, I asked the mechnic to help me pull out the code. But he couldn't get any code; and he suggested me go to Mazda dealer. I watched him when he did the test, I saw his equipment recognized my car from the VIN. I don't understand why it couldn't get the code. I am hesitating to go to a dealer. So, I am hoping someone may have similar experience with the CheckEngine light. Thanks!
  • haroldhx1haroldhx1 Posts: 14
    I forgot to tell you the year of my car in my last message.
  • haroldhx1haroldhx1 Posts: 14
    I forgot to mention another thing. There is indeed some leak on the pipe connected to the muffler. I found it yesterday when I went to do oil change.
  • The '94 automatics were supposedly switched to OBD II, while the 5-speed versions held out for two more model years. This matters because the pre-OBD II cars had both "memorized" and "non-memorized" codes, and if you happened to catch a code that wasn't memorized - say, an intermittent cooling-fan relay - you were out of luck unless the MIL was on at the exact time you were pulling codes.

    The following old two-digit codes fall into the non-memorized category, or at least did on the '93s:

    25 (fuel pressure regulator)
    26 (purge control)
    28 (EGR valve)
    34 (idle speed control)
    65 (torque-converter lockup solenoid)
    67/68 (cooling-fan relay)

    Maybe this will narrow it down somewhat....
  • haroldhx1haroldhx1 Posts: 14
    Thanks, windowphobe. I went to the Mazda dealer today, they told me I need to replace the airflow meter. I didn't do it yet since it's too expensive (the part itself costs $270). Anyway, after I tighten up the gas cap (as suggested in the Check Engine Light discusiion board) , the CLE light didn't come up on my way to the dealer and back, which totals 15 miles including a little highway.
    I noticed that Msg#20 also mentioned air flow meter broke down. I am thinking of purchasing the part myself from some online store (I remeber someone talked about this in this board), and asking some mechanics install it for me. Or could it be possible that I install it myself?
  • haroldhx1haroldhx1 Posts: 14
    In my Haynes Repair Manual, I couldn't find such a thing as Air Flow Meter. What I found is Mass Airflow Sensor. Are they the same thing??
  • One to a car. By convention, if it's a "sensor", it's the kind that runs off a heated wire; a "meter" has a door or cone that is pushed open by actual air pressure. Personally, I've always called them "meters", simply out of force of habit, but what's in the 626 (since '93, anyway) qualifies as a sensor.

    It's fairly DIY-able, I think; you need to pull the intake hose, detach the wiring, remove some bolts, and pull the thing off the air-cleaner housing. Rocket science, it isn't.
  • whackowhacko Posts: 96
    Well, here's the deal. When I bought my 94 626 with 99k miles, I wasn't sure if the previous owner had replaced the timing belt at 60k miles. Well rather than risking it, I decided to have it replaced anyway along with replacing the water pump as well. After the job was done (I bought the parts myself for $65 combined and my mechanic charged me $200 for labor)-- I wanted to see the old timing belt. Sure enough, the previous owner had it changed and the old timing belt looked just as new as the new one I replaced it with. Oh well, atleast I did the water pump because the old one was still the original part. But overall, I'm not upset about replacing a part that didn't need to be replaced. I instead paid for peace of mind and I can now confidently drive my car worry-free for the next 60,000 miles until the next timing belt replacement.
Sign In or Register to comment.