Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Quest/Mercury Villager problems

18889919394115

Comments

  • marku1marku1 Posts: 11
    I have had the motor mounts replaced by the dealer under warrenty once. I have replaced them myself once and currently need to do it AGAIN! (along with the transmission mount) There is no trick that I know of to prevent them from breaking, at least the work is fairly quick and easy. Do not worry about dealer or after market quality because the parts store mounts lasted longer than both of the dealer sets.
    Good luck,
    Mark
  • michjoymichjoy Posts: 1
    Ok I need some help here. Not only is my speedometer not working on my 2000 mercury villager but i took it to a friend who put it on the computer and my speed sensor is bad ah duh that is why it doesnt work and a bad knock sensor. Now this is all greek to me. I have had many problems since we have bought this used 2 years ago and my warranty is up (of course) and I have no idea what to do. My gas pedal sticks, brakes have gone out on me twice and have has issues with the ABS system. I have put so much into this and I am like most people tight on cash. Anyone know what I am goin through?
  • quicklinequickline Posts: 2
    I recently purchased a used 2000 Mercury Villager and the Cruise Control does not work. I looked at it and it is definately different from any cruise control I have ever seem. All of the relays are internal and the vaccum tank is seperate from the main unit. I have been unable to find any wiring diagrams which specifically show the electrical circuits associated with the cruise control unit. Any ideas? or troubleshooting ideas. Thanks
  • quicklinequickline Posts: 2
    You need to find some electrical wiring diagrams specifically for your 2000 Villager. It is a different bird from previous models and has some different wiring than you would expect. Buy some heavy duty brake pads that has good heat dissipation. Also replace both front and rear brakes at the some time. Lubricate your gas pedal linkage with WD-40 both inside the vehicle and under the hood. Also check to see if the spring that returns your pedal to its normal position is broken or weak. It is located on the engine. Knock sensors do not typically fail, they just get covered with carbon. So remove the sensor and clean it. Good luck
  • Our 2002 Villager has a bad vibration upon braking. I pulled the front wheels today to take a look it. The pads have a lot of life left, and the rotors 'look' fine.
    They don't cost much, so I think I'll put some new rotors on.
    Seems rotors can't be re surfaced like they could 20 years ago.
    I see two Torx bolts on the back of the calipers.
    My question is: what is holding on the rotor?
    Do I need to remove the wheel bearing bolt?
    Any advice appreciated, I don't have a manual for the van.
  • buggles57buggles57 Posts: 1
    I just purchased a used 1999 Mercury Villager Estate. The vehicle only came with one remote control, so today I visited the local Lin. Merc. Dealer and bought a 2nd remote. The mechanic's however could not program the remote, even after several tries. What the did was put the key in and out of the ignition 6 times and then said they were to hit the unlock or lock button to program it. However after several attempts, the remote still remains unprogrammed and unusable. Is there anyone out there that might know the correct way to program this remote? Any help would be greatly appreciated. Thanks Ü
  • kymikekymike Posts: 115
    1) While inside the vehicle, close and lock all the doors.
    2) Insert and remove the key from the ignition at least 6 times within 10 seconds to enter the programming mode. The parking lamps will flash to indicate that the programming mode has been entered.
    3) Turn the key to the accessory position. All previous key codes will now be erased.
    4) Press any button on the remote transmitter once. The parking lamps will flash twice to acknowledge acceptance.
    5) to enter additional remote transmitters, unlock and then lock the driver side door using the master window/door lock/unlock switch.
    6) Press any button on the additional transmitters. The parking lamps will flash twice to acknowledge acceptance.
    7) Open the driver door to exit the programming mode; the parking lamps will flash twice to confirm exiting the programming mode.

    Good luck! Report back if this works.
  • steverstever Posts: 52,683
    It's been a few months since I had mine off my '99 Quest, but once you remove the Torx bolts and move the caliper out of the way (C-clamping the piston), the rotor will slip right off. Ok, it may take some gentle nudging with a mallet. You don't need to remove the wheel bearing bolt.

    Most rotors can still be turned once I think, but it may not be cost effective.

    Try a Search This Discussion in here too.

    Steve, Host
  • I purchased a 1997 Mercury Villager with 130,000kms but there is a problem...While driving there's a 'thump' as if I hit an invisible bump in the road..Transmission code 0745 comes up, and the 'Service Engine' light is constantly on...Please HELP!! :confuse:
  • I have a Nissan Quest 2001 and i would like to know if i can put 17 or 18inch rims from a Maxima or Altima on it. Want to stay stock Nissan if possible.
  • jblake3jblake3 Posts: 2
    Went to Brakes Plus. Super helpful. My rear brakes were fine. what was broken was a rod that
    attaches to the proportioning valve that senses the weight of the load I'm carrying and adjusts rear braking accordingly. The mechanic at Mercury dealer saw that part was broken and probabily assumed I had no rear brakes.

    For $21.50 brakes plus cleaned up the brake dust, adjusted the rear brakes, and saved me $360.00.
    on the cost of parts and labor for a new proportional valve.
    Thank you brakes plus!!!

    John
  • fstavinsfstavins Posts: 1
    I am unable to turn the key in my 2001 Villager. Anyone else ever experience a total key paralysis?
  • sschmidsschmid Posts: 28
    My 93 villager oil light comes on about once a week. If I shut off the car pull over to check oil (which is fine) Oil light is off when I re start the car. My mechanic who is too busy to check it right now said it is probably oil pressure switch. My son can change it for me but where the heck is it! If any one has a haynes manual it will probably have a diagram. Any thoughts would be appreciated
  • sschmidsschmid Posts: 28
    I have had to replace mine twice (two different mechanics about 160 each time and now it is acting up again seem to last about 65K. Can anyone tell me how to change it myself. for a $35 part I am getting tire of paying $160 to fix it.
  • sopmansopman Posts: 46
    Neither one of my power adapter (cigarette light) works and I can't find the fuse. There's a fuse box next to the battery, but it wasn't in there. Does someone know where this fuse might be located?

    Sopman
  • Hi, I have a 94 Villager where the tumblers in the ignition are shot. The key sometimes binds so that you can't turn it without a lot of fiddling around.

    I purchased a new lock cylinder assembly that comes with 2 keys which appears to be just the thing I need.

    Problem is I'm not sure how to remove the old one to replace it. I can easily remove the lower part of the steering column plastic housing cover, But I'm not clear on how to remove the upper part which actually surrounds the ignition. Also not sure if this even needs to be removed as there is a small notch in the housing that may allow removal of the lock cylinder.

    Can anyone provide the tip needed to remove/release the old one from the steering column? Is a special tool required?

    Thanks in advance..
  • van93van93 Posts: 1
    my 93 villager has a similar quirk. Caused by the starter sticking slightly past the "on" position. Try backing the key position back to "on", from "start", after you start the vehicle. In my van, the oil light is signaling the "start up" sequence, not signaling problem with oil pressure. Not a problem, once you are familiar with it, but if I lend out my car, other drivers get a scare.

    Might be related to the "key paralysis" problem reported in thread above. Might also be related to the ten pounds of keys I have dangling from the ignition...
  • jmarchjmarch Posts: 1
    engine races when I start in drive..not a smooth transition to the next gear...when I purchased it, I was informed that this is normal. Is it ?
  • jr714jr714 Posts: 24
    According to the Haynes Manual, after removing the steering column cover you have to remove the the knee bolster and reinforcement panel. Then you turn the ignition key to 'on' (battery should be disconnected!) and use a drill bit or small screwdriver to push up on the retaining pin while you withdraw the lock cylinder. Be sure to catch the small spring that pops out as the cylinder is withdrawn from the housing.
    The photos in the book show this being done without the steering wheel but that may have been just to get better shots of the procedure.
    I have never done this so I can't tell you for sure it will work. But Haynes is usually right : )
    Good luck!
  • jr714jr714 Posts: 24
    Steve, or anyone knowledgeable on the '99-'02 models, do you know if the second row captain's seats can be removed and safely replaced with a bench seat?

    More specifically, do they all have the same seat slots in the floor? Will the bench seat line up correctly?

    Any info would be GREATLY appreciated since I'm in the process of buying a Quest and I really need that 2nd row bench, but I really want all the features of the SE/SEL model.
This discussion has been closed.