Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently tried to purchase a new vehicle after being out of the market for a while and found that prices were much higher than you expected? A reporter would like to talk to you; please reach out to [email protected] by 1/22 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

92 GMC Conversion Van please help

squonk240sxsquonk240sx Posts: 1
edited May 2014 in GMC
There is something causing the battery to drain. After 48 hours the battery will be dead but it can be recharged enough to drive. If I unhook the battery it seems to solve the issue because it will still have juice left to restart the vehicle.

Yesterday, while I was driving, the van just shut off. I noticed that the power antenna was on the fritz and kept going up and down.

Does anyone have any idea what this problem could be?

Comments

  • A bit late on this one but, I have a 1990 GMC Conversion van with the 5.7l v8

    I also have the drain issue. Some other sites pointed to problem with GMC and the stock radio drawing more power. I dont have a radio installed but pulled my horn,cig lighter and accessories fuse which seems to slow the problem. In the end though I like you have been disconnecting the battery.

    Im going to have it looked at in the coming weeks and will reply with the found issue if any.
  • dimocksddimocksd Posts: 1
    I have a 1993 Starcraft Conversion Van, high top. The original TV does not work and would like to purchase a replacement, so I can use the sound system in the van. HELP
  • havoc72havoc72 Posts: 1
    bad news the wiring harness plug at the fire wall is melting, sadly you can take my word for this, the water off the roof gutter comes down under the hood and right around the plug. I was forced to replace it with individual connectors messy but its run fine for four years
This discussion has been closed.