Toyota Sequoia Window Problems

jimmydnscjimmydnsc Member Posts: 6
edited December 2014 in Toyota
Rear window wont go down. Makes a lite noise when you push the window button on the dash. Whats the problem?
«1

Comments

  • jpoelmanjpoelman Member Posts: 1
    I have the same problem with my 2004. A couple weeks ago I removed the interior panels, tapped on the motor with a hammer and it started to work. Failed again today. The noise you here is the motor clicking so it's getting power. Repeated tries to get the window to move made the motor get warm, another indication it's getting power. Your window motor, like mine, needs to be replaced. I found new after-market motors on E-Bay for $75 with free shipping. Not sure how to replace it yet. It appears you remove the motor mounting screws with a torx bit on a ratchet. They're on the back side so space is limited. Remove the motor and install the new one. At least I hope it's that simple. If there's more to replacement than that I'd appreciate hearing from someone who knows.
  • dotratdotrat Member Posts: 1
    This seems to be a very common problem with Sequioas. I have an original 2001 and I try using the rear window as little as possible since it slipped off it's tracks a couple of years ago. The motor has sounded like it's on it's last legs since then.

    I just traded in my 2001 for a 2006 and when I tried the rear window on the new truck it fell off the track on the first try. The dealer is going to fix it, but I think the heavy rear window is just a bad design.
  • jimmydnscjimmydnsc Member Posts: 6
    Toyota center replaced rear window motor and ecu. part #'s(89222-0c021) (85710-0c070) (90269-05035) set me back $100 from goodwill warranty.
  • disappointdmomdisappointdmom Member Posts: 1
    I have a 2005 limited that I bought new. My rear window has quit as well. You can hear the motor clicking but it does not move! I've had it with electrical issues with this vehicle! I just got thru an ugly battle with the local dealership and Toyota Corp. about a computer issue that the dealership failed to find under warranty. I finally started taking pictures of the lights coming on and was taken seriously. Of course, they finally found it now that is out of warranty and having the "master tech" finally look at it. It could be fixed for $2330! Toyota finally agreed to pay $1500 and the dealership paid $600. This is my first and last Toyota!
  • cbmorris10cbmorris10 Member Posts: 1
    My rear power window, rear window defrost and rear window wiper don't work. The fuse is ok. The rear window defrost button on the dash does not light up. I believe the window is all the way up. Any ideas what could be wrong? Any help would be most appreciated!
  • jimmydnscjimmydnsc Member Posts: 6
    I think you have a bad ecu and maybe the window motor also. I had new ones installed in mine and now the window rolls down and wiper wipes.
  • seq200246seq200246 Member Posts: 3
    I also had this problem with my 02 Sequoia at around 32000 miles and no warranty coverage. According to my leasing agency mechanic (who relaced the motor for a mere $538.00) this is a known problem with Sequoias. It is caused by insufficent insulation/baffling that allows water to get into the motor.
  • redzeroredzero Member Posts: 1
    Toyota is aware of this problem but not done a recall. Instead they've taken money hand over fist in doing repairs. See the Technical Service Bulletin June 14, 2006, "Back Door Power Window Inoperative." http://www.justanswer.com/uploads/skyvisions/2008-02-25_151840_01_seq.pdf , the repair cost me $500. When I contacted Toyota Corporate about why this was not recall covered no response to multiple inquiries. A class action suit may be all Toyota understands. It was the windows then and the accelerators today. :sick:
  • 4whit4whit Member Posts: 2
    Have the same problem with my 04 my rear power window, rear window defrost and rear window wiper don't work. The fuse is ok. The rear window defrost button on the dash does not light up.Some one said something about bad ECU?Sorry do not know what that is. Could I replace it myself or do I have to go to the dealer. Any info would be great. Thanks
  • jimmydnscjimmydnsc Member Posts: 6
    www.justanswer.com/uploads/skyvisions/2008-02-25_151840_01_seq.pdf
  • jtjjtj Member Posts: 1
    I am wondering if anyone has comments regarding what causes the rear defrost, window wiper, and rear window not to work. It seems that if all three fail (as is my case), no power should get through. What has me puzzled is the click that can be heard when you hit the window switch. To me this indicates the motor is getting power and just needs to be replaced. Can a faulty motor stop power from getting to the other two items? Or is the click actually coming from the ECU, not the motor. I have a hard time telling.

    Thanks for all the info folks. It has been a great help.
  • jimmydnscjimmydnsc Member Posts: 6
    Had the same problem. Dealer replaced ecu and motor. All is good now.
  • sgoodsonsgoodson Member Posts: 10
    I have a 2005 Toyota Sequoia that had the Technical Service Bulletin repair for the inoperative rear power window done at about 30k miles. The problem occurred again at about 32k miles. Then the dealer wanted $600 to fix it again. The rear window / defroster / wiper problem has occurred on the 2001 thru 2007 models. It was a simple fix which could have been done at the factory by removing two bolts and a small gear "braking" device that malfunctions. In my opinion, this issue should have been a factory recall, but it seems Toyota continued to install these defective parts and let the dealer fix the problem later. If you were one of the unlucky people that got caught after the warranty period, like me, they don't care. I drove my Sequoia for two more years before looking on the net and finding the 4/28/2010 Toyota Technical Bulletin. You can find it here:

    http://www.toyotapart.com/Back_Door_Power_Window_Inoperative_TSB011510.pdf

    I was able to fix my power rear window problem and the inoperative wiper/washer and defroster. I set up a website with photos and notes to show how I did it. I hope this helps.

    By the way, I am really upset with how Toyota has handled this problem.
  • sgoodsonsgoodson Member Posts: 10
    Sorry, here is the website with photos of how to repair the rear window problem.

    http://www.piranamedia.com/toyotawindowrepair/

    Steve
  • skimodeskimode Member Posts: 1
    Thank you for posting this info....Unfortunately I feel the same way.....
    My dealer is asking for $1,005.00 to fix the back window/defrost/wiper issue, on a 2007 model and I'm only 31 days out of my waranty with only 19K miles on board and just like you've mentioned, nobody cares, Toyota's main office or the local dealer.
  • vfr182vfr182 Member Posts: 2
    Thanks very much Steve. I have had off and on rear window failure for the past 3 years. sometimes it worked great sometimes wouldnt move once closed. failure kept getting longer and longer and i decided to try to fix it. I have owned my 02 since it was new and it is babied. dealer tried to hit me for $800 2 months after they hit me for $600 to replace the crappy rear latch handle that fell off in my hand. Anyway your photos and the Toyota PDF were of great help. My 7 year old son and i took about 30 minutes to get this working 100% with no money, first time a repair on this thing was free. Otherwise dont know about you but my sequoia is bulletproof as long as i keep replacing brake pads and tires and oil changes. thanks again and take care.

    Steve
  • ricster1ricster1 Member Posts: 1
    edited September 2010
    Steve, A most excellent tutorial on how to fix this. I have a quote from the largest Toyota dealership in San Diego for 975$ to replace the ECU and window motor. Your info had it nailed down perfectly (especially about resetting the ECU, turning on and off the rear defroster) . I had to remove the faulty 'break' part. Total time about an hour and I am hardly a mechanic. Thanks again.

    ps There is a good youtube video on how to replace the rear door latch. When it rains it pours.
  • flyfisher11flyfisher11 Member Posts: 1
    Steve, My 2002 Sequoia rear window stopped working about 6 months ago and I've been delaying the repair due to the cost. After reading your post I removed the "braking" mechanism and then re-set the ECU module, now it works perfectly ! Thanks for saving me $600.
  • awolfefotoawolfefoto Member Posts: 1
    I really appreciate the time and effort you put into this in order to help other folks out.

    Thanks, AJ
  • dteskedteske Member Posts: 1
    I own a 2002 Sequoia and starting having problems with rear tail over 5 years ago. When the vehicle was covered under warranty they took care
    of it. Well now its my problem. The rear gate does not open, window does not go up or down. The rear wiper does not work. the dealer wants over $1000 just for parts another $600-$700 for labor. This vehicle should have been recalled. The rain gets into rear regulator and now everything is rusted. I am in proces of buying used parts and will have friend fix it myself. Dealer knows its a problem but refused to address it. I refuse to sell it until I fix this problem. Any suggestions would be helpful
  • rafemanrafeman Member Posts: 1
    Hi,

    I seem to be suffering the same problem that is being addressed in this thread but it appears that sgoodson's website at piranamedia.com is not accessible; I keep getting a 404 error.

    Is this information still available?

    If not, from what I am reading, it appears that I do not necessarily need to do what the toyota tsb says, namely replacing the ECU; is this true?

    In the absence of any data from sgoodson's website, does anyone have any other hints?

    Thank you!
  • sgoodsonsgoodson Member Posts: 10
    Sorry, but the link for the repair photos has changed as follows:

    http://69.175.10.122/~piranam1/_ToyotaRearWindowRepair/

    Hopes this helps.

    Steve
  • tiffrox81tiffrox81 Member Posts: 1
    Thank you SO much for your advice!! Me, being female, and not too mechanically inclined, would have spent the $1k fixing this through the dealer. Thanks to your super handy tips, my boyfriend was able to fix this, and all we're out is $10 for the part to pop off the interior frame! Everything works like a champ, again.

    One tip - I quickly realized the window was working again, but without putting the window all the way down, the other two systems weren't working. Be sure to roll your back window all the way down, then your defroster and wiper should work!
  • toyobobtoyobob Member Posts: 1
    I read your post and resent the unit. Thanks!!! All but the window now work. I'll take the brake out when I get home. I called Toyota and was told it was the computer or the motor, both of which are expensive repairs. Resetting the unit was NEVER mentioned. Thanks!!!!!
  • jebojebo Member Posts: 1
    Steve....add me to the list of people you've helped. My story is exactly like most others. I reset the ECU, wipers work, window heat works and then I removed the brake and the window now works. Unbelievable!!! Thank you for taking time out of your life to help your fellow Americans. Your Awesome!!!!!

    Keep it real!!
  • jazzhead07jazzhead07 Member Posts: 1
    I am dealing with the same issue. I fixed it once...than it stopped again. I will invest the time to replace the motor myself...it looks pretty simple. I replaced the rear latch today...not bad..about an hour total. There is a YouTube video on this...I watched it once...and fixed it. I got the metal latch from eBay for $30...I plan to fix my rear window this week...I will update you with my finding...it could be the break, motor or ECU...
  • ki5320ki5320 Member Posts: 1
    edited July 2011
    thank you, everything work like a champ, my wife is very happy, I have this problem for year,
  • muisemuise Member Posts: 1
    never had a problem with back window till last weekend it had a mind of its own.It would go down while driving and the locks kept clicking off.now the window is down and it wont go up.anyone else have this happen?
  • gatruckgatruck Member Posts: 2
    Thank you so much for this post! I own a 2007 Sequoia and rear washer, defroster and power window quit working. I took it to Toyota dealership and they advised me that I needed rear window motor @ cost of approx. $600. While visiting Indianapolis, I took to another Toyota dealership. They too advised me that I needed rear window motor @ cost of $580.77. When I returned to pick up vehicle from that dealership, THEIR technician had hit a fence in my vehicle and demolished the passenger rear fender, side running board, and scraped the rear door handle. Initially tried to claim that my vehicle was already like that. They finally owned up to doing it, got me rental vehicle and repaired damage. Kept my vehicle for 8 days! After all of this, they refused to throw in repair to rear window (pictures forthcoming). After researching, I ran across this site and tried it. The windshield wiper and defroster works great! Window still not working but will finish repairs using your information. Had I seen this first, could have saved myself lots of headache. Thanks so much!!
  • chrisgdellchrisgdell Member Posts: 2
    Thanks for the post. I recently purchased a 2005 Sequoia. I followed your instructions to discover that the "brake" has been removed and the problem still exists. Here is where i am confused... When I reset the ECU by holding down the rear window button, it does turn the wiper and defrost option back on. But the window is still not operative. Plus, when I push the rear window button (after the reset) I hear a click in the back and that then causes the defrost and wiper functions to stop working. So, does the motor or ECU need to be replaced? Or both, please help. Thanks. :confuse:
  • sgoodsonsgoodson Member Posts: 10
    edited October 2011
    Well, you now know that your ECU is working and not burned out because the wiper and defrost start working again after a reset. You said that after the ECU reset when pushing the rear window down button, you can hear the ECU unit "click" and everything stops working. Are you sure that the front and rear portion of the brake are removed in addition to the two bolts and spring? If they really have been removed for sure, the window may have been wedged too tight and locked into position. Have you tried to manually lower the widow glass according to the instruction bulletin? I checked mine before closing everything back up just to make sure it moved freely. You can see how to do this on Number 11 of the Technical Bulletin. You may also want to check to make sure there is nothing that fell down between the two gears causing a wedged obstruction. If none of the above works, your problem could be that the power window regulator is bad and maybe even the motor. The Technical Bulletin Number 12 shows how to remove. You could try replacing one at a time until you find the problem. The parts can be found using Google search. Be patient. Hope this helps. Technical Bulletin PDF
  • chrisgdellchrisgdell Member Posts: 2
    IT WORKED! Thank you so much for the extra hint! I opened it all back up and followed Number 11A of the Tech Bulletin. The window was jammed. Because of the jam it was not easy getting the regulator bolts out of their holes. There was a lot of tension pulling it down. Once I got the regulator free from the door frame, I then had to power the window down. This gave me room to put the regulator back in place without the tension. Everything is put back together and working great! Again... thanks! :D
  • toy4cintoy4cin Member Posts: 1
    I have had the same problem but only with the rear window not rolling down. I can push the button or use the key and hear the motor but nothing happens. Can't wait to try your instructions this weekend and see if I can get it working. Thank you for your post. Other than that, I love my car and will drive it til it dies....
  • ergobobergobob Member Posts: 1
    Ok, I read where several of you have said you reset the ECU. I can't find the post on how to do it. Help.
    Thanks
    Bob
  • steverstever Guest Posts: 52,457
    Dead link?
  • sgoodsonsgoodson Member Posts: 10
    Sorry about the bad link.
    I did some maintenance on my server and inadvertently deleted the files.

    Here is the new link:
    http://www.piranamedia.com/_ToyotaRearWindowRepair/

    Steve
  • steverstever Guest Posts: 52,457
    Thanks! (Had someone emailing looking for help on that).
  • grinnellgirlgrinnellgirl Member Posts: 1
    Thank you so much! I don't care about the window but the rear defrost and wiper bothered me - it worked. That was so easy - had to try a few times - up then down then up again but the defrost and the wiper and wiper fluid all work now. THANK YOU!!!
  • wow6wow6 Member Posts: 1
    Hey thank you also so much!!!! I've had this rear window problem for over a year and the dealer told me it would cost over $550.00 to fix. I was just surfing the web to find the cost of replacement parts when I came across this discussion. Read the info and when out side and BANG' my ECU was reset. Why did the dealer not do this??? I'm calling them in the morning. The window still is not moving but I will work on that next weekend. With spring rains around the corner I am happy to have the defroster and wiper working again. Keep up the GREAT WORK and THANKS AGAIN.
  • dprimrosedprimrose Member Posts: 1
    edited July 2012
    03'sequoia front right door glass broke, upon replacing the glass the window regulator is eratic.
    The typical reset/timming of holding the switch up & down a few seconds dose not recalibrate its motion.
    Any body know whats up.
  • crowdog6crowdog6 Member Posts: 1
    Hi Steve
    You should feel very good about how many people you've helped on this problem. After reading through the 5 pages it seems the link goes bad over time can you help me out with the link and reset it so I can also fix my
    2005 sequoia?

    Thanks
    Terry
  • jd124789jd124789 Member Posts: 1
    Is there a chance this information is still available. Can't seem to work the link you have provided. I of course have the same problem with my 2005 Sequoia. Thanks
  • bobn5bobn5 Member Posts: 2
    Steve, Thanks for all your information. I also have this problem on my '05 Sequoia, I was able to reset the ECM. I am now going to try to remove the defective Brake part, but i have a question before i begin.

    In the technical bulletin #9, it says to "Remove the multiplex network door ECU. Using a drill 3.2 mm (0.126 in.) or shorter, drill out the two (2) rivet heads". Then next in #10 it says to "Install the replacement multiplex network door ECU and rivets".

    Do I need a new multiplex network door ECU or just use the existing one and rivet it back on?

    Please let me know.
  • sgoodsonsgoodson Member Posts: 10
    The "multiplex network door ECU" discussed in item #9 of the technical bulletin is referring to the black square box (about 4" x 5") mounted to the black metal faceplate covering all the mechanics of the window & motor. This black electronic box (the ECU module) is mounted to the black steel plate using two silver metal straps. Each side of the strap has a rivet. Just drill out the rivet head on each side and the ECU module will be loose except for the wire harness. Unplug the wire harness and set the unit aside. Remove the black metal plate door, then remove the defective brake unit. To reinstall the ECU module box, I used two sheet metal screws with a lock washer on each. You may need to drill the hole bigger to accommodate the screw site you have on hand. Here is a photo which may help: http://www.piranamedia.com/_ToyotaRearWindowRepair/index_Page354.htm
  • bobn5bobn5 Member Posts: 2
    Thanks Steve, I was hoping you would say that. Will let you know the results so even more people can find out about your no cost solution that Toyota should NOT be hiding.
  • sequoia7sequoia7 Member Posts: 1
    Steve, Thank you so much! My rear wiper and defrost work again!!
  • toyo4toyo4 Member Posts: 5
    I had a problem with my Rear Defrost/Wiper not working, but the window was operating properly.

    This is what I did:

    1. Checked Fuses - all o.k.

    2. Tried Resetting ECU - did not fix problem

    3. Removed and replaced wire harness going in to ECU - Defrost and Wiper started working fine

    I did not have to touch the Rear Window Limit Switch or any bolts. I believe that when the panel was removed a month ago to fix the broken handle on the rear hatch door, that the wiring harness was not pushed all the way into the ECU and therefore no contact was being made.
  • ngag05ngag05 Member Posts: 1
    I just wanted to let you know that I too have been having the exact same problem for the better part of a year... I have been reading post after post with all the same resolutions which is to remove the brake... After getting the back opened up and looking at the assembly, I too realized that the brake had either been removed or an entirely new assembly had been installed. So, before reading this gentleman's problem with the 06 model (which mirror imaged my own, down to the reset of the ECU and only the defrost and wiper/washer working but not the window), I already put everything back in its place and closed it up, came back out to the front porch to regroup, then pulled up your thread here... To no surprise I smacked my forehead and went RIGHT BACK to the sequoia and opened her back up! Sure enough, had the exact same difficulty removing the regulator assembly due to the jamming, but was able to get the window fully operational again! Anyway, to bring this novel to an end... THANK YOU for all you do! It may not seem like a big deal to you, but it's due to extremely patient and understanding people such as yourself who take a few minutes out of your day to reply to peoples issues, that save people like us (paycheck to paycheck) HUNDREDS and even THOUSANDS of dollars in needless service department visits. So, thanks again! And I will definitely be coming here from now on!
  • sequoiaownersequoiaowner Member Posts: 2
    Here's a puzzle...I have a 2005 Toyota Sequoia. Fixed back latch one day without a problem, but afterwards the back window was working, the "auto" up/down feature was not working, defrost was not working, rear wiper was not working, rear washer fluid was not working, and rear window down feature on key fob was not working.

    After taking back apart again to triple inspect and check every single fuse, I read several posts here and tried holding the window in the "up" position to reset the ECU. Now, rear window doesn't work at all, rear wiper still doesn't work, the defroster does work, and the rear washer fluid does work ! Any ideas??
Sign In or Register to comment.