Edmunds dealer partner, Bayway Leasing, is now offering transparent lease deals via these forums. Click here to see the latest vehicles!

1994 G-20, 4.3L : Guages pegged or frozen, running rough

lunghdlunghd Member Posts: 61
edited July 2014 in Chevrolet
1994 Chevy G-20 work van, 4.3L auto

Possible red herring info: Regeared last week from 3.73 to 3.08 & a limited slip diff. (I know that I need to rewire the VSS.) Drove fine after gear swap past few days. Don't think this is related but mentioning since it is most recent work done to vehicle.

Left house today - van behaving normally. Within 2 miles noticed it was running differently - seemed smoother at highway speeds. Just an odd feel while driving.
Then noticed speedo was not where it "should be" (disregarding error from gear swap) and that oil pressure was frozen at 40#, voltage pegged at 0, water temp at 0, speedo frozen at 58mph.
Pulled over: Idle was smooth while I looked around for obvious things.
When pulling back out engine began to bog down, spit thru throttle body and had almost no power - could barely move the vehicle. Returned home with van taking a long time to reach highway speed - serious loss of power.

Yesterday cigarette lighter stopped working & given cluster is electrical (analog - NOT digital!) I'm assuming there is a connection.I know that some guages will peg out if the sending unit is grounded or open so suspect a wiring issue.

Hoping someone has some experience or feedback with this and can point me in the right direction.


  • lunghdlunghd Member Posts: 61
    Apparently my "red herring" may be a factor after all...

    Returned to vehicle & battery was almost dead. Disco'd battery & proceeded to pull lower dash panel for access to fuse box & rat's nest of wires.

    Troubleshooting found 15A gage fuse blown, replaced with another 15A.
    No discernable load (sparking) when touching disco'd terminal to battery. Voltage 12.35v.
    Reconnected battery & tried to start. Battery too weak to crank but it blew fuse again. Repeated w/ 10A fuse (all I had) with same result.

    Found VSS box (speedo converter box) that I need to rewire & pulled it.
    Replaced fuse with 5A fuse (all I had left) and tried to start again. This time it did NOT blow fuse AND gages all reset to rest positions.

    Hmmmm - jumped van with another vehicle and it started. Not spitting thru throttle body and power is improved but still very low on power.

    Reconnected the VSS box and there was no apparent affect - 5A fuse did NOT blow.

    At this point I'm hoping that the computer "learned" a new profile etc & that the VSS rewire will return things to normal.

    Any input is appreciated.
  • lunghdlunghd Member Posts: 61
    Rewired VSS - van seems to have recovered it's lost power and all gages now working although speedo still seems 'slow' by seat of pants guesstimate. In the interest of helping someone else who may stumble across this with a similar issue; here is a web link to a "how to" page with detailed instructions on rewiring the VSS module. http://www.tbichips.com/drac/

    Paperclip jumper to OBD1 port returned VSS circuit code alone. Will try to read codes again tomorrow after driving it a while.

    Could not find any shorts etc but disconnected both cigarette lighter ports at the fuse box. (Van is former Verizon vehicle so it has multiple ports for chargers & equipment.)

    I'll post back with the final verdict or updates in hope the info will help someone else w/ similar issues.
This discussion has been closed.