Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


asmbubbaasmbubba Posts: 4
I've tried to go onto the web site to view the repair manuals, but it won't let me create an account. Has anyone else had trouble?


  • tidestertidester Posts: 10,059
    You need to read and accept the privacy agreement in order to complete your registration. After you do that, will send you a password by email and you're good to go.

    tidester, host
    SUVs and Smart Shopper
  • Thats part of the problem. When I try to click on the privacy agreement, it goes to a blank page that says "Untitled" on the top.
  • Another thing, when I view the system requirements for your computer, the most recent OS that it lists is Microsoft XP. I have Vista, could this be my problem?
  • tidestertidester Posts: 10,059
    I suppose that's possible. I'm using Win 7. If it works with XP and Win 7 it's hard to imagine it wouldn't work with Vista but then who knows? On the other hand, if the latest supported OS is XP then it appears they haven't updated their system for quite a while.

    It may be that the problem is a browser incompatibility. I registered using Firefox and am pretty sure Internet Explorer would work. Which browser are you using? Version? Another requirement is that you have cookies enabled and that may be browser specific.

    There's also a chance that you have malware protection or a firewall that could be interfering.

    tidester, host
    SUVs and Smart Shopper
  • steverstever Posts: 52,683
    edited October 2010
    I just got in using Windows 7 and IE9 Beta. Didn't have to disable pop-ups or turn off my In Private Filtering to get there. It uses pdf files a lot so you should have a pdf reader like Foxit installed, but that wouldn't explain the blank screen you get after the privacy agreement screen. I think that screen is the same one you can see if you click on the Privacy Policy link at the bottom before logging in.

    The only other thing I can think of is that the site requires Flash so you may need to install or update that.

    Oh, just got in fine on my wife's laptop with Vista and IE8 fwiw.

    Some net posts from 2009 indicate that the Kia site only worked with Internet Explorer, so if you are using an old version of Firefox, maybe that's an issue. I'm sure Tidester is using the latest and greatest Firefox version and he got in.
  • i just tried the same thing and it goes to a blamk page everytime you try to view the privacy past. it says to hold the control buttn down as you click but that doesnt work either. So how are we suppose to view this site??? i have win xp btw. i really need help with my engine and blown head gasket/cracked head situation....
  • steverstever Posts: 52,683
    edited February 2011
    Still working for me.

    Is this the registration area you are having trouble with? I wonder if there's a pop-up that's getting blocked or one that's getting hidden by another screen.
  • Well, there are still problems. First I tried to log on and get an account using a MacIntosh computer. It did not work. Then I telephoned their help people and they told me Firefox & Safari do not work and i should try Chrome. That did not work. Called back and was told no Mac computer works at all. So I went to my wife's Windoze computer which had Vista on it. That did not work. So I purchased Windoze 8 for $119 and installed it. [Wow! Looks like Microsoft is starting to finally get it right!!!] So then I went to kiatechinfo again and filled all the stuff out and clicked on the legal stuff you have to agree to, checked the I AGREE box at the lower left, then hit CLOSE at the lower right, and then when I tapped CREATE ACCOUNT, a window comes up to say I have to check the I AGREE box. Which is what I have already done. I tried again and again. It is an endless loop with no way out.
  • A friend of mine lost her only copy of the ignition key. She thinks her toddler tossed it into the trash which was then hauled away. She has looked for days and given up finding it. So I am trying to help replace the key system. Unfortunately, when she bought the car she was told that the ignition key and lock had been changed by the previous owner. So using the VIN and registration to identify it to the Kia dealer to obtain a new ignition key will not work. So I just propose to drill the lock out and see what I can do to put in a new cylinder. But if I could get info from Kia, there may be some steps that would make the job more easy and some things to watch out for. I have tried to sign up at but I cannot sign it get an account after trying several times even though I have purchase Windoze 8 and installed it.
  • steverstever Posts: 52,683
    I got into just now. I'm running Windows 9 and using IE 10. Under tools, you could try Compatibility View (mine's working in "normal" view).

    Hm, just tried it in Chrome and that worked too. Very odd.
  • Windows 9, eh? Wow, you must be a bigwig at Microsoft. I just went to the MS website and there are only hints at how great Windows 9 is going to be, but no word on actually being able to get it for us regular guys. I am running Mac OSX 10.7.5 and have been using Macs for the last 15 or so years. Windoze 8 is a bit better than the older ones, but still it is futzy.

    Anyway, a different guy sent me a way to get into the Kiatechinfo website, and it proved worthless. You cannot get info on the ignition key problem unless you are a licensed locksmith and have a number to put in. Of course this is good to protect Kia owners, but it does not help me any. A locksmith quoted $500 to rekey this Kia. She shoulda bought a Ford!

    I am just going to drill out the cylinder. Hope it does not have a hardened steel front plate or I will have to use a carbide drill or grinding wheel.
  • steverstever Posts: 52,683
    lol, blame it on weekend thumbs. Win 8. :shades:

    I ran it under the consumer beta for months but I'm not quite ready to jump into another new OS.
  • Why can't I log on with an ipad 2? Would you have an idea?
  • steverstever Posts: 52,683
    edited May 2013
    I just got on using an iPad 3 and the Safari browser. Who knows why yours is fighting you.
  • I can't get the privacy page up to agree to it. I am using the safari browser
  • steverstever Posts: 52,683
    edited May 2013
    Well, it's my wife's gizmo and I don't play with it much (other than pinball, lol) so I'm out of my league. Maybe try an iPad forum. Got pop-ups disabled perhaps? (link).
  • Ok thanks but grrrrr lol
  • mgd4mgd4 Posts: 1
    I had exactly the same problem.

    I tried Stever's suggestion (Compatibility view) and I was finally able to sign up!

Sign In or Register to comment.