Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently bought/leased a new car online and requested a home delivery due to coronavirus? A reporter would like to speak to you; please reach out to [email protected] by 4/5 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

97 Ford Ranger staring issues

I have a 97 ford ranger. Everything is running fine, I stopped off somewhere, and when I went to start it back up I had no power. I checked the relays under the hood and when I went to start it again it started and ran fine as if nothing had happened. However, my radio presets were cleared out as if I had taken the battery out. This same thing happened once before about a week ago. It seems as if the system reset for some reason.

Comments

  • bolivarbolivar Posts: 2,316
    Check the battery and cables first. May be corrorsion inside the insulation. Check both ends.
  • lacrossesoakedlacrossesoaked Posts: 87
    edited November 2012
    where the battery cables attach to the battery terminals, may appear just fine but you could have corrosion between the cable clamp and the terminal post. It takes just a few minutes to pull the cables off of the battery, clean the inside of the clamps and the terminal posts and reattach. I had a similar problem and this was the solution.
  • My problem is that i have replaced the fuel pump, fuel filter, fuel pump relays, and fuel pressure regulator. What could the problem be?
Sign In or Register to comment.