Are you a current or recent car shopper who bought an EV and then installed solar – or who had solar already, making the decision to go electric easier?
Are you a recent EV buyer (past 3 months) as a result of manufacturer incentives and dealer discounts on these vehicles, including year-end deals? Were you convinced to buy an EV after finding a good end-of-year deal, or due to uncertainty around which EVs will no longer qualify for full/partial EV tax credits in 2024? A national business reporter is interested in speaking with you. Please reach out to [email protected] by 12/15 if interested in sharing your story.

Cadillac SRX, 2008 - trouble code C0551, option configuration error

amconamcon Member Posts: 1
edited January 2014 in Cadillac

2008, Cadillac SRX - three times the battery had gone dead (2x leaving the radio on, 1x cold weather and not being driven for 10 days)... first time the radio didn't work when the battery was recharged following the correct procedures listed in the manual. drove around for 15 min, parked for the night and radio worked fine the next day (fyi the nav worked just fine) no further issues.

second time bat died - the traction control light and warning came on... charged... drove for 15 min parked over night light was gone the next day.

third time bat died same as two however, the key seemed to stick, turned it back at normal resistance. thought it was off and pulled the key out, it came out roughly but came out with out any undue effort. but, I noticed the marker lights were still on. I re-entered the srx and put the key back in (again went in pretty normal) and noticed the key was in the forward but not running position. adjusted the steering wheel, and put the shifter in the drive, reverse then back to park position... the key stilled seemed to be in the forward position.

I started the car, did the same thing, and the key came back to the correct off position... however the traction control light/warning was now on. the code that seems associated with this is C0551 - "option configuration error"

so where is the problem? what needs to be looked at?

Sign In or Register to comment.