Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Chrysler 300M cabin fan problems

huntermhunterm Posts: 2
edited August 2014 in Chrysler
On this past Wednesday the cabin fan quit blowing and then yesterday it started blowing again. When it started it made a squealing noise and now only runs on high. The fan also won't shut off. The manual speed adjustment knob doesn't make a change and the only time the fan stops is when the car is shut off. The fan was working perfectly before it stopped running Wednesday morning.

Comments

  • huntermhunterm Posts: 2
    I am thinking that my problem is the climate control. Earlier today the screen went off but I could still change the temp and the other settings. Its not the first time the climate control controller has done this. This is the first time for the fan though. Anybody have any ideas?
  • hunterm said:
    On this past Wednesday the cabin fan quit blowing and then yesterday it started blowing again. When it started it made a squealing noise and now only runs on high. The fan also won't shut off. The manual speed adjustment knob doesn't make a change and the only time the fan stops is when the car is shut off. The fan was working perfectly before it stopped running Wednesday morning.
    Fan motor resistor. Under dash passenger side below/behind ductwork at firewall. 
Sign In or Register to comment.