Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently switched from a luxury sedan to a luxury SUV?
A reporter would like to talk to you; please reach out to [email protected] by 7/25 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Jeep Liberty Sport check engine light.

eddie523eddie523 Posts: 2
edited September 2014 in Jeep
I have a 2002 jeep liberty sport 3.7lts 6cyl, the check engine light had came on, I took the jeep to pep boys so they can put it on the scanner, what showed was the oxygen sensors, I changed all 4 oxygen sensor and the check engine is still lit, so I took it back to pep boys and again the jeep was scanned and still what reads is oxygen sensors, I took it to auto zone so they can scan it as well and same thing oxygen sensors, once I told them that they where replaced, I was told that it could be a fuse or the relay, I don't know what fuse and where is the relay I was told to look under ignition (is this right) I check the manual and the only thing I find is fuse number 36 ignition run/start-orc/left and right siacm or fuse number 37 ignition run only-orc and as far as relay don't even have a clue... has anyone out there gone through this problem??? I need your help.... thank you...

Answers

  • ray80ray80 Posts: 1,655
    eddie523 said:

    I have a 2002 jeep liberty sport 3.7lts 6cyl, the check engine light had came on, I took the jeep to pep boys so they can put it on the scanner, what showed was the oxygen sensors, I changed all 4 oxygen sensor and the check engine is still lit, so I took it back to pep boys and again the jeep was scanned and still what reads is oxygen sensors, I took it to auto zone so they can scan it as well and same thing oxygen sensors, once I told them that they where replaced, I was told that it could be a fuse or the relay, I don't know what fuse and where is the relay I was told to look under ignition (is this right) I check the manual and the only thing I find is fuse number 36 ignition run/start-orc/left and right siacm or fuse number 37 ignition run only-orc and as far as relay don't even have a clue... has anyone out there gone through this problem??? I need your help.... thank you...

    Did I miss the part where codes were cleared after sensor replacement?
  • sorry the codes were cleared as well.. check engine still came on..
Sign In or Register to comment.