Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Clicking noise coming from front end on a 2007 Town & Country LX 3.3L?

s_matthews05s_matthews05 Posts: 7
edited April 2015 in Chrysler
Has anyone else had this problem? We replaced the driver side CV axle because it was making noises, and it's doing it again. Could it be a defective part? We bought our van used with a salvage title, but we replaced all of the motor mounts when we did the axle. The van runs extremely well, except for this returning noise. It makes a clicking sound if you do a u-turn, etc. Any ideas?

Comments

  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 9,403
    Could be the other axle too. Sometimes those noises are hard to pinpoint and if the driver's side axle hit the end of the road, it's possible the other side went. But bad replacement part is certainly a possibility if it's definitely the same side.
  • It's most pronounced when you crank the wheel left as far as it will go. But, it also does the same thing when the wheel is cranked all the way to the right, too. Maybe it is the other axle? I hope it is and if it isn't then I'm irritated about the new one failing!
  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 9,403
    While it doesn't eliminate the possibility of the replacement axle being a bad part, my gut says it seem more likely that the other axle (assuming it's the same age as the left one was) went at roughly the same time. You didn't say how long ago you changed the axle
  • Oh, sorry about the time of replacement. It was done in October 2014.
  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 9,403
    Was just wondering. Another possibility is a bearing. Not that I want to think of bad things ;) but some parts of vehicles do age worse than others!
  • It could actually very well be the bearings. The van was purchased with a salvage title, since it had been in a front end collision. It only had 81,000 miles on it when it was purchased last January. The engine and transmission are as smooth as silk. I actually don't think we initially replaced the axle because of clicking noises.
    Instead, we replaced it because when you would put it into reverse, it would kind of vibrate, almost like it was being shaken back and forth suddenly. That shaking is back, and it also is clicking. I'll replace it sometime soon, and see if that makes a difference. But, wheel bearings are also another very possible problem.
  • Oddly enough, the clicking has not been evident today (April 9) for some reason. Quite odd.
  • Also, I have another item to add. It is also squeaking/clunking when going over bumps. But, that's the sway bar bushings, so we'll try to do that as well when we eventually replace the CV axles. Has anybody else ever had any serious steering/suspension problems with their van? Just curious.
Sign In or Register to comment.