Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently purchased a new minivan? A reporter would like to talk to you; please reach out to [email protected] by July 2 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Pontiac Grand Prix headlights

dwayne27803dwayne27803 Posts: 1
edited April 2015 in Pontiac
I was running HID in my lowbeams... the driver went out first. I kept messing with it until it usually came back on. It took a few months and the driver side would only flicker when you turned them on or did it yourself. I was about to remove the kit and replace it with another and decided to go back to the stock bulbs...they didn't work. Checked fuses and nothing.. all seem and appear fine. I checked many of these sites and noticed most of the problems have been a few years. I test lighted my fuse box (underhood) and light wires... no power. I had to make due with the situation.. by putting my high beams in place of my lowbeam until I can figure it out. At this point.. I am at a loss.. I have no clue what is going on with them. Any suggestions short of dealershipping it.. or just cutting the entire nose off and do something else? What am I missing and what should I be looking for? Help!!!!!

Comments

  • thecardoc3thecardoc3 Posts: 4,995
    What year?
  • 2collies2collies Posts: 13
    I had a similar problem with mine. I changed the relay in the box under the hood and that seemed to temporarily fix it but I keep spare bulbs and a spare relay in my car. I've had the thing at 3 shops and they can't figure out the electrical problem so with 200000 miles and nothing else really wrong I figure keeping some parts isn't that bad.
Sign In or Register to comment.