Are you shopping for a new vehicle and having trouble finding one, or have you been waiting a long time for a factory order? A reporter would like to speak with you; please reach out to [email protected] by Tues. 5/11 for more details.

Need a problem solver for my a/c issues in Phoenix AZ

local_phxlocal_phx Member Posts: 1
edited May 2015 in Mitsubishi
I have a 2002 lancer OZ

when the a/c is positioned on the first 3 settings the blower motor does not start. when I have it on the 4th setting (high) it kicks on.
google tells me this is most likely caused by the blower motor resister. its prob not the blower motor itself since I JUST replaced it hoping to finally have a/c this summer..

living in phoenix and only having an a/c that works on high wouldnt be an issue but the problem is when I have it on high the green a/c button turns off and only warm air comes out. when I have the setting on 1-3 the green a/c button is on but again nothing comes out.

I have checked the freon pressure and it reads normal

I also have a check engine light on which gives the same code I had last time that ended up being an o2 sensor.

my question is if I do have a bad o2 sensor would that cause the computer to turn off the a/c control only when the fan is on high?
if not what would?

thanks for the feedback!

Comments

  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAMember Posts: 9,403
    I think you need to start by replacing the blower motor resistor and see where that gets you. Electrical gremlins can sometimes cause weird effects.
Sign In or Register to comment.