Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Do you currently drive a 2019 Ford Ranger and live in Michigan?
A reporter would like to talk to you; please reach out to [email protected] for more details.

Trouble with my Air conditioner

jbander1jbander1 Posts: 1
edited June 2015 in Honda
No cold, So I turned the air on in the car and turned the fan on, the motor was dragged down. Opened the hood and checked the clutch and fan both were running. But the clutch didn't cycle, but stayed on. So I felt the high and low pressure lines and of course they were hot. So I had a hose and adapter with a pressure gauge on it for the air . I connected it without a can of refrigerant on it, if that makes a difference. It showed no pressure. So I pushed the air release in the fitting that you use to put refrigerant in and it made no noise and nothing came out. So I pushed the one on the high pressure side and it sprayed florescent lime green liquid and release some pressure. First shouldn't the clutch be off if there is no refrigerant or at least cycling. The green liquid I assume is die to find leaks , so I looked around but didn't see any green coming out of the system. I have a can of refrigerant , it came with it's own hose without a valve. It has sealer and dye in it. Where am I and what do I do next?? Any help will be appreciated.
Sign In or Register to comment.