Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

At my wits end

co_man_checo_man_che Posts: 1
edited June 2015 in Jeep
I purchased a 4wd comanche a month ago, and I knew it was going to need repairs done, I had no problem with it. But since then, I've run into a problem that I have done everything within my mechanical knowledge boundaries to fix, yet I can't correct the issue. The truck will idle all day just fine, and if in park or neutral, you can bring it all the way to rev limiter, put it in gear and it will idle fine as well, but give it gas and it will hesitate and stumble so bad it can't even move forward (reverse is O.K., but just ok). I have replaced EVERY. SINGLE. SENSOR on this thing and cannot seem to fix it. I replaced my fuel pressure regulator, distributor, coil, cap, plugs, wires, and stator pickup wire as well. Exhaust is free of restrictions. After replacing my PCM and alternator, the truck only runs halfway decent after all that and a check engine light that came on after I replaced my computer is now off with the replacement of an alternator, but seems to now possess a shifting problem. Now that I have really good power in R, 1, 2, 3 is weaker, I put it in drive and paid close attention to the sound and feel. I noticed that the vehicle jumps (that regular little jump we normally experience when we first put it in gear) in the 1-2 location, very positive in R, the jump is reduced at 3, but in D it is nonexistent, and when I went down the little straightaway of low traffic road in front of my homestead, I heard a bogged-down sound that as I gained speed to about 40, turned into a sound of abnormally high RPM's with no significant gain in speed, as though the truck struggles and can't shift up or down accordingly with the load. Taking off in D it seems that it doesn't start in 1st then work its way up. transmission fluid and filter changed within 30 miles. I am now thinking my problem could be a transmission governor pressure sensor/solinoid or a trans control unit. Would I have both of these or only the governor pressure sensor/solenoid, and could these be my issue?

Comments

  • isellhondasisellhondas Issaquah WashingtonPosts: 20,225
    Some jobs are beyond the skill levels of a do it yourselfer. I know I am certainly in that catagory!

    Instead of guessing and throwing expensive parts at it why not just take it to a qualified shop?

    All any of us can do here is guess and that can be a fools errand.
Sign In or Register to comment.