Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Rear air suspension is not coming up as was previously and with no problems ever with leaks.

djetdjet78djetdjet78 Posts: 5
edited September 2015 in Lincoln
OK the day before air suspension stopped my kid dropped a metal bead down into the car lighter hole and this blew a fuse so I replace but unknowingly my dad mixed them so not sure which fuse # is for that but any way since blown fuse my door locks ,trunk popkeypad entry which when was working when code to unlock it tried but to week lived w that but it still locked and opened trunk and doors not now no pwr locks no pwr trunk no ect. But also all of sudden no air rise in back also but I hear compressor as usual and switched fuses also flipped all relays around please help me quit dragging my butt. Thanks GB.

Answers

  • steverstever Posts: 52,462
    Town Car or ?

    Year?
  • Sorry I'm new!!
    1999 towncar 
    Thanks for rapid response
  • steverstever Posts: 52,462
    The manual may have the fuses listed, but may not.

    I don't know what else to tell you; maybe "fix" the fuses (check any under the hood too) and then "reboot" the car by disconnecting the battery for ten minutes or so.

    Some people don't recommend unhooking the battery since the computers will have to relearn your driving habits. Maybe some others will pop-in with suggestions.

    Usually we see failing compressor posts with older Town Cars and the frequently recommended fix is to swap out the bags for springs. But your situation is a bit different with the electrical gremlins.

    If you decide to unhook the battery, make sure you have any needed codes, like for the radio or keypad if you have one.
  • thecardoc3thecardoc3 Posts: 5,117

    since blown fuse my door locks ,trunk popkeypad entry which when was working when code to unlock it tried but to week lived w that but it still locked and opened trunk and doors not now no pwr locks no pwr trunk no ect.

    This is difficult to follow, but if you are saying that the power door locks are inoperative, check fuses #29 20amp and #30 7.5amp in the fuse block at the left side of the dash.


    But also all of sudden no air rise in back also but I hear compressor as usual and switched fuses also flipped all relays around please help me quit dragging my butt. Thanks GB.

    If you can hear the compressor running, then the system is trying to work which suggests that it has all of it's power inputs. How long does the compressor run? About three minutes and then it shuts off? If that is what it is doing each time you start the car but it isn't lifting the rear axle, suspect a leak or other system issue.

  • I appreciate all help but I'm just not thinking a leak cause never an issue plus if its that whats the chances its so bad of leak it doesn't come up at all. I see other problems that have been fixed w really IDD things you wouldn't think would have anything to do w it..any way I can test to see if compressor is pushing out air to the line to rule out compressor?
  • thecardoc3thecardoc3 Posts: 5,117
    There is a rule. Test, don't guess. Even if this is related to the fuse(s) issue, by testing correctly you will go right at it. By just figuring and moving forward (based on an assumption or guess) you risk trapping yourself because there is always going to be a chance that you have figured incorrectly.
  • Is there a way to test the compressor to see if its pushing out air to the line?
  • OK, djetdjet78 here still having  my 1999 town car dragging the rear end air suspension not working. My updated question is now that I have checked further  I've found under the dash in fuse box the fuse #s 20, 22, 24, 26 which if you see diagram these are all in a row and are offsetes or every other one.also # 28 fuse in same spot just under the relay is also out all good fuses all getting nothing on test light even checked without fuse also nothing so with new info abt this what could this mean wrong???
Sign In or Register to comment.