Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Replaced clutch now it won't start.

intheback40intheback40 Posts: 1
edited November 2015 in Saturn
I just put a new hydraulic system and clutch in my brothers 2002 Saturn sl1. Now we tried to start it yesterday and nothing. Just barely clicked a few times at the starter. I tried jumping it and checked all the connections I could think of that came off while doing the clutch. Nothing. So as I was pulling him home from the shop I had him try to jump it at a slow speed and what do you know fires right up. When we got it home . Turned it off and again nothing it just clicks. So my question is would it be the starter , maybe battery cuz it had a terrible looking ground connection or is something else misaligned on the flywheel. I wouldn't think so since it started and all the gears worked. Its a manual obviously. Please someone help.

Comments

  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 8,884
    Well the clicking certainly sounds like a low battery or bad connection someplace. And you said the ground connection looked terrible. You drift started it and everything worked, so it almost has to be that. Have the battery tested AND clean up all the connectors would be my first moves.

    It doesn't sound any more complicated than that at this point.

    Edmunds Moderator

    Need some roadside assistance? [email protected] - or send a private message by clicking on my name.

    Just purchased or leased a vehicle? Write your own vehicle review

    Meet your fellow owners and discuss your vehicles in our Owners Clubs

Sign In or Register to comment.