Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Welcome to the Edmunds forums! We are changing the way you sign into our forums. Click here to learn more.

transmission problem, help please!

skredneckskredneck Posts: 1
edited November 2015 in Dodge
hey guys im having one heck of a problem, it's going to be a long story to get all the facts in so here goes:

ive got a 2000 dodge ram 1500 4x4 with the 360, 392's 35 inch tires
cold air intake

one friday night i jumped in my truck and tried to get my big 35's turnin an well i blew the diff out.

SO, over the next day i rebuilt the diff threw it back in and thought i was good to go, jumped in to drive away and this truck is boggin down and locking up the diff, i couldnt get past 40k without skidding to a stop, i figured it was the diff, re did it and same thing, i would get to usually 30k @ 2000 rpm it would bogg to 1500 no matter how much throttle i gave her then full lock up and tires would skid me to a stop. it's like it locks and unlocks it never lasts more than 3 seconds and i have all my gears ( i think) i never make it out of first before it locks up on me

So i popped of the driveshaft figuring i had a piled up chain in the transfer case and yup did it again so popped out the transfer case getting ready to rebuild it when buddy comes by with a code reader and what do ya know it keeps doing the same thing without the transfer case on now only because i have no drivetrain i keep bogging out the motor, it wont stall but @ the rpm where it sits at 30km it wont get past, usually i hit 2k an boggs me down to 1500 or lower.

also noticed the fluid looked burnt and buddy claimed he seen a little smoke coming out the output shaft after i disconnected the transfer case

so now i figure it in the tranny and i popped a couple code which are:
P1740: TCC or O/D solenoid perf
P1757: Gov Press above 3 PSI in gear with 0 MPH
i think it's a 46re, maybe 47re transmission

And now im lost because i dont know transmissions at all.
ive had a couple people tell me its the torque converter and i spoke to my buddy who's dad is a tranny guy an he says it looks like to him that the tranny is going into limp mode and says to replace the governor pressure sensor.

if you guys have any advice it would be greatly appreciated,
feel free to pm as well

Comments

  • Need help.  Have 75 dodge w100.  Swapped in a 46re trans.  Now I have no spark.
Sign In or Register to comment.