2003 Pontiac Vibe GT | Really Weird Electrical Problem

theak8822theak8822 Member Posts: 1
edited November 2015 in Pontiac
Sorry for the lengthy post but I wanted to get all the details out there since I'm not a car guy.
Day 1
So my problem began when I noticed I was able to drive my car to work (roughly 12mi drive) but I was not able to start it when I got off. I got a jump from a co-worker and was able to drive it home.
I charge the battery overnight with a trickle charger.
Day 2
Next morning I'm not able to start it. I'm thinking ok what's the deal?
So, I get the battery tested, it seems to test fine according to Wal-Mart.
I start to notice the only time I can start the car is if it has a jump. By some leap of logic, I begin to think that it is the alternator since the car will technically start, it's just not getting enough juice.
So, my friends and I misread an alternator test and take off a cable while it's running. Apparently this is only a thing you should do to very old cars...whoops
Day 3
From this point on, I think it's the alternator. We take it out, test it at AutoZone. Tests fine.
At this point, I'm completely lost, so as a last ditch effort I test the battery one more time according to Mr. AutoZone's advice. Battery tests fine at AutoZone, he suggests it's my terminals.
I replace the terminals and what do you know, IT STARTS AND WORKS.
Day 4-6
However, it doesn't last long. Over the weekend, weirdly enough I see my ABS and brake lights come on, with my radio dimming. Only happens every now and then. So I don't think anything of it. I've just been making short drives on the weekend.
Day 7-9
Monday rolls around. I can't even get up to 40mph on the interstate from the car giving out. I get a tow to the shop. I take it to a mechanic who tells me it's the coated terminals I replaced it with. Ok, I can buy that...
So he swaps out the battery with a new one and I think everything's fine.
Day 10
It starts up with the ABS lights, brake lights, and radio dimming again about 1mi away from getting to my work. Seems to drive a lot longer but at this point I'm clueless as to what it is.
The mechanic thinks I need to change the alternator now. Which I'm well versed at since I already took it out.
I already ordered an alternator online to do myself.
Is this the right next move?
TLDR: My ABS lights, brake lights, and radio dims every now and then which is a signal for me my car will not start soon. Is my alternator going out?

Comments

  • imidazol97imidazol97 Crossroads of America I70 & I75 Member Posts: 26,083
    edited November 2015
    Check the ground lead connections at both ends. Loosen, clean ends, and retighten bolts.
    Look for ground wires that go from the engine to the body.

    You say it always starts when jumped: when jumping the car do you put the ground
    jumper cable onto the engine instead of connecting it at the battery terminal ground?
    The engine connection bypasses the ground connection at the engine. The might be
    indicating where the problem is.



    Clean the positive cable as well--but do it with the ground wire disconnected at the battery
    to prevent accidentally shorting a positive to ground.

    2014 Malibu 2LT, 2015 Cruze 2LT,

  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAMember Posts: 9,400
    Might be a short somewhere too. Electrical gremlins are tough to track down. Really need to get them into a corner they can't escape from!
Sign In or Register to comment.