-June 2024 Special Lease Deals-

2024 Chevy Blazer EV lease from Bayway Auto Group Click here

2024 Jeep Grand Cherokee lease from Mark Dodge Click here

2025 Ram 1500 Factory Order Discounts from Mark Dodge Click here
Options

Weird symptoms

punkin13punkin13 Member Posts: 1
edited December 2015 in Mazda
I have been having weird problems with my Mazda MPV. It has 177k miles on it, and for the most part it runs fine. It has just died on me several times while driving down the road. I pull over and put it in park and it starts right back up and drives fine. This has happened about 5 times in the last several months and seems to be when letting off the gas on a hill. I have since noticed that sometimes (not always) when I let off the gas, the rpms drop, the lights dim and the heating fan cuts out for just a split second. When I give it gas, it doesn't sputter or anything. It just again drives like normal. This summer it also started making a noise like the AC condenser was kicking off and on, but it does this regardless of if the AC is on or not. I had all 6 coils replaced last spring, along with the throttle position sensor. I just got a new battery put in a few weeks ago. My old one was a super cheap one and almost 3 years old. I don't suspect the alternator because with my old battery, once it started it was fine all day, it just wouldn't hold a charge overnight once the weather got colder. Any suggestions on where to start looking? I'm not a mechanic, but I can generally troubleshoot and make minor repairs myself (my daddy taught me well).
Sign In or Register to comment.