Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Weird stall problems since water pump replacement

bacmb104bacmb104 Posts: 1
edited April 2016 in GMC
I have a 2005 Sierra 5.3L with about 125k miles on it. I took it to my mechanic to replace water pump and check out prior to a camping trip. As I was leaving his place, I'd gotten about 1/2 mile down the road, and the engine started 'surging', with the tach going back and two between 0 and normal RPM (this was at a stop sign). Truck finally died, and whenever I'd turn the ignition, all that would happen was a hum or buzz behind the dash. Took the key out, opened the hood, tried it again, and it cranked. Took it back to his place, and it did the same thing... then it started. I tried to make it happen again, but it started consistently about 15 times. Drove home. That was a month ago. Since then, I have a problem starting a couple of times a week. Truck starts normally, but within 10 seconds is hesitating, then stops. I'll turn the key a few times, get the hum, then it will start. Today, I was driving along at about 40, and tach showed engine acting erratically, dropping down to near 0. I coasted to a stop, put the truck in park, turned the key off, tried to crank it again, cranked right up. Obviously, I'm taking back to the shop, but wondered if anyone had any idea what could be going on.

Thanks
Sign In or Register to comment.