Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

A/C Compressor Clutch kicking in with relay bypassed but not when plugged in. Also possible leak

sbaker89sbaker89 Posts: 5
edited May 2016 in Chevrolet
So I have a 1989 Chevy Cavalier Base with the L4 2.0l. I bought the car not long ago and the A/C worked fine most of the time but every once in a while it wouldn't blow cold for a short period of time. I just assumed this was due to low refrigerant but before I had a chance to buy a can to recharge it stopped blowing cold altogether. I went and picked up two cans of r-134 refrigerant and took to the mechanic shop behind my work where I was told my compressor clutch was not engaging probably due to low refrigerant and I should jump off the compressor so I could recharge with the r134 I bought. One of the mechanics had me wrap a wire around his test light and put the other end on the positive terminal of my battery and to touch it to the power plug harness on the compressor to jump it off and hold it there while I recharged the A/C. I know now that this was not the best and proper way to do this! Anyways when trying to find which side of the plug was the hot terminal and not the ground with sparks flying I believed I may have blown a fuse/relay or ungrounded something. Because when at first I had touched it to the correct terminal the clutch would engaging momentarily but as i lost my place and touched it again to the ground terminal, the compressor clutch stopped reacting to the wire at all. From this point the only way I can get the clutch on my A/C compressor to engage is by removing the compressor relay and running a jump wire from the hot terminal on the plug to the one sending power signal to the compressor itself. I have purchased a brand new relay that I confirmed is the correct relay and working although still the only way I am getting my compressor to click on is by removing the relay and running the jump wire. The head mechanic has tested any and all fuses and all of the A/C controls and wire harnesses inside the cab of the car and everything is working properly. Also I even tried replacing the high-side pressure switch and plug but not the other one on the back of the compressor yet. I have on multiple occasions since this completely drained out all of the refrigerant until the gauge reads completely empty and refilling with r134 and running through my system with the compressor jumped off but will only pump cold air with the compressor running if I once again remove the relay and run a jumper wire on the plug. Once I plug the relay back in I get nothing and the recharge hose gauge will go into red but when running the jumper wire it shows in the green. I cannot figure out what other options I have besides replacing the compressor or compressor clutch and honestly I believe the compressor is functional. Has anyone been here before and is there any ideas out there? What should I try and do? I cannot bear the heat without my A/C working. Please let me know if anyone has anything for me!! Thanks!!

Comments

  • sbaker89sbaker89 Posts: 5
    Also I am aware the A/C is originally r12 and that I am using r134a but the car has had no problem running on r134a before and I don't believe any valves need to be retrofitted
Sign In or Register to comment.