A/C Left Side Hot - Right Side Cold - Back Ok

mrzorbamrzorba Member Posts: 2
edited June 2016 in Ford
2010 FORD EXPLORER, am sole owner.
Last few months have had the Left front blowing hot/warm air while the Right side and all rear working properly.
This is regardless of fresh air or recirculating air position.
Flash light looking into the facing vents show both doors open and close properly (so the dowel trick as shown on youtube does not apply).
Must be some door that does not move properly before air reaching the top ? !

Dealer wants to charge $1,000 just to open up dash and check !

Any ideas are welcome.
Thanks,
Mike

Comments

  • mrzorbamrzorba Member Posts: 2
    Wow, no one must have the same problem ! No replies : :disappointed:
  • steverstever Guest Posts: 52,454
    It does sound like the blend door (or one of them). Most searches on the net just show problems with older Explorers though. And the fixes mostly focus on the older ones (it sounds like you've done a lot of searching on this).

    Anyone?
  • thecardoc3thecardoc3 Member Posts: 5,535
    What testing has been done? Has anyone connected the factory scan tool (The Ford IDS) and followed the correct routine to be sure if the actuator itself works and whether the door has failed inside the plenum assembly?
  • paulas2008paulas2008 Member Posts: 1
    I have the same problem with my 2008 Ford Explorer!! Started out that the left side was blowing hot and the right cold and the back was ok then that started blowing hot. Took it to a shop and they said it was the blend door and repaired that cost $620. A week later the front is fine but the back is blowing hot, took it back in and they just called me and said that now it's the ac dryer and that it will cost an additional $325!! WTH. I'm thinking of getting my vehicle back and just taking it to a Ford dealership but they are just so expensive. Any suggestions??
Sign In or Register to comment.