Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Have you recently leased or purchased a Lexus sedan or SUV? If so, a reporter would like to talk to you. Please reach out to [email protected] by Wednesday, December 19 and the Edmunds PR team may connect you with the journalist.
Have you recently purchased (not leased) a subcompact sedan (such as a Toyota Yaris, Honda Fit, Chevy Sonic or Ford Fiesta)? If so, a reporter would like to talk to you. Please reach out to [email protected] by Wednesday, December 26 and the Edmunds PR team may connect you with the journalist.
If you experience loading issues with the login/register form, please completely disable ad blocker or use an incognito or in-private window to log in.

idle haywire on Chevy Blazer

nhra502nhra502 Posts: 1
edited July 2016 in Chevrolet
2000 blazer 4.3 2 wheel drive auto trans ...........anyone ever seen this problem?
idle haywire when you turn on AC, idle jumps up 500 to 1500 rpms
had it at 2 shops, it doesnt want to mess up when it goes to the shop
have had the smoke test done, replaced ivac , tps ,temp sensor, mass air flow,
first time it went to the shop, they told me the intake gasket was bad had that fixed
shows no codes? now as soon you turn the ac on 80% of the time it will act up.
and even if you turn it back off it still acts up for along time.
ive done some research but cant find my problem, ive read that the reveits on the Throttle Body get loose but mine are fine, the mech from the shop said it could be the ECM?
thanks guys <<<<<<<<<<
Sign In or Register to comment.