Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

2001 Toyota Avalon stalls on cold start

rwiechmannrwiechmann Glendale, CAPosts: 1
edited November 2016 in Toyota
I have a 2001 Toyota Avalon XLS with just over 100k miles, and is up to date on all scheduled maintenance. When I start my car in the morning it will turn over but almost immediately will shudder and stall. What I have been able to do is to immediately hit the gas (while still in park) and rev the engine at aprox 2,500rpm for 30-45 seconds. After that the engine will normally be fine and I can put it into gear. This seems to be more of an issue in cold weather. I live in California so it is not freezing, but has been in the high 30s/low 40s lately. This problem has only started presenting itself in the past three or four weeks.

Once the car is driving, it is fine, it is just getting it started the first time. If I have driven the car for awhile and warmed it up, I am able to turn the car off, and then turn it back on again with no issue. It is only after it has been sitting for a few hours and cooled off.

Another thing is that once the engine does start and stay on, it's idle rev is higher than normal by about 500-750rpm. That last only until the engine temp goes up, and then it settles back down.

My mechanic has taken a look at this and has plugged into the computer, but there are no pending or current alerts, so he does not know what the issue is.

Has anyone ever experience this before, and if so, what was the solution.
Sign In or Register to comment.