Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

2004 Grand Am Starting issues

jarefo83jarefo83 Posts: 1
edited March 2017 in Pontiac
I have a 2004 pontiac grand am 3.4 v6. I just replaced the fuel injectors, spark plugs, and egr valve. Now it doesn't want to start. It cranks for 6 or 7 seconds smelling like a buttload of gas is being dumped before firing. Once it's running it has more power than I ever did before but I'm not sure what the starting issue is. It was starting perfectly before the new (not cheap) parts. I'm wondering if the fuel injectors are defective. I'm at a complete loss. According to the code readers it's running lean and misfiring. Any ideas on what the issue could be?

Answers

  • Well if you replaced the injectors and it smells like it's getting lots of fuel then i doubt that will be the problem. This may sound naive but have you checked the negative battery terminal. I had a client bring a truck in the other day that started when it wanted to and sometimes wouldn't. I asked him if he'd had it serviced anywhere else recently and he said he'd had the battery changed at another shop a week prior so i started looking at the battery cables thinking that they might be cracked of broken and upon doing so i found that the negative battery terminal was loose. I tightened it, kept it at my shop for 2 days starting it at least 4 times a day and he hasn't had the problem since. Simple fix but could have caused a big issue
  • laurier2laurier2 Posts: 1
    edited May 2017
    My 2004 Pontiac grand am won't start . Yes it has a securtie light too an its on.. But it will not even turn over and the lights do come on. But it will nit make any noise at ALL .except the door noises and the ding ding when the keys in it.  The battery fine. they been saying starter.  But I am wondering if thats it or thing else.  Anyone got any ideas? Or had this problem ?
Sign In or Register to comment.