2008 Chevy Equinox Weird Rough Idle on Start-Up Issue

gregoryd2gregoryd2 Member Posts: 1
edited September 2017 in Chevrolet
I have a 3.4L 2008 Chevy Equinox that runs rough on initial start up. If I rev the car, even only one time, to 3k RPM the idle is fixed. Upon revving the engine, the brake pedal gets softer and I can hear running water just behind the steering wheel (driver left). The car runs great after that. I've installed new spark plugs and spark plug wires recently.

Comments

  • 0patience0patience Oregon CoastMember Posts: 1,712
    edited September 2017
    Are you sure it is water you are hearing and not air?
    The reason I ask is your symptoms sound more like a leak in the brake booster.

    The reason I say this is, the booster is mounted on the firewall behind the steering wheel and if the check valve on the brake booster is broken, cracked or not working properly, when you start it, the vacuum from the engine will need to charge it. Which will cause the brake pedal to be hard on initial start up and as the vacuum charge fills, the brake pedal softens. And will cause a vacuum leak, in essence, on the engine and can cause the rough idle.

    If I explained that well enough.
    So, if you have a vacuum pump (Mityvac MV8000 - Automotive Tune Up and Brake Bleeding Kit is inexpensive), you can hook it up to the brake booster hose and check to see if it holds vacuum for at least 10 minutes. If it does not, then hook it up, removing the check valve and hook directly to the booster and retest.

    If the booster holds vacuum with the check valve out, then the check valve and not the booster is your problem.
Sign In or Register to comment.