Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Shuddering issue - '08 Outlook

mjj_rljmjj_rlj Posts: 1
edited February 2018 in Saturn
We purchased our Outlook about 2 years ago. A year into having it we started noticing a shutter while accelerating. More prominently when we are going up hills. You can usually stop the shuttering by giving more gas or switching to the towing feature on the vehicle. It doesn't seem to do it as much when it is running at a higher RPM.

When it started we brought it to the dealership we purchased it from. After driving it they told us it was the flex plate and that we needed to bring it to the GM dealership for warranty repair. We then scheduled with our local GM and they said since there was no code they wouldn't do anything.

I guess my question is this:

Has anyone experienced this shuttering type issue? It isn't a chugging issue, so we ruled out fuel issue. It is getting worse. We replaced plugs and wires and replaced EGR valve. Does this sound like a flex plate? Torque converter? Transmission dying?

Thanks in advance

Comments

  • Just saw your post here. I have a 2008 also and just this past week, after turning 158,000 mi. noticed a slight shuttering shifting from either 2nd to 3rd or 4th to 5th gear. More noticeably going up a slight hill. Trying to find an answer or resolution online is like trying to find a needle in a haystack! I bought this Outlook in mid-2013 with 63,000 mi. A year later engine light comes on and I notice weird gear shifting. It wasn't consistent and at times the engine light on the dash board would turn off. After researching online, and AGAIN not finding resolution, I took it to my local GM dealer.

    They ran the code and told me it was the transmission fluid level pressure sensor (or switch) that, in the end, cost me around $1200 to replace. Had no choice but the transmission has been shifting flawlessly since. Happy to say they didn't mislead me into thinking it was the wave plate issue and just go ahead and replace it too. So there ARE "decent" folks out there still that don't take advantage.

    So at this point in time...a couple of things. First, did you ever see the check engine light come on? And second: what was the diagnosis and repairs completed?
Sign In or Register to comment.