my 2004 vibe - electrical issues

vibermanviberman Member Posts: 2
edited June 2018 in Pontiac
I recently got a 2004 vibe, the last owner was somewhat of a twit and let the car go to crap, well I brought it home thinking that all I needed to do was change the alternator and the car was good to go, or so I was told. Well the alternator wasn't the issue it was the battery after buying a new battery the car started up just great, only issue I have not lights,signals, heat, wipers no nothing working. I checked all the fuses and changed the dead ones but still nothing works. Would it be a relay and if so which one. all help welcome

Best Answer

Answers

  • imidazol97imidazol97 Crossroads of America I70 & I75 Member Posts: 25,913
    edited June 2018
    I assume the engine starts and runs, since you didn't say that was a problem.

    A quick look on the electrical distribution shows two positive connections at the battery. On some GM's the two connectors were joined by a lead bushing that could corrode or not make contact with the second positive cable to pass power to it. Separate and clean or purchase new one.

    Here's the distribution with 10 diagrams.
    Click on the attachment at the bottom of this post name vibe2004.pdf to open it in a pdf view.
    It has 10 diagrams you scroll down through.

    Hope it helps.



    2014 Malibu 2LT, 2015 Cruze 2LT,

  • vibermanviberman Member Posts: 2
    that simple little connection would cause everything to just not get the power to the complete dashboard and such
  • imidazol97imidazol97 Crossroads of America I70 & I75 Member Posts: 25,913
    Ground diagram in pdf.
    Download to computer by clicking on vibe2004ground.pdf
    Then look for items that are not working and circle them. See if they have a common ground point.

    2014 Malibu 2LT, 2015 Cruze 2LT,

Sign In or Register to comment.