Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Do you currently drive a 2019 Ford Ranger and live in Michigan?
A reporter would like to talk to you; please reach out to [email protected] for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Help needed to troubleshoot 2009 aspen hybrid dual mode hemi 5.7L

curiousvcuriousv Posts: 2
edited June 2 in Chrysler
2009 Chrysler Apsen hybrid ..ran out of fuel and it never started again.
When I turn on the key ..nothing .. Green 'READY' sign about hybrid battery comes on for a second but goes away fast...
when I try to jump start hybrid battery using posts under the hood....I found message on navigator screen 'system not in use'

How do I make sure hybrid battery and hybrid system is ok?

Comments

  • thecardoc3thecardoc3 Posts: 4,992
    curiousv said:

    2009 Chrysler Apsen hybrid ..ran out of fuel and it never started again.

    This is going to depend on exactly what you did when it ran out of gas. When the more common hybrid vehicles run out of fuel repeated attempts to restart the vehicle can deplete the hybrid battery. Some of them will set codes for the gasoline engine unable to start and evenually lock themselves out (occurs when the hybrid battery state of charge falls below 20%) in an attempt to preserve the hybrid battery. Your car is very rare and most techs outside of a select few dealer techs have never seen one let alone got training on one. The system your car uses is the GM design, but it uses all of the rest of Chryslers onboard electronics. In GM service information jump assist is initiated using a scan tool, specifically the GM TechII. You probably need to get hold of a WiTechII to do the same with your Aspen.
    curiousv said:


    When I turn on the key ..nothing .. Green 'READY' sign about hybrid battery comes on for a second but goes away fast...
    when I try to jump start hybrid battery using posts under the hood....I found message on navigator screen 'system not in use'

    The posts under the hood are 12v system and in the GM version you do use the GM 12v system to charge the hybrid battery through the APM (DC to DC convertor) but again this takes the factory scan tool to command that function to occur.
    curiousv said:


    How do I make sure hybrid battery and hybrid system is ok?

    The easy answer is you don't. Without specific hybrid electric vehicle training and full O.E. tooling and service no attempts to service this system should be made.

Sign In or Register to comment.