Encoder Motor Problem for 97 GMC Jimmy

willg121willg121 Member Posts: 4
edited May 2014 in GMC
Everytime I drive and get on the throttle until I get up to around 40 or 50 miles per hour and then back off the throttle, I begin to hear a whiring noise from the front end, sounds kinda like a drill scoring metal. Anyway, I've changed the control switch on the dash, and had the encoder motor replaced and it still does this when I get on the throttle.

Does anyone have any ideas what exactly the problem might be? My mechanic says that it sounds like the 4-wheel drive is trying to engage at a high speed, however, I'm not sure anymore since I had those things repaired.


  • repairdogrepairdog Member Posts: 948
    Encoder motor is on the transfer case and puts the low gear in for 4Lo only. You have a coupler on the pass side of the front diff that locks when you select 4Hi and 4Lo so the axles both spin then. There is a vac line that runs down to an actuator under the battery tray that may have a vac leak in the line or the diaphram leak on the actuator so the coupler is only partially engaging. Your system also has vac line connector on top of the transfer case (not on 98up) and a sensor on that axle and transfer case to tell the 4wd computer the state of the coupler and transfer case. The front diff and transfer case fluids could also be low and causing a whine.
    A final problem/fix these have is the computer sometimes hangs up so disconncet the battery for 30 minutes and then reconnect and see it the condition clears - it sometimes does.
  • willg121willg121 Member Posts: 4
    My next question is, how costly is this to repair if it's indeed the vac line leaking or the diaphram leaking?

    I mean, I've put in a lot of money to fix this truck. First it was the fuel pump dying on me, and now this. I'm hoping this is the last repair I have to do to this truck.
  • repairdogrepairdog Member Posts: 948
    Vac lines are simple and 5/32 or 7/32" line you can do. Actuator part isn't much its the labor. As for repairs assume this one has over 100k miles so there are some things that could go wrong still, common/normal for these are: AC, water pump and flush system, alternator, hubs, ball joints, ignition switch module (97 only), and then on all vehicles brakes. Have to do maintenence on all cases with new fluids and no one does so they fail. Electric pumps are all in the tank now and if drivers run low often they heat up and fail sooner. Decision on a vehicle is always a personal one.
  • willg121willg121 Member Posts: 4
    Like the title says. Anyway, I'm going to just get it fixed, whatever it costs is whatever it costs. I just hate the labor aspect.
  • repairdogrepairdog Member Posts: 948
    I do most of my own - have 4 of them so I know - seen many of the common problems and I'm in FL so sweat alot in the summer fixing them! Relax and enjoy life!
  • willg121willg121 Member Posts: 4
    I had all the things you said checked, and nobody can find anything wrong anywhere. Fluid levels were good, vac hoses were good. So I don't know what else there might be. Any ideas?

    Also, I'm going to take my truck off of its battery for the half hour you suggested when I return from an errand, but otherwise everything else checked out.
  • jackassjayjackassjay Member Posts: 4
    I have a 99' Chev Blazer and went to use the 4x4, but to no avail. I can press the button on the fly and in park and in neutral and nothing. All it does is flash the 4hi button and goes back to 2hi. I can hear it trying to engage at the transfer case but it sound like the encoder motor is seized or dying. It does this as well when I try 4lo. I'm at the end of my rope this ride as it only has 120,000 km. I've replaced so much it's rediculous. I need to fix to sell....Thanks Jay
  • repairdogrepairdog Member Posts: 948
    Read posts above and try 4Hi first - no encoder motor for that only the front axle coupler. You also have a solenoid on the firewall so see if that works - follow the vac lines.
  • schorndogschorndog Member Posts: 2
    I'm having the same type problem with my 97 Blazer but I can't get into 4 wd high, I can get into low 4wd, transmission garage looked at and they figured computer(control module) in dash($390 gm part without labor)- I then went to the local dealership and they diagnosised as the transfer case encoder motor (the gm motor was $580 without labor) I found the motors new at local parts distributor for 1/3 that, but with what I have read here it has cast doubts on the encoder motor....at the cost of these parts I'm trying to eliminate any question...
  • repairdogrepairdog Member Posts: 948
    You lost me on that - encoder motor is only for 4Lo so if you got it into 4Lo then the motor worked and the front axle coupler worked so 4Hi should work - remove the battery cable for 30 minutes and see if that reboots the TCCM or control module and try again. Someone is wrong. Also there are sensors on both the front axle and transfer to send status to the TCCM (the ones that look like a round sender unit with an electrical connector on them. Check all vac lines before you go on!
  • schorndogschorndog Member Posts: 2
    Yes, I had it at the dealership 2 weeks ago and they diagnosised as the encoder motor, I had read your postings at this site and argued that it should not be the encoder , I had 4 wd low but not high, they stood by there diag...I was reluctant and refused the work, I posted my problem and your suggestion worked, I disconnected the battery and it did reboot, thanks for your help and sharing your knowledge
  • firedog443firedog443 Member Posts: 1
    Hey repairdog I have a 2002 Jimmy with the 4 HI not working. Took it to the dealer and they said it was the Encoder motor, and that it would cost me $1500 for a new one with the install. Tried removing the battery cable for 30 minutes like you posted and it worked. Thank you very much for your knowledge.

    PS: You should be called repairgod.
  • repairdogrepairdog Member Posts: 948
    Glad to help. I have 4 Blazers so have had alot of the problems and with three 4wd ones - got 2 with AutoTrac or 236 cases and a 98 with InstaTrac 233 case so keep learning new things all the time. Just as a note you can get many parts online at gmpartsdirect and rockauto and that encoder is about $200 and even the TCCM or 4wd computer is under $300.
  • christ123christ123 Member Posts: 2
    repairdog, That sounded like a good call on that encoder motor. I have the same problem with my 2002 Blazer and can't wait to try disconnecting the battery to see if it reset itself. On the chance that does not work, how difficult is it to actually change the encoder motor? I have research some Motors Manuals and they don't actually give the details on R+R the encoder motor.
  • repairdogrepairdog Member Posts: 948
    Depends on if 3 or 4 button case, 3 button (NP233)has a 3 port vac switch on the transfer that is most commonly bad and is $15 Motormite/Dorman #49315. If 4 button (NP236)I would look at that underhood firewall mounted vac solenoid as suspect also. GM#15165891 for $45 cause if they leak front axle coupler ops is slow and if they fail and pass vac no axle coupler - so bypass that with a simple inline vac connector and see if 4Hi works. Encoder motor bolts on and about $200 if you shop around but I would do that last. The TCCM is usually locked up and in some climates I've read that condensation gets in the connector and they blow it off and all works. There also is a "4WD" fuse in the dash panel by door and another called "ATC" in the underhood panel that should be checked and can be pulled instead of the battery.
  • christ123christ123 Member Posts: 2
    Kudos to you, and many thanks Repairdog.
    Disconnecting the battery and reconnecting cleared whatever error condition existed. The 4WD works now, thanks for the advice.
  • mojo23mojo23 Member Posts: 4
    well we got out 2001 LT blazer a little over a year ago. I love the truck its awesome, but recently we have had some problems. we were driving up to rockford hours from home, and our transmission made some nasty clunking sounds, and then wouldn't shift into reverse. so we took it to a local dealership, who were very nice and the warranty covered basically rebuilding the transmission,we didn't have the truck for a week. well just the other day before a big, ice/sleet/snow storm for the 1st time since we got it back I hit the auto 4wd button and nothing happened, I also got stuck in the snow. it won't shift into any of the 4wd gears at all, the panel just blinks and it goes back to 2hi. yesterday I took it back to the dealership I bought it from , and an hour later they told me the decoder motor went bad. they would have to order a new one. well we bought an extended warranty and that doesn't even cover it. they are saying $830 to fix it. I won't have it fixed, I can't afford that. I tried the disconnect the battery trick, and it just does the same thing. I still think them doing something with the transmission and this are connected because it worked when I gave it to them. any one have any solutions here ?
  • repairdogrepairdog Member Posts: 948
    post once
  • dougaroodougaroo Member Posts: 6
    99 Blazer...stuck in four wheel high. Will not drop out of four wheel until I pull the ATC fuse under the hood. Replaced the ATC control module..cleaned the contacts...still no go.
    Replaced the four button dash switch, no change. Still blinks and will not drop into 2 wheel, (nor four low) the auto four does stay steady lit. Vacuum switch on the firewall is good. You can here the encoder motor working when I push the buttons, can't say it's engaging...the puzzler is why does it drop out of four high when I pull the fuse?
  • repairdogrepairdog Member Posts: 948
    Points to vac applied to the front actuator so with the vehicle running pull that vac hose off the solenoid on the firewall and see if you hear the actuator release - if so put a golf T in the source side and test it out - can leave till buy a new one but no 4wd. Those solenoids leak - internally sometimes applying vac or externally for slow engagement.
  • dougaroodougaroo Member Posts: 6
    Bought a new actuator valve. No change. Still stuck in four high. With a vacuum pump checked the actuator (under the battery) and it holds a good (20psi)vacuum. I by passed the valve and hooked the two hoses together and it puts it in four wheel high. Plug the vac hose and it drops into 2wheel.
    So by deduction it appears voltage from somewhere is keeping the actuator valve open. When I pull the fuse this of course
    cuts the voltage to the actuator valve.
    Any suggestions on where to look now?
  • bruce48532bruce48532 Member Posts: 64
    Error code: 0323 T-Case Lock Circuit Low
    Parts Repaced: Dash Switch and 4WD Frt Axle Actuator

    Current Symptoms:
    1. Defaults to 4HI after I switch the ignition on 5 sec off 5 sec then on 10 sec.,will also switch to Auto 4WD.
    2. Depressing dash buttons runs 4WD Frt Axle Actuator with whining then vibrating grinding noise at end of cycle. Acts like the actuator is trying to shift gears but overloads, then shuts down when trying to switch to 2Hi or 4Low.

    I Checked fuses, left side drivers door and ATV under hood, OK.

    Low Fluid level possible ?
  • repairdogrepairdog Member Posts: 948
    Looks like an NP246 case (larger than 236 auto case) but should work the same. Sounds like one of the ball type sensor switches on either the front axle or transfer is stuck ON (ball pressed in) so the TCCM thinks its 4wd time. Ckeck them and if OK standand trick is pull the power for 30 min and see if it reboots. Also pull and plug the vac line on the firewall solenoid and see if it stays in 2wd then, if so replace solenoid. Check the connectors and wiring down on the transfer case too - cuts or bare spots.
  • s10468s10468 Member Posts: 1
    Dougaroo,I also own a 99 s10 and my blazer is behaving exactly the same as yours is. The encoder/motor buzzes and will not complete the shift back to 2HI. I replaced some vacuum line and the frt axle clutch solenoid(actuator valve)... still not fixed. Were you able to solve anything yet?
  • dougaroodougaroo Member Posts: 6
    No I have not solved the problem yet , but was able to find a possible fix from another posting a I made.

    Here's the text of the post and the link


    EUREKA!!!!!! Found the Problem with the Blazer. After testing all of the components involved with the 4 wheel system I couldn't find any problems...
    I finally decided to pull the encoder motor to see if I could shift it manuals to make sure I didn't have a mechanical problem and found the problem. Looking at the encoder motor from underneath It looked almost new. I pulled it off and found a major build up of corrosion between the plastic gasket and the motor gearbox. So much so it distorted the gearbox and bound up the unit so it wouldn't complete the shift. I scraped all the corrosion off and it had a very pronounced bow to the unit. I pulled it all apart ( I'd like to kick the engineer that decided to put security torx bolts in the cover) and separated the 2 halfs. I checked the machined surfaces with a straight edge and found that the housing was warped by at least 3/16th of an inch. I figured nothing ventured nothing gained so I pulled the unit completely apart and using a press straightened the 2 halfs the best I could. I then used a big mill file and flattened the two halfs so they were true. While I had the unit apart i checked the brake unit on the end of the motor and it was fine except that there was some gunk on the friction plate so I cleaned it off. I checked the motor and found one of the stabs for the power feed was almost burnt off. I cleared away some of the insulation and soldered the wires directly to the motor feed wires. No chance to loose continuity again.
    I reassembled the unit and installed it back on the transfer case, installed the driveshaft and lowered the truck to check the shift modual connections.
    After connecting the modual I replaced the fuses and started the truck. Bingo the truck snapped into 2HI and works like a champ now..
    Sorry for the long post but thought you guys would like to have the info.
  • groundhog03235groundhog03235 Member Posts: 2
    Hi guys! We have a 2000 Jimmy approx 98k miles. Last winter the 4WD was perfect, this year nothing-when I push the buttons for 4 high or low or the auto 4 high, the light blinks for awhile and then goes right back to 2 high. Took it to the local GM dealer to be checked-they condemned the encoder motor. I'm going to try disconnecting the battery as previously suggested-if that doesn't work, could it be time for a new motor?
  • repairdogrepairdog Member Posts: 948
    Could be - have you done all the things listed to test all the other components yet and is it 3 or 4 button - vac to front actuator is often the reason.
  • groundhog03235groundhog03235 Member Posts: 2
    I tried disconnecting the battery-no luck there. So I consulted my local mechanic who suggested that we try the new motor based on the dealer's diag. I was able to get it at his cost (still $470!) and it did the trick. But I appreciate the other info for future reference.
  • dougaroodougaroo Member Posts: 6
    Problem solved. It was a severely corroded encoder motor. I took it off the T-case and found incredibly heavy metal salt deposits between the encoder case and the T-case. These deposits formed from road salt that leaked between the plastic spacer. Corrosion was so bad it warped and split the encoder case and broke the metal along one of the anchoring bolts. The plastic spacer was deformed. I took the unit apart and found rusty water in the gear assembly. The electric motor was also shot, as water leaked in from the wire connection, which in turn filled the motor casing with rust. Finding a new encoder motor is hard. They are back ordered everywhere, even on Ebay. The dealership has them but will hose you for $800 plus. I finally found a rebuilt one for $150 that had to be ordered in from Chicago. I was able to heat and press the spacer back in to shape and then sealed it to the encoder case with blue gasket material to prevent future rust. Exercised the T-case shift spline, which was fine. Reinstalled the motor and bingo, everything work great. I got my two and four wheels back. Sweet. A PM word to the wise for those with 1999 S10’s in the snow belt, check your encoder mounting before it’s to late.
  • repairdogrepairdog Member Posts: 948
    Yep, a pain and good its fixed. Dorman makes new encoders and has pictures online - under $250 at most auto stores - many will order them for you and then rockauto and gmpartsdirect are 2 online ones. Sorry, a day late and a few dollars short.
  • murphy51murphy51 Member Posts: 5
    My 99 blazer does not respond at all.No lights or anything.
    In shop getting diagnosed tomorrow.
    Will let you know what they find.GM junk again.
  • murphy51murphy51 Member Posts: 5
    Found a blown fuse under hood in fuse box.Replaced and worked for a while and blew fuse again.Must be a short somewhere.
    Any suggestions?
  • murphy51murphy51 Member Posts: 5
    Mine keeps blowing the fuse under hood in the fuse box.Any ideas?
  • Rick_MRick_M Member Posts: 2
    2000 GMC Jimmy 4x4 4.3, VIN "W". I'm swapping a tired engine/tranny with a another used one (what a pain!!!) and when I removed the hose to the 4x4 front axle engage vac motor several ounces of tranny fluid ran out of the motor. I also noticed tranny fluid in vac hose when removing the three port connector to the vac valve on top of the transfer case. I assume the seal inside the valve has failed and sucking fluid. Does that sound likely? Will the tranny fluid ruin the vac motor, should I replace that also? Also, any known problems to look for, or parts to replace before re-installing, e.g. timing chain, water pump, etc? The "new" engine/tranny has 47,000 so it should be OK for a while.
  • Rick_MRick_M Member Posts: 2
    Well I investigated a little further and figured it out myself. Since the fluid in the transfer case is green and the fluid that ran out of the vac motor was red, I knew it was not the vac switch on top the transfer case. It had to be tranny fluid, so I traced out the vac lines and found that the vent line from the tranny has a tee in it that connects to the vent port on the transfer case vac switch. The only thing I can figure is at some point someone must have overfilled the tranny and it filled the vent line. Then when the 4x4 was activated it sucked the tranny fluid that was in the line into the vac motor when it disengaged. The only other thing that might caused it was if the tranny fluid foams and fills the vent tube.

    To prevent that from ever happening again I ran a seperate vent for the tranfer case.

    I also replaced all of the vac hoses from the transfer case vac switch all the way to the intake manifold. Several sections was already soft from the tranny fluid. I also ran a new line to the vac motor under the battery tray.
  • michael79michael79 Member Posts: 21
    i read alot of the post's about the problems of failed 4x4, mine was stuck in 4x4 for awhile and always thought it was a cv joint, i finely got it out of 4x4 but i found there was that atc blown fuse, put a new one in and it blew, i got to the tccm and checked the wires, did seem fine, i plugged the little cable in first and the fuse did not blow, hooked up the big one and pop, where is a good place to check. i have checked wires and seem good, i did not drop the gaurd under the encoder motor to check anything there, help would be appreciated.
    thank you all
  • michael79michael79 Member Posts: 21
    ok men, thank you, i think i read enough to understand that most likely it is the encoder motor. if not, i'll be back.
  • michael79michael79 Member Posts: 21
    i did find a bare wire under the brush guard that goes to the encoder motor, next to the connection it was rubbing on the shaft, going to the shop now they help me out, can not do it laying down with my neck. you all have given alot of insight for this problem. thank you
  • knowslittleknowslittle Member Posts: 1
    I am trying to repair my "encoder issue" by disconnecting my battery right now. However, I think this may not be the fix because reading everyone's post, my issue may be a little different. My 4Hi, 4LO, and 2Hi all work. Except what happens is that every so often the red light next to my Neutral, in between 4Hi and 2Hi, lights up, and when it lights up I cannot control whether I am in 2 wheel drive or 4 wheel drive. The dealership said it was my encoder and wanted $700+. Any other insight, or still feeling its either the encoder motor, encoder sensor or fuse? Thanks.
This discussion has been closed.