Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Chrysler 300/300C/300C SRT-8 Electrical/Lighting

This light has come on a few times. It is a small circle with an arrow like a one handed clock always pointing to 10:00. It is located at the far left side by the maint. indicator light. no explanation in OM. What is it for?
«1

Comments

  • pablo3pablo3 Posts: 5
    The small green light comes on when cruise control is set.
    Best of luck with the SRT-8, I am in love with mine.
  • To Howdee :)

    The light is telling you the tire pressure is low. Go to
    systems settings on the dash behind the steering wheel and go to tire pressure and it will show pressure for all tires.

    :(
  • I have a brand new 2006 300C and have had it towed back to the dealership several times after the battery has gone dead in my garage. The techs keep telling me that they believe one of the control modules that tells the computers to go to sleep is malfunctioning but can't pin point the problem. They keep telling me that all diagnostics run fine and can't find a problem. This just happened again after I parked the car on a Friday afternoon and by Monday morning the battery was dead. Anyone have similar experiences?
  • guestguest Posts: 770
    Did they check the cells in the battery?Just because its new doesn't mean it can't be bad.
  • Have you found a solution yet? I am having the same experience. The only difference is that the car was dead on the lot so the dealer gave me a new battery before delivery yet I still have the same problem.
  • srt8usrt8u Posts: 5
    definitely cruise control , I have an 06 chrysler 300C SRT8.
    Just push the small rod on the left side of your column to activate or deactivate.
  • Ok I have a 05 300 with 50k miles and never had a problem. This happened yesterday, when I got home and turned the car off it did not shut off, I pulled out the key and afew secs later it shut off. About 5 secs after that everything came back on again (dash lights, warning lights, radio) I keep messing with it and it finally went off for good. Well this morning I get in and crank it up, go to back out of the drive way and it would not go, check engine light was on, ABS and other warning lights were on. I turn the car off wait for 5 secs and crank it back up again and it has run fine since. I dont know much about cars but it sounds like a Relay to me but wanted to ask on here.
    Thanks,
    Rocky
  • kzl600kzl600 Posts: 1
    I have a 2005 300C and have been having some intermittent issues with the windows not working. The dealer replaced a relay to fix one then it jump to another. This does not always happen... Then my auto lights don't always come on at night. Now my radio volume is now not working... It can only be set to a volume of 1.. Again all this is a intermittent problem.. Has anyone seen this on this car? Any ideas??? I love the car but this is driving me nuts!!
  • kass1kass1 Posts: 1
    Thank you got your post, at this moment my 2006 300c hemi is at the dealer, since we have purchased it, we have had 2 new battery installed, we took the car to Florida from Canada, worked well till we parked it for a week and had to have it flat bedded to the nearest dealer..Does anyone know what might be the problem? Helpppppp
  • mrcu2000mrcu2000 Posts: 2
    I am having the same problem with one of my windows. Unfortunatly I just passed my warranty and they won't fix. I have noticed other discussions with the same problem. I love the car too, but I don't know that I will ever buy a Chrysler again due to the continuous malfunctions they can't seem to fix! Good Luck!
  • mrcu2000mrcu2000 Posts: 2
    I am wondering if anyone has had any problems with their 2006 300 not starting due to a problem with the security device? I took the car in to the dealership and they said this is just something that sometimes happens. Unfortunatly they had no advice as to how to prevent it in the future. Unfortunatly I am 2600 miles past my warranty and the part will cost $400.
  • I have a 2006 300 Touring, the other day while driving @60 mph, the dash lights went dead, the blower went dead for the AC and my gauges went dead. The car kept running fine, just lost electrical power I assume. This happened about 7 or 8 times within a 15 minute trip, but has not happened since. Has anyone else had this happen to them?
  • xtecxtec Posts: 354
    I have had this happen on some of my cars and it was always the ignition switch wasn't on the run position all the way.Next time it happens jiggle the switch and see if that helps.
  • Ten days ago, my son brought my 2005 300 to the dealer, my complaint being the RR speaker crackling. They diagnosed the RF door speaker was not working and ordered one. I checked and the 2 front speakers and both doors don't work and the crackling from the rear stopped. While returning from a trip, about 2 hours into driving the AC high blower stopped working. An hour later it came back on. The next day the same thing happened after 2 hours driving. Once home, I tried to unlock the doors from the passenger side. The lock button on the door don't work. All these malfunctions at the same time. Any ideas or solutions? I certainly don't want to rebuild the electrical system one part at a time. :(
  • xtecxtec Posts: 354
    Is your car still under warranty?Thats why I buy the Extended warranties.People say its a waste of money,but your case proves anything can happen and it would have been a good idea to get it.When you buy A first year model these are problems that happen.I hope you get it fixed.Good luck.
  • Regarding the windows - I can almost guarantee it's not a relay. It's the window motor stator that's gone bad and the motor will need to be replaced. I've had this issue with 2 of my windows, 1 front, 1 rear (and I believe it is a very common problem with Mercedes, too).

    The interesting thing is that if you slammed the door, it would jiggle the motor just enough to be past the bad spot. Since I've had the motors replaced, the problem has not come back.

    It seems weird that the other problems have appeared serially. how much do you trust the dealer you're using for repairs?
  • Did anyone ever find out what battery/electrical problem was? I have a 2005 300C that had a dead battery after sitting for about two hours. The dealer replaced the battery. About a week later the battery was dead again. The battery tests fine and now I have to wait for my battery to drain again & tow the car in before they will try to figure it out.
    Help!
  • My 05 300 headlights have occasionally flickered since I bought the car. Recently, at 47K miles, the instrument lights have begun to flicker too. A dealer said they checked the headlights and cleaned the bulb contacts. That seemed to help for 10K miles, but the flicker has come back. I haven't had the instrument light flickering checked yet. Any suggestions?
  • xtecxtec Posts: 354
    There is a service bulletin for your problem.Service bulletin #1800305,the date this came out was Jan.12 2005.Its for Headlights fluctuation and interior lights fluctuation.Your dealer should know this and why they don't is something I can't understand.This bulletin should take care of your problem,so when you go back,tell them to check your car for this bulletin and it will tell then the fix.Good Luck.
  • I have a 1999 Chrysler 300m with a short somewhere in my instrumentation where I get an intermittent series of warning lights that includes all of the warning lights on the instrument panel. The dials will go dead (Tach, Speed, Fuel, etc. And in its most extreme the A/C system to become erratic. The symptoms will sometimes last a few minutes, and sometimes will persist for hours or until the car is re-started. Can anyone give me a hint on where to start to diagnose the problem?
  • My navigation was working fine but now it's giving me and error saying disk not found. Any ideas my cd seems to be fine. Also, my driving lights are on constantly is there a sensor or something i need to change for them not to turn on during the day.
  • bdymentbdyment Posts: 573
    Driving lights are designed to come on when the car is started. They remain on until the headlights are turned on or on some models when the parking brake is set.
  • Chafle, I've had the exact same thing happen on my 2005 300 limited. At first I attributed it to weak contact (loose posts) on the battery connection in the trunk. But then it happened again. Occurs sporadically and without warning. Part of the reason I wanted to buy a brand new 300C (my 2005 was used).

    Everything was peachy, until last week I started the car at night and all the instrument lights lit up and didn't go away until I turned the car off and started it again. Definitely something going on with the computer. Very strange! I don't like it one little bit.
  • Hey all interesting problem. When I put my turn signal on, the daytime running light on the same side goes out. Also, sometimes when I put the turn signal on to go say right, the left tun indicator comes on. Any ideas would be appreciated.
    Darron
  • Three months later... this time I left my 2005 300C in a parking garage while shopping. When I returned the headlights were flickering on and off (who knows for how long). The battery was dead and had to be jump started. I checked to be sure the lights were in the off position and have no idea what caused the problem.
    This is getting really old.
  • kmolchankmolchan Posts: 1
    I have a 2005 300C with the same problems. The memory seat works for a couple of days then goes out. The headlamps don't come on automatically sometimes. The back windows don't always work. The radio resets the settings on it's own. Dealer says they don't know what is wrong.
  • pwargo1pwargo1 Posts: 1
    I'm just back from the dealer where they got me for s new battery 185.00us
    this is the second batt.in less than 3 yrs, about 18 mons each time .
    I was told the battery had a bad cell both times. once maybe not twice.I also have intermitten trouble with the auto up windows . this is a 2006 300c hemmi 44300 miles
  • smithedsmithed Posts: 444
    Somethings wrong there. The batteries should last longer than that. Next time don't go to the dealer. The battery shouldn't cost that much. $185 is crazy expensive for a car battery.

    My two cents: Next time go with and Interstate battery. :shades:
  • xtecxtec Posts: 354
    I think you answered your own question about needing two batteries.You state that your having problems with your auto-up switch,this could be drawing juice from your battery.I would check into replacing your switch.
  • gcsextongcsexton Posts: 1
    I have a 2005 Chrysler 300 limited. I recently took it to a dealer to have my computer reset because of flickering lights. (There is a TSB about this) However, when I picked up my car my cruise control no longer works. Any body else had this problem?
  • shironshiron Posts: 1
    Our 2005 Chrysler 300 has had the battery replaced twice under warranty. Dealer advised dead cell each time. 13 Jan 09, it died again and I replaced the battery with a larger, stronger after market battery for half the price. The dealer wanted $270.00 for a new battery and $80.00 to install it. 15 Mar 09 after sitting for five days I now have a dead battery again. Has anyone found what is wrong with these vehicle to cause so many dead batteries?
  • depetedepete Posts: 1
    I have my car towed in 6 time in the last 4 months. The dealer has replaced the battery 5 times and one alternator. If the car sits for more than 48 hours it will not start . Two dealers have run every test they know of and cannot find the problem. Anyone have any suggestions?
  • smithedsmithed Posts: 444
    You have a short somewhere. The dealer is not the best place to have this looked at. There are auto electric shops that are more experienced than the techs at the dealer in finding this.
  • Simple question - Have an 07 300C - Have had a large moth and a few flies get into the rear center brake light receptacle, and quietly pass away! In order to give them a decent burial I need to get them out of there, but no one, not even the dealer, seems to have a clue about getting inside there. Are the insects smarter than us? Need some help!!!
  • It is very unlikely that you got 2 bad batteries. You probably have what is called a "parasitic" load. That means something is drawing the power from the battery AFTER you turn off everything and leave the car. You can test the car yourself for a parasitic load with a simple 12 volt test light.

    Disconnect the NEGATIVE battery cable and hook up a test light BETWEEN the cable you just took off and the battery post. You are going to need a helper to do this test. Attach the test light clip to the battery cable you just disconnected and the other end to the battery post. This puts the battery back in service but only for testing purposes.
    If the test light comes on and it most likely will, then you have a parasitic load which confirms why the battery is going dead.

    Now, while the test light is ON, start removing fuses one at a time until the light goes off. Also, remove any relays if the problem isn't found with the fuses. When the light goes OFF, that is the circuit that is killing the battery because it is still drawing power. Have that circuit checked if you don't know how.

    If all testing fails to turn offf the test light, the Alternator could be the problem. If you know how to get to the Alternator, disconnect the large power wire from the back side. (This is a live wire when the battery cables are both attached). This large power wire is usually held onto the Alternator by a #10 Metric nut. Disconnect the wire and if the light goes out, you need an Alternator. Good luck!
  • jlb182jlb182 Posts: 1
    i recently purchased a 2006 300. The radio, screen, and navi all work perfectly, but when i try and put in a cd i'll push the load button then the disc number and all that comes up on the screen is "Disc Error" when i haven't even put a cd in the player yet. Has anyone had this problem or maybe know of a solution?
  • lacadelacade Posts: 12
    Had the same thing happen to me just yesterday. It seems like a mechanical problem. I gave mine a good whack (and I mean good) and it loads, ejects and plays CDs again.
  • Did you ever find out the problem, I have an 05 Chrysler 300 with electrical problems that will not stay charged for more than an hour or two, and none of my dash lights work, and sunroof has a short in it to.
  • While under warranty, the dealer could not duplicate the problem, thus could not find a resolution. The battery seems to hold a charge now, as long as the car is driven every few days or so. I took the car into another Chrysler dealer after a two week vacation and coming home to a dead battery. The battery was recharged before I went to the dealer and low and behold, they COULD replicate the problem...noting that the battery continued to have a drain when the key was off and removed from the vehicle. Unfortunately, the dealer informed me that they would need to remove the panel & dash to investigate further and it could cost upwards of $1500 to figure out which component was pulling from the battery and to repair. ...I now carry jumper cables everywhere I go.
  • I have a 2008 Chrysler 300. I purchased it used about 2 months ago. I recently had a problem with my wipers not shutting off. Even with the car off, the wipers will run. I have had to remove the fuse to shut them off. Since we have experienced the turn signals not working, intermittently as well as the radio. Has anyone else had this problem? Is it a problem with the computer?
  • How do I repair the dash light for the heater /ac control?
  • fra1fra1 Posts: 3
    2005 300C with dead speedometer. Suddenly my 300 C's speedometer went dead while driving. An ideas? 17,000 miles clocked on odometer which is working..
  • Hi, I have a 2006 Chrsler 300. When I turn the cruise "ON" the dash screen says "Cruise ON" but when I try to st the cruise nothing happens. Any idea what my problem may be? Thanks!
  • "Cruise On" means the cruise control is activated. When you reach your desired speed, you have to flick the lever down to "set" the cruise control. Check your manual if you have one- if not, write back and we'll get it straightened out.
  • Did you ever find out the problem? I have the same trouble with my 05 Chrysler 300. I have to charge my battery every time I leave my car off for over an hour. Also when it is charged, nothing works, including everything on the dashboard, my headlights stay on at all times while running, and they sometimes flicker.
  • Thank you for the information, Im going to take my car to an auto electrician & see what they say. I will let you know if they find anything out okay.
  • amroachamroach Posts: 1
    I had a problem with my 300C. When it reached 30,000 miles all of the dash gauges would turn off for about 3 seconds. Enough to scare me. For the next 20,000 miles I would take it back to the dealer every month, and maybe twice a month. The entire car started turning off, and I would have to put in neuteral and start it back up. As you know could not duplicate. Finally the service man said he called the extented warranty company, and they told him to check the battery. The battery was running on 275 amps, and was suppose to be at 730. The warranty company told him they had that problem before. New battery and have had no problem for 2 months now. I drive it every day.
  • pnelson1pnelson1 Posts: 6
    Any luck with the electrician? My car is back at the dealer. Waiting to verify the problem. I'm wondering if the battery amp issue posted recently is our problem.
Sign In or Register to comment.