-July 2024 Special Lease Deals-

2024 Chevy Blazer EV lease from Bayway Auto Group Click here

2024 Jeep Grand Cherokee lease from Mark Dodge Click here

2025 Ram 1500 Factory Order Discounts from Mark Dodge Click here
Options

Saturn S-Series Electrical/Lighting

belannafanbelannafan Member Posts: 1
Just recently, my Brake light started coming on, on my dashboard for several seconds or more then going back out. I checked the fluid and it was fine. The next time the brake light came on, I noticed that the needles for Both my Speedometer and RPM gages dropped to zero for as long as the Brake light was inlluminated. Once the brake light went off, the needles once again showed my speed and RPM (were functional). This occurs while I'm simply driving down the road. What could be wrong and how do I fix it? Thanks.
«1

Comments

  • Options
    morgan7987morgan7987 Member Posts: 1
    Well here it goes. I have a 1999 sl1 and up to now it has been a good car for my family. But now it loses power to the dash and the rpm and fuel gauges go down then back up for just about a 3 sec glitch. I though might be battery but replaced still have problem I though maybe speed sensor but then i thought if they are bad they are bad all the time right ?
    well if you got a clue to my car sl1 problems of power lose to gauges and fuel indicator going down and then back up and the rpm and speed gauges doing the same.but sometimes total power lose to everything. All power out to engine, lights complete power failure any commits please.????? :sick:
  • Options
    dmnteddmnted Member Posts: 2
    I'm experiencing the same issue with my 1999 saturn sw2 wagon. has there been any other resolution to this issue?
    I did notice when it happened that it was cold out side. This is not the first time it has happen to me.
  • Options
    viperskeeleviperskeele Member Posts: 1
    Hi, I've discovered through much searching that the alternators in these go bad and cause all kinds of wierd electrical problems. These alternators don't quit like a normal alternator does when it goes bad, they give a much weaker output, so all the electrical systems are struggling to keep up.
    First: The brake light is probably coming on because your emergency brake handle isn't all the way seated.
    Second: the brake light when it comes on is probably sapping enough power from the dash display module to drop your computerized stuff all to zero, Because of the low output from the alternator. Put a new alternator into it.
  • Options
    amonkeyamonkey Member Posts: 2
    Does this sound familiar to anyone... door locks clicking like the car is haunted. The battery dying for no apparent reason. Squeal coming from engine area, even after fluid and belts have been replaced. Alternator and Battery replacement. I gave my '96 Saturn to my daughter three years ago, and for the past two years it has been one electronic issue after another. Any ideas for a way to exorcize this vehicle?
  • Options
    cmelaucmelau Member Posts: 1
    i have a 97 and it did the same thing, i disconnected the lock on the drivers side and it went away, now i have a different problem, just so you know, i am a mechanic, now my fuel pump is shutting down, i replaced it and it still does it, i went to the relay. It wasnt there just a jumper wire, put drl relay in its place and it still happens, im stumped.
  • Options
    imjustsomeguyimjustsomeguy Member Posts: 4
    I'd like to inspect the air recirculation door, motor and linkage to determine why it seems to make no difference whether I put recirc ON or OFF...both choices produce lots of outside ram air rushing into the car, bringing in lots of pollution and pollen that drives my allergies crazy.

    But my Haynes manual makes no mention of where these are located, nor how to get to them without unnecessarily tearing the whole dash and subcomponents apart.

    Does anyone know how I can get to these items to check them for proper functioning and adjustment? If so please post ASAP - thanks!
  • Options
    96saturnsl296saturnsl2 Member Posts: 6
    Hi, i have a 1996 Saturn SL2 with 124k on it and for the past 10k miles the Low Coolant High Trans Temp Light, has been on, i've replaced the trans temp sensor and the coolant overflow tank, all to no luck, if you have any ideas or suggestions i'm open to them. This light is bugging me because its the only light on in my dash cluster.

    Thanks
  • Options
    satidlesatidle Member Posts: 5
    Thought I had a "new" issue with my SL1, maybe not. First, my rear window defroster stopped working. I replaced both fuses and switch module, still does not work. Mechanic suspects a short somewhere, somewhere too expensive to track down! Shortly after this waste of time and money, the Emergency/Parking Brake indicator started coming on intermittently. Once I used the regular brakes a few times, it would go off. Then it came on and stayed on ever since (over a month now). I must have checked the Emer brake handle 16 times now, it is definitely down/off all the way. I don't drive this car much, so it doesn't worry me too much. But that damn light is annoying! Does this sound like these other alternator related problems?
  • Options
    purplecarpurplecar Member Posts: 1
    I recently bought a 1996 Saturn SL1, and have been driving it for about 500 miles now out of nowhere my windsheild wipers come on by themselves. I played with the switch but found it to be in the correct position ( OFF ). Has anybody else had this problem. For something positive I checked my gas mileage 38 mpg.
  • Options
    timkarlbergtimkarlberg Member Posts: 3
    Same thing here (as the post at the top, with the speedometer and tach guage problems)! It's equal parts frustrating and encouraging to know I'm not the only one. The symptoms you described fit my problem to a "T". I drive a 1999 Saturn SW2, and have had this problem for about two years, very intermittently. Replaced the battery first because it was relatively inexpensive and easy. Seemed to work for about 6 months, then the unexplained phenomena starting popping up again. Mostly the goofy gauge stuff on the speedometer and tach. Finally replaced the alternator on a gut feeling and, again, seemed to fix the problem for another 3 months or so. Now it's back again, and I'm out of ideas. Any advice anyone?
  • Options
    cw_meekscw_meeks Member Posts: 4
    MOdern cars are very voltage sensitive.Check the voltage at the battery terminals with engine off ,then at high idle speed.AS far as I know there should be about 14.3 volts dc there at a speed just above idle.Wait, now do one more thing.Switch your digital voltmeter to ac mode and get a reading on the presence of any ac voltages.any ac voltage present should have very low voltage. those ac volts should only be a few tens of milivolts. check for loose connections to the alternator.check for corrosion inside electrical connections under the hood and around the engineand clean if req'd/ thank you
  • Options
    mcavicchiomcavicchio Member Posts: 1
    Hello, I have two power windows which intermittently get stuck . One is the driver's side, the other is the sunroof. They eventually go back into place after starting the car later on. I have tried everything short of replacing the switches for each window. I have cleaned the contacts and it seems like the contacts need to be replaced. Has anyone had similar problems and if so, was it indeed the switches? I know this would be a very costly repair and I"m not even certain it would fix the problems, because in order to access the switch for the driver's side, the middle console needs to removed to gain access to the area where the power controls are, a labor task, then to actually remove the switching mechanism and pay for the part of the new switch and then re-assembling everything. Has anyone been through this and know realistically close to what this might cost? If this even fixes the problem? The sunroof opens just so far, and then stops, and it retracts depending on how the button is pressed and how hard. This is what makes me think that's a contacts issue. But with the power window, it doesn't seem to matter how I lift the switch, it just does what it wants. One interesting caveat to the driver's side window issue is that if I'm trying to lower the window and it doesn't respond, after I shut the car off and before I get out, I open the door and then slam it shut, and voila! the window goes down....figure that one out! As far as the power sunroof, it only opens just so much, but then I have to "play" with it while another person sitting inside presses the button for it to close, then it closes from the little that it opened, but no matter what, I suddenly can't get it to open all the way again. I never had a problem with it before, It was always smooth in opening and closing...now this!!
  • Options
    west488west488 Member Posts: 1
    I could not find an L series group but suspect that most of the electrical systems in Saturns are close to the same.
    My problem is that when I first start the car in the am after an all night rest, the signals may or may not work, about a half hour later they will always start working.
    I also have a problem with the headlights (auto day/night system) in that if the headlights are on when first starting in the am, I park the car at school and the headlights will not go off. It is daylight when I reach my destination, but have to use a flashlight to shine on the dash sensor to get the lights to turn off. Bad sensor maybe?
    Any info would be appreciated.
    Thanks St.West
  • Options
    dkscaddydkscaddy Member Posts: 1
    My passenger side window works just fine in my 2002 SC2 Saturn. The window on the driver side goes down with out a problem , you can even stop it half way down. You just hope the best when it comes to getting the window up. Right now, it is down all way and refuses to raise. There has never been a pattern as to when it will go down and come back up and the same trick never worked 2 times in a row when it came to raising it. Has anyone else had this problem? Is this a problem that can be fixed in the driveway, or does it need to go in to the shop? Any suggestions would be appreciated !
  • Options
    timkarlbergtimkarlberg Member Posts: 3
    I have a 1999 SW2 with the same problem on the rear passenger window. I've figured out a relatively simple and (so far) trustworthy fix. The window always goes down as far as it should, with no problems. Most of the time, though, if I only put it down part of the way it doesn't go back up again. In these cases, I have to stand with that door open, and pull it up manually with two hands--one on the inside, one on the outside. As long as I always roll the window ALL THE WAY UP AT ONCE or ALL THE WAY DOWN AT ONCE, there are no problems. Give it a try.
  • Options
    timkarlbergtimkarlberg Member Posts: 3
    I finally figured out the problem (two batteries and an alternator later). I have a 99 SW2 with the same issues--see my post further down. It was the Vehicle Speed Senser. I picked one up at my Napa shop for a few bucks and had it in the car after about 30 minutes of monkeying (it's not the easiest to reach). Problem solved for good. That was several months ago and not the slightest hint of trouble since. The bad news is the money and time I spent replacing the other things. Oh well; it's a happy ending.
  • Options
    skausskaus Member Posts: 11
    Hi All
    Yesterday I was 95 miles from home and I had a transmission leak from the filter.
    I lost 3 qts of oil. I replaced the filter and put 3 qts back . The reason I looked under the hood was 2 fold. I kept stalling at my destination and the ABS light was on. The engine would stall only if I applied the brake pedal.

    Six hrs later in panic mode ,having to drive 85 miles back home I found 1 solution.
    Remove fuse from brake and I made it home. If I but the fuse back in and press the brake pedal the engine will die .

    Okay my transmission was soaked with oil. I cleaned off all oil. I checked the wiring harness and it was clean .

    **In front of transmission are 2 sensors or switches.
    If I look at wiring diagram it shows Brake transmission safety interlock ,Brake sense switch and stop light switch all in series. Could one of these be my problem?
    Another thing when I step on brake pedal the dash board left and right signals light up dimly .
    Today I put the brake fuse back in and everything is okay.
    I do not trust this car at the moment. Anyone have a clue

    Please let me know what you think. Thanks
  • Options
    macgloinnmacgloinn Member Posts: 1
    I have a 96 saturn SL2. Both the dash light and the rear lights keep blowing a fuse They both stay on for about 2-3 minutes and then blow again. Also the chime no longer works when the door is open with the lights on. Any ideas?
  • Options
    quick3quick3 Member Posts: 1
    I have a 1993 SL2 with 120k on it. The fan won't come on? It's not the relay and not the fan itself? I am lost...could it be the the computer? I put a whlole new top end on this car.. If I want to drive it I would have to hard wire the fan...

    Any help or suggestions would be great ..

    Thanks,
    Rick
    Phoenix, Az.
  • Options
    sarahmac6sarahmac6 Member Posts: 1
    I have had my Saturn for a year and a half now and many electrical problems have arose and i wonder if they are related/are caused by the same thing

    here they are:
    -my rear window defroster never worked (bought it in the summer so i didnt notice)
    -my gas gauge stopped working, then my car wouldnt start...fuel sensor was broken according to the dealer, and was fixed for about $700 :(
    -all my dash lights went out
    -my driver side window stopped working...the dealer said it was both the switch and the motor (not sensible to me) but i havent had it fixed yet

    is there maybe some overall electrical issue with my car causing all of these individual problems? i really dont want to keep spending hundreds and hundreds to fix them but not actually find the source of the problems
  • Options
    442dude442dude Member Posts: 373
    Does the fan come on when you turn the AC on???

    Here's a guess based upon not being there...have you ever replaced your engine coolant temp sensor (ECTS) If the car doesn't know its hot the fan won't come on. Also, the S-series fans come on when the temp needle is just about to enter the red zone, higher than most....
  • Options
    robstuffrobstuff Member Posts: 5
    My power door locks open and close very intermittently whether or not the key is in the ignition. I have tried replacing the relays but the problem continues. The only way to stop the locks is to remove one relay and break the circuit. Could it be the computer? Any suggestions? Thanks
  • Options
    checharleychecharley Member Posts: 4
    i need help my saturn cranks and runs great for about 2 miles then it shuts itself off. we have put new spark plug, wires, new fuel filter, fuel pump and valve cover gaskets
    coil packs and intake modual valve. none of this has helped. does any one have a clue? also the engine fan will not come on
  • Options
    starrycj1starrycj1 Member Posts: 1
    I drive a 2000 SL1 with about 150,000 miles. I have a 2 week history of weird events, and I'd like to go to the mechanic a little better informed.

    Event 1- I start the car and start to back out of the parking lot. All of my indicator lights stay on and I have zero gas and zero speed. (though I have gas in the tank and am moving.) I turn the car off and the engine cranks but won't turn over. So, I disconnected the battery waited 1 minute, reconnected, and it started fine and everything worked.

    2- Later, I was driving and my fuel indicator rapidly fell to 0, I lost speed indicator and my indicator lights went on (after driving a while this time). I pulled over, turned off the car and restarted. Everything was fine.

    3- Again, I pulled out of a parking lot and lost power steering. I rolled out of the way, and after a few tries with just cranking, the car started and everything was fine.

    4- Last night, I left work and it wouldn't crank at all. My clock was even blank. But the radio would work when I turned it to the fan/ radio on position. I disconnected the battery, 1 minute, reconnect, and it started fine. Started fine this morning too.

    I'm suspicious about the recent hot weather here having a part in this, but it wasn't hot every time. Probably not the battery because most of the time it works.

    Any ideas? How much is this going to cost me?
  • Options
    nshorenshore Member Posts: 1
    I drive a 2002 Saturn SL and have had various problems (steering column, ignition switch issues), which had to be fixed at the dealership. Now, my instrument panel is basically dead. I have no readings for my gas gauge, odometer, speedometer, rpm, or any sensor readings. My turn signals, emergency lights, and inside and outside lights work properly. My clock, cd player, and air work as well.
    I've troubleshooted some and have determined that it's not an alternator or fuse problem. None of the relays are specific to that area either. I believe I either have a short at one or more of the wires at my instrument panel or it's a computer chip problem. The problem does seem too specific to be a computer chip problem (no fuel injection, or any other problems.)
    The problem is finding a schematic or wiring diagram for this area. I don't want to remove the dash and pull or adjust the wrong wire (air bag) and cause some serious problems.
  • Options
    checharleychecharley Member Posts: 4
    it was the crank shaft positioning sensor. thanl you fior your help
  • Options
    cordoo49684cordoo49684 Member Posts: 3
    i have the samething going on what did you find out
  • Options
    cordoo49684cordoo49684 Member Posts: 3
    i have a 2002 saturn s series the head lights will not go off ,i turn off the car and the lights stay on : :mad:
  • Options
    keith40keith40 Member Posts: 1
    i have a 95 sl-2 fan was working fine, one day it just quit. check fuse, it;s fine.
    any ideas??.. first time here. bye the way...it has 178,000 on it and runs
    like a top. from what i've been reading, i'm very lucky.

    thanks keith

    great form...
  • Options
    miltrichmiltrich Member Posts: 1
    my daughters 96 sc2 is having same problems. wipers intermittently turn on. Come on at starting of car, won't go off. Did you ever find a fix?
    THANKS MILTON
  • Options
    downstiggerdownstigger Member Posts: 1
    My stepson and myself installed an after factory stereo and now when I start the car within seconds the service light comes on and stays on. We have tried disconnecting the positive post on the battery and waiting as long as 15 minutes. Is there something I am missing? Everything works and I have had no problems with the car since I purchased it 2 weeks ago. Any suggestions, before I spend the money to have it hooked up to the computer code reading machine. :confuse:
  • Options
    442dude442dude Member Posts: 373
    Go to Autozone or another auto parts store - they will read the codes for free.

    Make sure you get the actual codes and then post them here. I'll keep an eye out...
  • Options
    wyelbillwyelbill Member Posts: 3
    The service light stays on but not the service engine soon light. Oil change, plugs O2 sensor new. Had it scanned at Auto Zone came up with no codes. Any ideas how to clear this?
  • Options
    442dude442dude Member Posts: 373
    At the Dealer...they're Saturn specific codes and not every reader will read them. Its trying to tell you that something is wrong but its not emissions related. Sometimes its as simple as a burned out bulb somewhere.
  • Options
    wyelbillwyelbill Member Posts: 3
    Come to find out, the tailpipe/muffler bracket was broken completely off. Made a new one myself. After about 10 minutes on the road and another engine start the light was out and has not come back on. Cost: 2 hours of my time.
  • Options
    gnutbustergnutbuster Member Posts: 1
    I have a 1996 Saturn SL2 with power doorlocks and windows (including a non-functional moon roof due to leaks it has been sealed shut ... that's another story). The car suddenly started honking all by itself and I had to remove the fuse to quiet the noise. This happened around the same time that the power doorlocks started clicking, I had to remove the fuses to prevent this from draining the battery. Doing w/o the power door locks is something that we can deal with but, not having a honk is a safety issue. This is my daughter's primary mode of transportation and I need to know that she and the other occupants will not be in danger of possibly being unable to warn another vehicle of a pending accident because of not being able to toot the horn. I know that somewhere amongst yards of wires in the electrical system these two items are connected, when they both functioned properly the horn would sound when the doors were locked using the remote. Has anyone run into a similar set of troubles? Not sure where to start with tracing the troubles.
  • Options
    argus462argus462 Member Posts: 1
    Hi,
    Bought a 96 SL1 SOHC 3.5 years ago with 261,000 km (now over 362,000) on it. It's a plain jane with minimal electricals on it- lights, heater, rear defog, and radio.

    The first year it was fine, but has gone through 6 replacement alternators since (just put on #7). The battery has been changed twice with the alts. Some of those alts have failed in as little as a week, others lasting 6 months. Some of the alts were making a low volume med-high pitched whistle, after failure.

    Both my mechanic and I are stumped. We both have never seen or heard of such an occurence before.

    Anybody have ideas on what is causing these failures?

    Thanks,
    Argus462
  • Options
    boregard9boregard9 Member Posts: 1
    it seems that it is possibly the window motors. I have experienced window motor failures on different cars. One way to find out is to have a helper and one person sit in the car and actuate the window. If it fails to operate, bang on the door with the heel of your hand. If the motor has bad contacts or brushes as most electric motors do, it will start to operate. This will not work on a window motor that has completely failed. Depending on the particular model Saturn, go to ebay motors and search of the switch. I am about to replace a switch in my SL 4 door and they run from $15 up. Also the middle console is quite simple to remove. Generally you will need to remove the panel from the front kick plate by gently prying it off. Now, remove the screws. At the back of the console in the top center you will find two screws. after you remove the two screws, lift up on the real of the console and slide it back about an inch or so. Go to the front and disconnect the wiring for the cigarette lighter and the lamp. It should lift off. This procedure may vary somewhat depending upon the model of your car.

    Stan Cobb
    Savannah, GA :)
  • Options
    cookieman1cookieman1 Member Posts: 2
    I had the same problem. It was the turn signal switch. I ordered one online for $40.00 total cost. It's very easy to install yourself. Disconnect the battery. Wait 3 or 4 minutes. I was told this will disable the airbags.
    Simply pull the top section of the plastic steering column apart. This allows you to see the turn signal switch. Unplug the existing switch and compress the top and bottom tabs on the switch, then slide the switch out. Push the new switch in and plug it in. Snap the plastic steering column back together. Hook battery back up and your done!
  • Options
    cookieman1cookieman1 Member Posts: 2
    Has no sunroof. Water gets in car during heavy rains when car is parked. Recently had windshield replaced but I think it was leaking before that. Any ideas appreciated.
  • Options
    misterbaatardmisterbaatard Member Posts: 1
    Hi. The rear defog on my '99 Saturn sc won't work. The dash light for the switch works, but it won't actually switch on. I've replaced the interior fuse and the switch itself but still no results. Any ideas? Thanks!
  • Options
    hothandhothand Member Posts: 1
    Just wondering if you ever found your problem. I am having the same problem with a 1998 SL1 and after a month looking for the problem wired the rear lights on a separate switch. Another problem just cropped up, the HVAC air circulation fan quit working. fan, switch checks out OK. was trying to get to the resistor but don't know how to get to it, took the dashboard off but duct would not budge. This might also need a work around but would really like to the repair.
    thanks,
    Stan.
  • Options
    1998lincoln1998lincoln Member Posts: 108
    Make sure you have a good engine to fire wall ground, if you have to, install a ground wire(14 guage)from the engine to fire wall ! Sometimes it will lose ground,and you will experence the same problem you are having!
  • Options
    danieldkkdanieldkk Member Posts: 9
    edited March 2010
    My 2002 Saturn SC1 122K mi just developed the horn on condition suddenly. Were you able to solve your problem?
    Also when I bought the car 3 years ago, the dash lamp for the temperature gauge side has been out.
    Any help would be appreciated.
  • Options
    tflantflan Member Posts: 1
    Hey nshore. Did you find the problem to the issue you posted about the instrument panel being basically dead? I have a 2001 saturn sl1 and have the exact same issue. In fact, I drove it for approximately 20 more miles when I noticed the dash issue and then it died. It will turn over but just won't start. I'm stummped as to what it could be. Would be really interesed if you solved your issue and if you could give me a little direction.

    Thanks,
    Tlflan
  • Options
    dkbrandydkbrandy Member Posts: 4
    How did this electric issue get resolved? My in-laws have a 2002 Saturn with electrical issues no fuel gauge, speedometer, gauges, etc. car dies, but when restarted seems ok for a while. Its been in their local auto repair shop running up the bill with no resolution. Can anyone advise?
  • Options
    dkbrandydkbrandy Member Posts: 4
    Did this issue ever get resolved. Similiar issues with dash gauges, car engine dies after full stop, etc. Do you recall what the problem was? Please share if possible.
    thanks much!
  • Options
    dkbrandydkbrandy Member Posts: 4
    2002 Saturn with electrical issues no fuel gauge, speedometer, +gauges, etc. car dies at a full stop intermittently, but when restarted runs great again until the next glitch. Took this auto to the local repair shop ... ran diagnostic tests .... no resolution. Bill $300+ now with no resolution & no repairs. Can't afford this! Any ideas?
  • Options
    jwrong02jwrong02 Member Posts: 2
    I have the same issue except my car doesnt die when i lose the gauges if i tap them they normaly come back up. if I am running the ac i have to turn it off & then back on because it stops blowing cool air when the gauges go out.
  • Options
    dkbrandydkbrandy Member Posts: 4
    edited June 2010
    UPDATE Ref: #53: Relatives picked up the car. IT is not stalling- elderly relative misstated issue. Broken is gas gauge, radiator/heat gauge and odometer off. Air bags not funcitoning. Paid $358 for nothing. Any ideas?
Sign In or Register to comment.