Subaru Legacy Wagon Hesitation problem

carnut114carnut114 Member Posts: 3
Hello, I have a 1998 subaru legacy gt wagon 2.5 auto. When taking off from a stop it has a hesitation like the engine tries to almost die out then the rpms comes up and it's fine. It does not do this all the time just here and there. Sometimes the check engine light comes on and when it does it and reads knock sensor. What do i have to replace to get it to stop doing this?

Thanks Eric


  • carnut114carnut114 Member Posts: 3
    This is about a 1998 subaru legacy gt wagon 2.5
  • grahampetersgrahampeters Member Posts: 1,786

    It sounds like either ignition or fuel delivery problems. If it is fuel, a good start point is to add a bottle of top engine cleaner to clear injectors etc. and possibly shift to a high octane, detergent added fuel such as Shell Optimax or BP Ultimate (there will be something similar in the US).

    If that does not clear it, try looking at plugs (look up what clean plugs look like on the net) and possibly replacing plug leads.

    After this stage, you are in to spedning some money with a good service agent. Ultimately, this may be the most economical route to investigating the problem.


  • carnut114carnut114 Member Posts: 3
    Hello, I have decarbed the engine twice with sea foam ( disolves carbon buildup) and one other fuel injector cleaner. I have put new boch platinum spark plugs, new fuel filter, pcv valve. The spark plug wire look like new. I think it might me a throttle position sensor or a map sensor. Possibly a mass flow air sensor not sure.
    Thanks Eric
  • ateixeiraateixeira Member Posts: 72,587
    If the wires are original, they're 9 years old now. Swap them out even if they do look new.

    Next thing to try would be the ignition coil, about $80 on-line.

    My '98 Forester is running much better after those changes. A chipmunk had chewed my wires (!), but it's running smoother than even before that happened.

  • bailey21bailey21 Member Posts: 4
    Try to also clean the throttle body. Pull out the air filter where it attaches to the throttle and inspect for sludge or builup as it could possibly create the effects that you are experiencing. This could be a cheaper route to solving your problem before you make any other expensive purchases in trying for a resolution. If you have any luck with this let me know as i had similar problems.
  • benmullin333benmullin333 Member Posts: 1
    Any progress on this? I'm having the exact same issue!!
  • pvonhaam1pvonhaam1 Member Posts: 1
    Me, too. frequent stalling out of standing position. and a pretty loud "clank" when releasing clutch. Bucking in the engine, too, which is driving me crazy.
  • pathtomaxpathtomax Member Posts: 215
    I have had it for some time now. Every once in a while, I will press on the gas, and just wait for the Outback to decide to proceed. It is usually in my driveway first thing in the morning. Any other time, it is in parking lots etc.
  • mdbonjrmdbonjr Member Posts: 5
    Having the same problem with a '93 legacy except in this case it is a bit more noticeable. The car idles ok, but when you try to give it gas it bogs down. If you play with the gas pedal it will rev up but if you put it in gear, forget it. We've swapped out the TPS, IAC, MAF, and the knock sensor. We've cleaned out the throttle body and the intake manifold. At this point, we're at a loss. We've also swapped out the computer to no avail. I know the injectors are firing but could they be clogged up beyond cleaning or might the fuel rails be an issue? Any further advice would be greatly appreciated. Thanks!
  • rx7shadowsrx7shadows Member Posts: 1
    I have a 2000 legacy gt, I got it with about 130k on it and when I picked it up it ran like a million bucks. 4k later and I want to shoot it. It started acting up and I am lost at this point. It idles a little shaky sometimes, no problems when it is in park, it will rev as high as you wanna take it. Put it in drive and it will go fine for awhile, but whenever you punch it, it starts acting up. Bouncing back and forth, losing power. It sounds like the timing is way off, but I just tore it apart and the timing belt is right on. There is no engine light, so I am lost. I took the intake off and checked every sensor on it, cleaned all the carbon off everything. Installed a new fuel filter. Injector cleaner, high octane, damn near tryed everything. someone give me an idea here.
  • gentzelgentzel Member Posts: 1
    Knock sensor?
  • paisanpaisan Member Posts: 21,181
    Plugs, wires, ignitor/coil-pack, fuel filter, air filter, fuel pump, alternator,

  • ateixeiraateixeira Member Posts: 72,587
    Turned out to be the ignition coil ($80 from any Subaru parts wholesaler) in my case, when it wasn't running smoothly that is.

    I did the things paisan suggest in order, though. First a tune-up (plugs), then plug wires. Then ignition coil.

    That last one did the trick. Turns out a chipmunk had chewed up my wires and the coil failed. :sick:
  • edub763edub763 Member Posts: 2
    I replaced and reset the timing belt, no codes show any problems. I also replaced the plugs, wires and coil, but still have no power when reaching inclines (hills). What else could the problem be?

  • xwesxxwesx Member Posts: 16,289
    Dirty fuel injectors? Clogged vacuum system? When is the last time the PCV valve was replaced?
    2018 Subaru Crosstrek, 2014 Audi Q7 TDI, 2013 Subaru Forester, 1969 Chevrolet C20, 1969 Ford Econoline 100, 1976 Ford F250
  • edub763edub763 Member Posts: 2
    I've changed the PCV valve when I changed the plugs, wires and belts. Let me give a brief history on the vehicle, I was driving home from work and the timing belt snapped. I replaced it and had the car sitting for almost 2 years. The replacing of plugs, wires and pcv valve were done in the last month. When I reach inclines it acts as if it doesn't want to move. I'm at a loss. the number 1 and number 2 cylinders have no spark.
  • xwesxxwesx Member Posts: 16,289
    Oh, wow. Okay, that certainly changes things.

    No spark at all in #s one or two... the coil pack is operating properly? If so, then I can only think that it perhaps it is related to the timing, which is controlled by a trio of sensors: knock, crankshaft, and camshaft. At least, I think it was controlled by the sensors in '93, but I am not certain. If it is, the knock sensor retards timing in the event of detonation, while the crankshaft and camshaft sensors determine when to fire the plugs. They are mechanically based, with the crank sensor reading TDC position on the crankshaft sprocket and the camshaft sensor operating off a set of magnets embedded in the upper crankshaft sprocket on the driver side of the vehicle. Perhaps there was damage to one of those sprockets or one of the sensors. I would guess the camshaft sensor and/or sprocket is the most likely culprit if that scenario is true.

    Hard to say though - all kinds of bad things can happen when a timing belt breaks. :sick:
    2018 Subaru Crosstrek, 2014 Audi Q7 TDI, 2013 Subaru Forester, 1969 Chevrolet C20, 1969 Ford Econoline 100, 1976 Ford F250
  • mvgmvg Member Posts: 2
  • chinookcptchinookcpt Member Posts: 3
    Hey there,

    i got the exact same problem on my legacy brighton 2.2 1999. Also tried the sea foam cans and fuel injector cleaner. Both oxygen sensors, plugs and wires have one year, new fuel filter and I've just changed the mass air flow and knock sensor, but still nothing does the trick... and still no check engine...

    Have you solved your problem finaly? Did anybody?

    Somebody knows anything new? Thinking about changing the ignition coil after reading this thread but, did it help anyone?

  • bdzin1bdzin1 Member Posts: 1
    Anyone else notice a persistent hesitation? I have had a hesitation since new, I had it back at the dealer and each time they tried to tell me it would be fixed on the major service, they had no issues with it being reported. They changed the coils to no avail. I took the service manager out for a ride and we didn't have to leave the starting spot to notice it. He said that it was nothing. So I asked to go for a ride in his car. He said that wasn't fair because he didn't own a Subaru. I said why, because they have a hesitation problem. I had an Inpreza loaner and that car didn't have any such problem.

    So I was an idiot and waited and now even the lemon law here in CT won't help me.

    The hesitation is right as you attempt to accelerate from a stop. I can't depend on the car to get the 'jump' at a light so I have to sit and wait. I know if I was a teenager this would kill me!

    I'd be interested to hear everyone's comments on this subject.

  • saedavesaedave Member Posts: 694
    My 97 Legacy had the same problem. The cure (after much trouble with the dealer) was replacing the knock sensor.

    Needless to say, I bought my 2005 Outback 3.0R from a different dealer.
  • chinookcptchinookcpt Member Posts: 3
    Since I've already changed my nock sensor 2 weeks ago, I'm looking elsewhere... Did your "trouble dealer" do something else or did he tried something else before changing the knock? That could maybe help me troubleshooting the damn car...

  • saedavesaedave Member Posts: 694
    I seem to remember that mounting the sensor on the engine had to be done correctly for proper operation. Details have gone from memory

    Did you replace the knock sensor yourself or did the dealer do it?
  • chinookcptchinookcpt Member Posts: 3
    I did it, but the proper way. Anyway, my hesitation problem begun before I changed my knock sensor, and I had a CEL saying the knock was out of range. I changed it, deleted the code, and it hasn't re-appeared during my Montreal-NY city - Montreal trip last week-end... So I am pretty sure that I installed it correctly, still looking for the problem though..!
  • xwesxxwesx Member Posts: 16,289
    Now that you have the knock sensor replaced, perhaps it is a good time to reset the ECU/TCU memory so it can relearn your driving habits. If you want to try it, you can easily do it by pulling the battery cable for a while to let the system backup power drain.
    2018 Subaru Crosstrek, 2014 Audi Q7 TDI, 2013 Subaru Forester, 1969 Chevrolet C20, 1969 Ford Econoline 100, 1976 Ford F250
  • bshifty73bshifty73 Member Posts: 1
    stopped running on hwy signs of any issues at noises...nothing! mechanic 2day tells me timing belt...replaces belt and starts it up...2 out 4 cylinders are running...he tells me they are shot...everyone is telling he is nuts! no way this could made no noise! we even tried turning it over yesterday and didnt grind or seize or nothing....Is guy trying to take me for a ride? Getting a second opinion hopefully tomorrow....Any suggestion?
  • xwesxxwesx Member Posts: 16,289
    What engine does it have in it? 2.2L or 2.5L? The 2.2L is a non-interference engine, so there should be no damage due to snapped timing belt. There may be other damage, like a camshaft or crankshaft position sensor, that is causing the lack of spark in those two cylinders (which two are they?). If it is the 2.5L engine, that is an interference engine (meaning the the pistons can contact the valves and cause physical damage if they are out of phase). However, there would be noise... a very painful, crunchy noise... if this happened. I would double check to make sure the belt is aligned on the camshafts and crankshaft correctly first (it can be a pain in the butt if the belt broke, because the camshaft sprockets go all which-a-way), then look to make sure there is no physical damage to the sensors.
    2018 Subaru Crosstrek, 2014 Audi Q7 TDI, 2013 Subaru Forester, 1969 Chevrolet C20, 1969 Ford Econoline 100, 1976 Ford F250
  • ateixeiraateixeira Member Posts: 72,587
    Plus it sounds like that mechanic created the problem, so I still might go to a different one, who knows boxer engines.
  • lomo50folomo50fo Member Posts: 1
    I have a 2007 Impreza. Got it at 6000 miles. At around 30k miles 4th gear acted like the syncro was gone and grinding. It did this for 5 or 6 k miles. The very day I took it to the dealer it stopped grinding and started working as it should.. It stayed that way until about 58k miles and has done it ever since. It now has 67k on it. Any thoughts?
  • newsubieownernewsubieowner Member Posts: 1
    Have you looked into the TPS (throttle position sensor) my 98 subarau legacy 2.2L had the same issues and i put a new TPS in it and it seemed to solve the problem.
Sign In or Register to comment.