Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently bought/leased a new car online and requested a home delivery due to coronavirus? A reporter would like to speak to you; please reach out to [email protected] by 4/2 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

1999 Chev Suburban - Hesitation / Engine Rumble Going Up Hill

sswannysswanny Posts: 5
edited March 2014 in Chevrolet
We have a low mileage 1999 Subarban 1500 4x4 (60,000k or so). Accelerating up hill (usually steep) can occasionally cause the Burb to start to shudder and slow down. Almost like it missfires on one cylinder, or takes too long to shift down, and cannot recover. The engine warning light comes on and we have to slow way down for a time before it returns to normal. Once it recovers it drives fine. Shop guys can't seem to figure it out. Any suggestions?

Comments

  • tidestertidester Posts: 10,059
    This should help: Engine Hesitation (All makes/models)

    tidester, host
    SUVs and Smart Shopper
  • sswannysswanny Posts: 5
    Umm ,, no. Giving me a 2421 reply thread did not help. And trying to parse that to find out what TSB actually is is next to impossible.
  • kiawahkiawah Posts: 3,666
    Well if you think someone is going to have some crystal ball that magically going to identify and fix your problem, based on the limited symptomatic info you provided....I think you'll be disappointed. The forum suggested would provide a number of posts that when read might provide a number of hints of things to look at that you might not of thought of before.

    Your problem could be caused by 100's of different things (e.g. fuel or fuel delivery, compression/head gasket, timings, computer, electrical, any number of sensors, etc).

    I personally approach problems 2 ways, either you know where the problem is and drill down to find the failing component.....or it's a process of elimination where areas are eliminated one by one and proved not to be the problem, until you get to the point that it must be the thing that is remaining.

    Hard to know what all you've looked at so far. Have you tried a compression test on all the cylinders to know that you are working with a sound set of pistons, valves, head gaskets, and timing? What error codes have been recorded in the OBD computer? Are you still on the original plugs/wires/distcap? Have you pulled all the plugs to look at how they look and are burning? Do you know that your fuel pump and filter are delivering enough fuel at high enough pressure?
  • No I don't expect a crystal ball diagnostic. And I had read a number of the posts and found nothing similar that is the reason I posted in the first place. I couldn't find anything similar. Granted I didn't read all 2400+ posts.

    More information:
    -Under load the Suburban sometimes bogs down and shudders going up hills.
    -The check engine light comes on at that time. Sometimes it goes back off once you return to normal driving conditions.
    -Re-seating the gas cap does not help.
    -Computer says I have misfires in 3,4,5.
    -Compression and other tests find no problems at all.
    -We have relatively new plugs and this condition has occured both before and after the new plugs were added.
    -It has recently (within the last year or so) had a major service where the replaceable parts of the ignition system, Dist cap, wires, plugs, etc were replaced.
    -Our local dealer (Roy Robinson in Marysville) said it was carbon fouling in the heads but when we took it to a different shop they said there is no more carbon than should be expected and the carbon that was there would not cause any problems. The local dealer's suggestion was a $1500 machine job of the heads. The alternate shop found we had a fouled fuel filter and that appeared to be the issue (a whopping $85 fix).
    It would appear that the local gas station has crappy gas and it lowered the life expectancy of the fuel filter (so it was a fuel delivery issue). Now we haven't driven the Suburban long enough since the fuel filter replacement to be 100% positive that was the issue but so far so good.
    From my recent experience I would say that Roy Robinson in Marysville is highly untrustworthy. They were very nice and courteous but suggesting a complete re-machine of the heads without going over the fuel delivery system was definetely trying to take advantage of my wife. Matter of fact when I asked for the complete estimate before they did the work and questioned if this was truly the issue they just put the car back together (they had run a chemical bath through the heads (i guess) to try to "remove" the carbon prior to suggesting the machine avenue) and we never heard from them again.
    From the above description if you have any other suggestions I would love to hear them.
  • kiawahkiawah Posts: 3,666
    Well it's happening at a time of maximum fuel consumption, so a blocked fuel filter or bad pump are certainly on the suspect side of the list. Misfires in 3,4, and 5 are on different cylinders and different heads, so IMO not likely a valve, ring, or gasket problem, plus your compression test was clean.

    Are the misfires always on 3,4 and 5? If so, probably not a fuel problem, but could be a wiring, cap, rotor problem. Did you have this problem before the wires, cap, and rotor replacement? or only after they were replaced? Do you know if the wires were a really expensive quality replacement and/or a cheaper set? They make some di-electric goop which you put in the sparkplug cap and rotor/plug connection, do you know if that was done? You buy this usually at the checkout or parts counter at autoparts stores, in a little pack (smaller than size of match pack). You might try reseating all of the wire connectors, as well as making sure they are routed cleanly to avoid interference, and click onto the plugs with a really tight connection. You might also rev it up at night in the driveway with the lights off, to see if you are getting any sparking cross wires that you shouldn't have. I would also check to make sure when they mounted the new cap, that both screws are tight. Try wiggling the top of the rotor cap to make sure there isn't any play in it. If none of that shows anything and assuming that the plugs were gapped correctly when put in, I would probably swap those three plugs to other cylinders....to see if the problem moves to the other cylinders, or stays with 3,4,5.

    Just a couple ideas to consider.
  • Thanks!! Good input.
    Yes the misfires are always 3,4,5.
    Happened both before and after the plugs, wires, cap and rotor were replaced.
  • kiawahkiawah Posts: 3,666
    If this problem stays consistently with those 3 cylinders, you might also consider that you may have an intake manifold gasket problem.
  • Have you had your fuel injectors checked? I have a 98 sub not doing the exact same thing but close and my mechanic thinks it maybe the fuel injectors?
  • We resolved the problem. I took it to a mechanic I trust (not a dealership) and all of the sudden my $1500 head re-machine turned into an $85 fuel filter replacement.

    My mechanic says nothing wrong with the heads, no carbon I wouldn't expect, but you must be using crappy gas because your fuel filter is fowled and that can cause this problem.

    Fuel filter replaces and I've been driving it hard up hills trying to reproduce the issue and can't.
  • kiawahkiawah Posts: 3,666
    Excellent,

    Fuel filter is certainly one of the possible causes when the problem hits while you are at maximum gas consumption, but it's somewhat strange that the misfire error codes are always with the same cylinders.

    Hope the filter fixes it!
This discussion has been closed.