Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Have you recently leased or purchased a Lexus sedan or SUV? If so, a reporter would like to talk to you. Please reach out to [email protected] by Wednesday, December 19 and the Edmunds PR team may connect you with the journalist.
Have you recently purchased (not leased) a subcompact sedan (such as a Toyota Yaris, Honda Fit, Chevy Sonic or Ford Fiesta)? If so, a reporter would like to talk to you. Please reach out to [email protected] by Wednesday, December 26 and the Edmunds PR team may connect you with the journalist.
If you experience loading issues with the login/register form, please completely disable ad blocker or use an incognito or in-private window to log in.

Ford Expedition error codes P0171 P0175 P0191

mmachulskymmachulsky Posts: 1
edited September 2014 in Ford
HELP.... at first I thought it Trans was going. had not get up and go just starting out or at high speed. Trans is fine. The mechanic had these error codes and said it may be the fuel pump driver module??? Has anyone experienced this or do you have any info on it. The part is a 2-3 week backorder. So i would think it has some problems...thanks everyone

Comments

  • rsipposrsippos Posts: 1
    Did you replace the module and all is well??? I have the same codes on my 05 expedition and it has 65000 miles. The dealer told me that the codes pointed to the fuel pump, but said that my module was corroded a bit as well. I am going to have them replace the module first and see what happens. I think that they want to milk me for money.
  • bigdan71bigdan71 Posts: 1
    Can someone please help me before I keep throwing my money away? My 98 Ford Expedition w/ 5.4L V8 has the check engine light on. I was told that it may be my Catalytic converters and others say that I need O2 sensors replaced. I replaced the O2 sensors with Bosch sensors but I still get the same codes. I was then told that I need the original sensors from Ford. Does anyone have a solution. The dealer wants 160 for the diagnostics plus parts and labor. Can a good mechanic guide me in the right direction? Thanks!
  • coco43coco43 Posts: 1
    I have had the same code # and changed all o2 sensors massair flow sensor air filter and may more items. Come to find out on the back of the intake manifold and under the idle air valve there is a vacuum hose about 3/4 of an inch round that reduces to about 3/8 of an inch and goes around the back of the engine and to the pcv valve and back to the side of the intake. Mine was broke where it goes from 3/4 to 3/8 and sucking air like to never found it. If u need the ford part # it is f75z6c324ja that is on a 99 5.4 expedition. Hope this helps, let me know
This discussion has been closed.