Are you currently struggling to find an affordable car that you want? A reporter would like to talk to you about your experience with car shopping; please reach out to [email protected] for more information.

Cadillac Deville Starting / Stalling Problems

hustla_365hustla_365 Member Posts: 6
edited July 2015 in Cadillac
I have 1996 cadillac deville. I was driving yesterday and when i was coming to a stop, my car stalled out!!!!!! I pulled over and cranked it back up and never had a problem with it until this morning when it did the same thing!!!!!!! Could anyone help me please???

See also: How to find a good car mechanic
«1

Comments

  • bolivarbolivar Member Posts: 2,316
    Crank Position Sensors.
  • hustla_365hustla_365 Member Posts: 6
    Would this also cause my computer to restart???
  • bolivarbolivar Member Posts: 2,316
    What do you mean 'computer restart'?
  • hustla_365hustla_365 Member Posts: 6
    When I start my car back up, everything electric resets............like my clock, trip mileage ect.
  • bolivarbolivar Member Posts: 2,316
    Well, that little piece of info puts a different face on it.

    Looks like you have a total electrical failure. Which could be a very discharged battery - except the car would not restart.

    Sounds more like there is a battery cable failure - an intermedent open in one of the cables.

    Clean the cable attachments. Retighten them down securely. See if you can get to the ground cable where it grounds to the motor (usually) and see that this ground is clean and tight. Look closely at the cable ends at the battery. Acid could have gotten down inside the cables, under the insulation, and literally eatten the cables apart.

    Or, some kind of bad failure in the main fuse box. If the thing comes and goes, it's going to be tough to find the problem until it totally fails.

    Anyway, it sounds electrical. Where, exactly, ????
  • mmb1982mmb1982 Member Posts: 3
    Hi I have a 2003 Cadillac Deville Dts. and since Nov 2007 it has been stalling. It seems to happend 1 evey three-four weeks. Then if i leave it off for a while it will turn back on wiht no problem. Or if I turn it off open all doors and let itslef reset it will start. It is soooo weird. I have taken it to Cadillac and they don't know whats wrong. I have already changed out the Cam sensors and and the torque converter but it is still happening. The guys at the dealer our clueless and say the car is perfect. NO IT'S NOT if that was the case it wouldnt turn off .. Please someone HELP !!!! I have a baby and I am scared this might happen while i'm driving. Luckily so far its only when I get in my car and turn it on.

    Oh yeah and now it's leaking oil ..AHHHHH !!
    :cry: I've only had the car 1 1/2 and it has :mad: 75000 FYI. :cry:
  • mommie_of_2_08mommie_of_2_08 Member Posts: 2
  • mommie_of_2_08mommie_of_2_08 Member Posts: 2
    I have a deville, it wont start, i have checked into many possibilities, like checking for spark, (there is) New fuel pump, filter, and strainer, put new alternator in, new battary, so now i am looking into the fuel being the issue at hand. There is fuel going into the fuel rails, when they are compressed fuel is shooting out, so where it goes after there may be the problem? That i dont know. When there is fuel put directly into the throttle body, it will start up, then die when there is no more fuel in there, but when turning it over i get nothing along with that, we took the throttle body off, and under there are two pipe like things that go strait up under there, one of them are clean and have no grime or anything, the other however has sludge like stuff inside it,and when i attempt to start it that stuff sprays out, I dont know much about cars so im hoping someone will come across this and have an answer, I have ran outta things that people tell me it could be that its not...so im at a stand still and really would appreciate some advice...besides getting rid of it, ive put too much into it to want to do that. Please someone help!!!
  • cadilllaccadilllac Member Posts: 1
    check fuel preasure regulator
  • jstreffjstreff Member Posts: 1
    I have a 1998 Cadillac Deville and for the last two months it has been stalling at stop signs whenever it is raining. Garage says its wiring but to hard to track. Any Ideas?
  • bolivarbolivar Member Posts: 2,316
    Crank Position Sensors. There are two of them, replace them both. If it truly is water related, the connectors for the sensors might have a problem.
  • 98slab98slab Member Posts: 8
    Once the car is started, there is no problem with that. As I'm driving the car, every once in a while it would just stall out. I'll pull off the road and restart it with no problem. It wont really happen again until the next time I drive it. There is no check engine light or anything. I tried to get a diagnostics but couldn't because the check engine light wasn't on. Other than that, everything works as it should. Can anyone help me with this? :confuse:
  • bolivarbolivar Member Posts: 2,316
    Gee, didn't you read the message just above yours?

    Crank Position Sensors. There are two of them, replace them both.
  • 98slab98slab Member Posts: 8
    I didn't, but thank you for the advice. I'll look into the price. I'm not a mechanic so do you think it will be better to have dealer do the work or buy the parts and take to my mechanic?
  • bolivarbolivar Member Posts: 2,316
    I'm a cheep SOB, but that is something I've never had the guts to do - buy parts and ask a shop to put them on. You are basically asking him to reduce the price on the job by about 10% or more, which is his discount on the part when he buys it and charges you retail.
  • mmb1982mmb1982 Member Posts: 3
    well i have changed the Crank Position Sensors. Not to mention a bunch of other things and my car still keeps stalling out. One minute its fine the next it doesnt feel like staying on. It seems like the fuel is not getting to the car. I've taken it to Cadillac but they can't find anything b/c the check engine light is not on. What else could it be ?
  • transocean1transocean1 Member Posts: 2
    I've had a 97 Deville now for 4 years. When I first got it (had 50,000 miles on it), it stalled when I was decelerating.....say from 40 MPH down to 20 or 10 MPH....I replaced the crank shaft position sensors, fuel pressure regulator, fuel filter, etc. Turned out to be the EGR valve....(it was just not functioning properly and choking off the engine). I have had no decelerating stall outs since then (going on 3 years and I'm up to 100,000 Miles).....but like most 10 year old Devilles new problems have emerged over the last couple of months (it's been a relatively quiet 3 years of driving though since so I can't totally complain).
  • transocean1transocean1 Member Posts: 2
    So my current issue with my 97 Deville which only occurs when it is raining (okay so I'm instantly thinking electrical system). The vehicle stalls out when I am stopped at a light...will restart right back up....and once in a while if I'm going really slow making a turn say under 5 MPH it will stall.....it definitely has to be raining outside and it has to be in drive (if I put it in park at the light it will not stall). I saw the post about checking the battery cable, grounds, and connections (all great ideas and I'm currently doing this....I think it might be the alternator connection). Was wondering if the 98 Deville that had a similar problem found anything. I have had a weird occurence which may be related (about 3 times now when I've started the car the gas cover solenoid has activated....almost like the car has lost power and the computer gets a quick surge...I believe I can replicate this by removing power from the battery and quickly reconnecting (again would point to the power / ground cables) With this the radio goes to a channel I haven't programed, but the other items don't reset (trip odometer, gas mileage etc.) The vehicle truly is in great shape and this is not a huge issue, but would be good to correct. Any thoughts or similar problems out there????
  • willietopzwillietopz Member Posts: 1
    I have a 1998 Deville and the driver’s window stopped working. I can’t locate the fuse, the books I have talks about the fuse and relay but they don’t tell you were they are located. Is there a trick to getting the door panels off?
  • bolivarbolivar Member Posts: 2,316
    The fuses and relays are not inside the door panels, but are in the fuse boxes. Under the hood and inside the trunk. You have to take out the carpet trim and the fuses are on the left front of the trunk I think.

    Removing door panel, if like my 97 - there is a screw behind the lower rear lights that turn on when the door is opened. You have to pull the lights off and there is a screw. Then pry up the panel at the front that has all the power window buttons (I think, it's been a while since I did this, it might be the seat control panel.) You must pry the panel up, then there is another large screw that can be reached. Then, there is the little triangle shaped trim piece at the front top of the panel. There is a push-in panel pin there, you gently pry around this piece until it pulls out. There are NOT push-pins all around the edge of the panel - it is retained by screws, this one pin at the top front, and it then have J hooked shaped connectors on the panel that push down into U shaped connectors in the inner door.

    So, basically, when you have the screws out and the one pin out, you just pull the panel straight up and it's loose. There are all kind of electrical connectors still attached. The lights, the window controls, the speaker wires, etc, etc. And, you probably have a side AIR BAG! Before starting any of this DISCONNECT THE BATTERY! Disconnect the air bag connections from the panel. If you blow an air bag, don't blame me!

    What you are trying to get to is the window motor, which is probably failed. Pull the power connector off the motor. Put a volt meter into the two wires of the connector. Reconnect the battery. Push the window button up, you should have 12+ or - volts. Push the window button down, you shoud have 12- or + volts (the reverse of what you get the other time). If you get this, the wiring and the switch and the fuse, etc are all ok. If not, start working on getting power there. If you have the correct voltages, the motor has failed.

    Put a couple of strips of duct tape up the window and onto the top of the door frame. This will keep the window from falling. There are 3 bolts holding the motor in, it's real easy to remove. After bolts out, you might have to wiggle it around a little. Take the motor to any auto parts house. Check carefully that the motor sold to you is identical to the old one. At Autozone, their part numbers are messed up, I got a right hand one when I needed the left hand one, so, take the old one in. It should be about $70 or so.

    Buckle it back up. Your are done. The worse part of the job is getting the door panel off a Cadillac. The motors are all bolted in and easy to remove.
  • 98slab98slab Member Posts: 8
    Well I took the car to the dealer and was told that the crank sensors were good and that the ERG was faulty. Had it changed and that still didn't fix the problem. Afterwards, the throttlebody was cleaned and they said that should do the trick, but once again it did nothing. Now I'm being told that the IAC is most likely the problem. Is there anyone who can really help me? Some of the DTC codes are: PCM P0603, IPC B1552, ACM B1341, TCS C1255, PZM B1552/1558, and MMM B2144. Most these didn't show until I disconnected the negative cable from the battery. Also they all are history codes and not current. Please help, I'm at a loss:( :confuse:
  • 98slab98slab Member Posts: 8
    Also, can someone explain the body control module on a 1998 deville, and where it's located? Thanks! :confuse:
  • 98slab98slab Member Posts: 8
    on the stalling on the 98, I was told to change the Idle Air control valve, but I really don't trust the dealer being that they told me it was the EGR valve and 500.00 later the problem was still there. Then they said that EGR just had to go through a reset phase which is not true. Also the throttle body was cleaned out and the problem is still there. I'm really tired of this problem and wish I could just get this resolved. Good luck on your problem and hope you find it.
  • 98slab98slab Member Posts: 8
    no other answers on stalling Deville besides Crank Position Sensors?????????? :confuse:
  • 98slab98slab Member Posts: 8
    Well went out on a limb and changed the IAC valve and it seemed to have fixed the problem of the stalling. the valve is two screws and right on the side of the throttle body on top. Real quick and easy fix plus no maintenance cost on your own labor. So if there were a lot of things changed including the CPS's, change that valve and you should see the problem disappear. Remember to disconnect the neg cable from the battery for about 30 sec to reset the ECM. Good luck out there! :)
  • tp28tp28 Member Posts: 1
    I have a 2000 deville.When turning key no power to starter. Checked for trouble codes, can not connect with pcm. all fuses are good
  • br20000007br20000007 Member Posts: 1
    I have a 1998 4 door cadillac deville with Power Windows. There is a contol pannel with 4 buttons on the driveres door to control each window. I recently rolled my drivers side window down and now , when i press the button to roll it up, the window will not roll up as if it is not getting any power. The other three are working fine and getting power but not the drivers door. has this happened to anyone else and does anyone know what i need to do to fix it? I first thought that it might be a fuse, but i assume if its a bad fuse then the other three would not be getting power either??
  • bolivarbolivar Member Posts: 2,316
    The motor probably died.
  • ctshadafloodctshadaflood Member Posts: 21
    This like new vehicle has just 55,000 miles and is just used once a week. For some reason while driving, the gas pedal becomes hard, then the brakes, then it will stall. after complete turn off. It will restart and not occur for another month.

    any help will be appreciated
  • bolivarbolivar Member Posts: 2,316
    Crank Position Sensors.
  • 97_deville97_deville Member Posts: 2
    I have experienced a similar stalling problem to the OP. The car drops out of idle intermittently while in D, stopped at traffic lights. The stall is very quick and silent - no chugging or revving. I had a dead battery - drained because the running light relay had gone bad and left the lights on. So the mechanic fixed the relay and charged up the battery, and told me very confidently that my problem was fixed. I questioned his wisdom at the time, and I was (unfortunately) vindicated. As others have said after their cars were "fixed," I drove it again for a few days, then the problem re-occurred. I am told by an engineer that this is very unlikely to be a sensor problem, because no check engine light or codes. The IAC valve is the most likely culprit, so it needs to be removed and cleaned, and I will clean the throttle body at the same time. If this solves the problem, I will reply in this thread to let you all know.
  • bolivarbolivar Member Posts: 2,316
    Crank Position Sensors shut the car down so fast it doesn't have time to set the check engine light code, in some cases.
  • quick64quick64 Member Posts: 1
    I had similar problems with no start on my son deville took it to a machanic shop and to caddy dealer they couldnt figure it out. Check your fuse panel under the steering wheel area, fuse #'s 20 and 21 or 21 and 22 control your injectors. 1 of them may be blown, that was th problem with ours. There is usually a spare fuse in I think #10. Let me know if this helped.

    Ken
  • 97_deville97_deville Member Posts: 2
    I am not a mechanic, but my profession does involve loads of troubleshooting on complex systems. It does not make any sense whatsoever that a car which only stalls while idling stationary or at low coasting speeds would have a problem with the crank sensors, especially when no code comes up on the computer. One time could be an anomaly, a few times could be unusual, but repeated stalling without any indication of an electronic problem would point to a problem and solution which are purely mechanical. I'm not trying to be arrogant here, but it is a huge waste of resources to go around replacing crank sensors on the off chance that they are actually causing the problem.

    That said, I took off the IAC (Idle Air Control) valve, which is a small but expensive cylinder fastened by two torx screws above the throttle body. I cleaned the valve by spraying loads of electrical parts cleaner on it. At the same time, I cleaned the throttle body. There is an online manual on how to do this here:
    http://www.cadillacforums.com/forums/cadillac-tech-tips/167181-tb-iac-idle-air-c- ontrol-valve.html

    The poster who created that guide to cleaning the IAC valve had Phillips screws in his newer model, but check it first and make sure you have Torx bits/drivers if that's the sort of screws on your Cadi. Note that you should disconnect the battery and unplug the controller wires when working on this type of stuff, and use the appropriate cleaner. I wonder whether MAF sensor cleaner would work fine both for the IAC valve and the MAF sensor, but my local store was out of it, so I didn't try or even look into it. I hate having to buy 10 different kinds of cleaners if 2 or 3 will suffice. The important part is not to get water or other corrosive stuff on the coils of the IAC valve.

    Since cleaning the valve, my car has not stalled even once, I have no problems starting or idling, and I could not be happier with its performance. It even idles at least 25 RPM lower.

    The IAC valve is only open while the car is idling. If the car never stalls with yor foot on the gas, this is the possible source of your problems. If you are stalling during acceleration, or experiencing rough acceleration (or similar issues), then the culprit could be the EGR (exhaust gas recirculation) valve. The solution is the same - take off the EGR valve and clean it. It's considerably harder to access and remove, though. I've never done it, just read about it. When I have the time, I will clean it as a bit of preventive maintenance.

    If you don't feel comfortable doing this stuff yourself, at least suggest these issues to your mechanic before agreeing blindly to replace sensors that have not even caused a check engine code. I am an inexperienced, low-level mechanic who was able to do the job with $5 worth of cleaner, an old toothbrush, and an hour and a half of my time, including a run to the auto parts store.

    One more thing - these valves can fail as well, and you can check to see if they are functioning, but if you don't know how to do that, at least make sure to try cleaning it before paying loads of $$ to replace the part. The movement of the valve is sort of like a solenoid. It has to be actuated electrically, meaning that you cannot test it manually without having it hooked up to a power source (the controller wires).

    I hope my experience and my post are helpful to those who are having similar problems.
  • troundatrounda Member Posts: 5
    dont see any codes has plenty of fuel at the fuel rail think its crank sensors told it has 2 sensors exactly where are they located
  • teachtechteachtech Member Posts: 1
    I think that the response by bolivar "motor died" is wrong, since the window did go down.
    I just had the same thing happen to my '98: The driver's window went down, but not back up. The other 3 window switches all work fine. It turned out that the switch failed. I pulled the switch assembly out & tried to clean the switch contacts, but N.G. The Cadillac dealer wanted >$175 for the switch assembly (they are PROUD of their prices), but Advance Auto was able to get one from the OEM manufacturer for ~$100.
    NOTE: Both Cadillac and my local garage said that the book calls for 90 minutes labor to replace the switch (probably claiming to have to take the door apart). I just pulled the entire assembly (including the side mirror switches) up from the armrest, unplugged the cable, unplugged the switch assembly, and then plugged the new switch assembly in. It took me a total of 4 minutes, and I did it in the dark with just the interior light on!
    Hope this helps....
  • web6web6 Member Posts: 1
    I have a 2002 DeVille which started giving stalling problems at stoplight idle around 100K miles, now at 103K. Mechanics could not find any problems, so we replaced the IAC and EGR valves ($900) but still have the problem. Now getting hard to start. Any other solutions? No stalling at speed, only at idle, and only after warmed up. Stall is sudden, no rough idle. I hope yours stays fixed.
  • rich_crich_c Member Posts: 2
    I have an '89 DeVille with 77,000 (actual) miles. 1½ years ago, I had a problem starting it after driving about 5 miles, then parking for a few hours. I waited about 15 minutes, then it started immediately. All was fine for about 2 weeks, then it did the same thing. Waited about 10 minutes, and it started right up. Happened about 2 more times, took it to my mechanic, where he changed a "module". Everything was then fine for about 6 months. Took it back, he replaced the module again, and all was fine for 4-5 months. It did the same thing again, but my mechanic said the part supplier "checked" the returned module, and declared it was "fine". Now they won't replace it unless I pay for a new one. Any ideas?
  • george3405george3405 Member Posts: 2
    Hi,All,
    I'm new to this forum. I'm looking at a 1997 Deville for sale very inexpensive. The catch: The current owner said it was running great and then the digital dash went blank (off) and the engine quit. The car will not crank or anything. He has only one key and thinks it might be the computer chip in the key. Is this possible or is it possibly a real risky deal? I do not know how many miles it has on it yet, but it looks good. Thanks, George
  • rich_crich_c Member Posts: 2
    My '89 Coupe de Ville with 77,000 miles apparently has a blown head gasket. (It tested positive for hydrocarbons in the coolant. 85!) I'm told to either get a rebuilt or a used engine. Think I'm throwing good money after bad? Is there no "easy" way to take the heads off and replace the head gasket? It's obviously not like the good 'ol days when you could do it in your garage on Saturday morning. I can't seem to find anyone that wants to tackle the job. Everyone says $1500 to $2000, or more! Any suggestions?
  • chelsie1chelsie1 Member Posts: 1
    i have checked the battery....it has a brand new starter. wont make a noise when u turn the key over.....please help me its a 1992 cadillac deville
  • bolivarbolivar Member Posts: 2,316
    First thing to check is both battery cables. Check where both are bolted down, both ends. Check that there is not extensive corrosion INSIDE the rubber insulation. A cable can rot away inside there where it cannot be seen.

    Next place would be the security system. I think this year had a lot of problems with a small wire inside, or at the bottom, of the steering column that breaks. This is the wire that takes the signal from sensing the small 'pellet' in the key to the system that controls the security system.
  • john96caddyjohn96caddy Member Posts: 1
    Will this work on a 96 4.6 deville also? keeps saying service emissions, rough idle but runs good.
  • dtsman1dtsman1 Member Posts: 1
    i have a 2001 dts 78,000 miles serviced regularly at dealership, noticed lately idle is low at start up sometimes, within a month car refused to start twice because idle was at about 400 to 500. sometimes while driving idle will be high around 1500 to 2000 with foot off gas pedal and u can feel it pulling at a complete stop. sometimes car runs fine with no problem. check engine light came on and the codes were 506 and 507. ive cleaned throttle body but not iac also was wondering if it was a vacuum leak could the idle fluctuate both low and high idle sometimes??? please help with any suggestions. thank u very much
  • billeason2006billeason2006 Member Posts: 1
    when I try to start I get a message, "Starting disabled, wait 3 minutes". Sometimes it works, sometimes not. Is this the chip in the key or the computer going out or something else.
  • rev2010rev2010 Member Posts: 1
    Hello gang. I have been trying to get an answer to this problem for about a month now from all over. My 2000 Deville (Base) will not crank. Everything works, battry new, replace key cylinder, crank sensor A & B, ignition switch, starter and starter relay, and check all connections and grounds (to the best of my knowledge). There appears to be a break down between the starter and gound. If you connect a separate ground from body to starter the engine will turn over slowly. If you run the additional ground to the body, it barely turns the engine over I used jumper cables and also tried at the battery ground. The only codes were P0335, P0340, P0385, which all point to to crank and cam sensor curcuit, all of which seem to have tested fine. Even used a scan tool not a Tech 2 (loaded with updated software, except for the GM high priced subscriptions) a friend has, but could not get a crank request. Any help would greatly be appreciated. I do have the factory service manuals. :confuse:
  • bolivarbolivar Member Posts: 2,316
    You've thrown a lot of parts at this problem without much success. I think it's about time to tow it to a dealer.

    A problem with my wife's 2005 Deville - I like to bring up all the displays occasionally. The voltage was continusly bouncing between about 13 and 15.5 volts. Staying on any voltage only a few seconds.

    What I found was the negative battery cable, under the read seat, grounds to the body there, right next to the battery. It was a little loose, plus the red paint (car color) was under the cable. I removed the bolt, ground the paint off with a Dremel tool, and scraped the cable end, etc. This totally stopped the voltage bounce.

    If you haven't done it, you sure need to check this battery ground back there!
  • gotwyngs2gotwyngs2 Member Posts: 1
    i ws told that the solenoid in the tranny of my 2000 deville needs replacing. will that cause a leak around the seals?how much for the repair
  • bolivarbolivar Member Posts: 2,316
    First off, I don't think a solnoid problem would be related to a leak problem.

    There are 3 solnoids in a Northstar's tryanny.

    There are A and B shift solnoids. There are simple to replace with only the pan being removed.

    There is the solnoid that does the 'lockup' for the top gear in the tranny. You cannot get to it by just dropping the pan. The motor and tranny usually are pulled out of the car to get to it. This is known as the $40 part buried $2,000 deep in the transmission....

    There is a diffferent error code set for these different solnoid failures.
Sign In or Register to comment.