Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Mazda RX-8 Starting and Stalling Problems

mmonterosammonterosa Posts: 1
edited December 2013 in Mazda
Hello, Everyone! I have 2005 Rx8 and a few days ago weather changed (it got cooler) and Rx 8 wouldn't start. At the time it sounded like the battery, because engine turned very slowly. Since, I've changed battery, checked all fuses, and engine still doesn't start (though it engine turns fine). Would you please assist me with any info which will help me to determine what's wrong. I'm mechanically inclined but just don't have much experience with rotary engines..
«1

Comments

  • kev14kev14 Posts: 1
    I'm in the exact same situation and would also love to know whats going on we thought / hoped it was also just the battery but we are also in the same state and need to know whats what asap HELP!!!!
  • It's been warmed up, as signified by water temp reaching at least above the second mark on the left, it's been revved to be 3000 RPM immediately before turning the engine off, and the gas peddle is not even touched during the startup?

    Also, while driving, RMPs are not allowed to drop below 2500 as this seem to keep the engine clear of carbon build up.

    Here in Boston, the winter has arrived with an uncharacteristic punch. Engine starts have been no problem at all for my 2005 RX-8 AT.
  • Well to ad insult to injury! Our 8 has had the same problems for 3 years. Mazda has supposedly replaced 3 engine's. Additionally, everytime this occurs they indicate that the plugs and coils were replaced. We have to have it towed in and it comes out running...for a while. Yesterday, went out to start the car.........you guessed it! It would not start. It is now out of warranty. So I'm trouble shooting to get it running again. I personally don't believe a word Mazda or the three dealerships have told us.
    Now that I'm done venting. Can anyone give advice as to how to get the thing to start? Batt is good, replaced and checked all relay's, control modules and fuses that are related to the problem.
    Oh! The ac issue we all seem to share..........there is no fix for it. We've had it in the shop for three years with mulitple issues, including the ac prob. and as of yet there is not a fix. Mazda has produced a lemon with this one. I would advise any rx8 owner to get the extened warranty...YOUR GONNA NEED IT! :( :lemon:
  • thydethyde Posts: 1
    I have also had my mazda in the shop for 3 years everytime it gets cold it wont start
    they tell me that its something different every time i have had a new engine,new coils, new tail lights, new cd player, several new batteries also problems with the a/c
    they assure me every time that the problem is fixed my warranty is about to run out. i had no idea there are so many people with the same problems i have had. I asked for the dealership to make this right and trade it in on another vehicle(not a mazda they have 3 different dealerships) i went with hopes of them doing that, talk about adding insult to injury i would lose the 12,500.00 downpayment and over 2 years of payments they wanted to pay off the car and give me 1,500.00 to put down on another car and start all over with payments. this just cant be right!
  • You got it! Too many repeating problems for us. I've been told that these cars must have super unleaded fuel, the rpm's must get really high really often and that they flood easily. Such as moving the car out of the driveway for someone to get out.
    In addition to the aforementioned problems. The interior components such as the hardware is faulty, loose, rattles, etc. The car is basically falling apart before our eyes in only 4 years. We are VERY good at taking care of our vehicles. Oil changes once a month for example. A little extreme but in my little mind it's the life of the engine.
    If you keep your car you better get the extended warranty! We are currently car shopping. Nissan, BMW and Altima is along the line of car's I'm exploring now.
    Can't wait to get rid of this piece of junk RX8...does the R stand for rottin'? :mad: :lemon:
  • tlang1tlang1 Posts: 1
    Hey...

    Just to let everyone know.. I had my 2004 Mazda RX-8 in the shop on Saturday because it wouldnt start..My car has 42,000 miles on it.. As it turned out.. The dealership told me I needed updated Plugs as well as a starter.. The starter is much stronger than the original one that was in the car.. SUre enough.. once they put the updated plugs in there as well as the updated starter.. it was easy to start..Mazda paid for everything being that theres a 4 yr 50,000 mile warranty on that particular car.. they also did some AC work for free as well as my car wasnt cooling sufficiently.. PLease call your dealership and schedule an appt... By the way.. Mazda gave me great service on the day I came in around 12:30 on SAt... I Didnt have an appt but they worked on my car and had me out of there by 5pm .. I was impressed as it was a very busy service day and I was expecting them to tell me that they couldnt get to it.My email is [email protected] if you have any other questions.
  • al94al94 Posts: 1
    your story sounds exactly like mine- i have a 2006 rx8 and i have had the car in to the service department 18 times in the past year with the last one being that i needed a new engine! well like you i went to the dealership to see about just trading straight across for a new one with out losing any money-well you know how that one went. and just when i thought i was going to be stuck with this brand new worthless car someone told me to go to my state's lemon law web site-i live in az- and there my prayers were answered- iam in the process of getting all my money refunded and they can have the car back-check with your states lemon law web site-it sounds like your car falls right under that law- good luck
  • smogdungsmogdung Posts: 349
    Sorry to hear about the RX8 problems....You can get one of the few remaining Crossfires for $13-15,000 under sticker right now....they come with lifetime powertrain warranties....performance #s are virtually identical to the RX8s...+ top speed 151, I ave 24 mpg.....heated leather....homelink...esp.. buildt in Germany....by Mercedes! My 07 6speed is an absolute joy to drive!!! Production stopped on 12/17/07....76046 were buildt total ....maybe 50k came to USA.
  • fedlawmanfedlawman Posts: 3,118
    Actually, the Crossfire was built by Karmann, not Mercedes. It has a combination of previous-generation Mercedes C-Class and Chrysler parts (about 50/50).

    While the RX-8 is one of the purest sports cars on the road, the Crossfire is more of a GT car. Although it's undeniably a fine car, I don't think the Crossfire really compares to the RX-8 from a sporting point of view - plus, it doesn't have a back seat.
  • smogdungsmogdung Posts: 349
    I just thought I'd throw that out there for anyone in the market for a new car soon...it's a fantastic bargain right now ....Daimler & Chrysler have parted ways & it didn't sell well partly cause they had real high sticker prices....mine's sticker was $36K ....I gave less than $23K. for a 6 speed Limited....some people are getting even better deals...

    Trust me....it's so solid & fun to drive.....with the lifetime powertrain warranty....it's a keeper! My guess is there are less than a 1000 new ones left (worldwide) & most of those are automatics......
  • duke15duke15 Posts: 161
    I think I replied to a reduced version of this in another forum, but now I have more information.

    I have this same exact problem with my 2006 AT. My original dealer gaves me the same BS line about it. I went to another dealer, and they replaced my engine mounts. That worked for a little while, but then it came back. I have now gone through 7 sets of engine mounts in 15K miles, and now there isn't any difference after I get the engine mounts - the problem still exists and seems to get worse with time. The problem was worse when my AC was turned on, so once they replaced my mass air flow sensor and that problem was solved, but not the overall problem. My car also "stumbles" from time to time when I put it back in gear from neutral at a light. Try puting your car in neutral at the light - the vibration should stop or be barely noticeable. Mazda had a regional rep come out to look at my car, and his solution was to give me my 7th set of motor mounts. The vibration was a little better for about 10 feet, then it was back and worse than ever. One of the service managers at the dealership confessed that certain 8's do that and they don't know why - others are fixed by relacing the engine mounts. It is maddening to me.

    Sorry I don't have a solution, as my car was never fixed. I also had a slew of other problems, so my solution ended being to sue under my states "lemon law". I am in the process of settling with Mazda now.
  • My 2004 AT with 37k has slowly acquired a vibration when in gear and stopped. You feel it in the brake pedal,steering wheel,doors, and you can see the vibration in the mirror's.Dealer said that their scanner/computer show that everything is in the NORMAL RANGE LIMITS....... The motor mounts have been checked and show no signs of wear.
    The trailing plugs and coil were replaced along with the leading plugs 2 weeks ago and has not helped to negate the loud vibration. I only feel it when stopped. :cry:
    Any ideal's or recommendations of RX8 dealer's in N.Cal. bay area ?

    Doug H.
  • OK, here's my solution the vibration issue that I used in my 2005 RX-8 AT with 38K miles. The solution may be unacceptable for some, but for me, the solution provides far far more driving fun on top of minimizing the idle in gear vibrations...

    1) Don't use the full automatic in city driving. 2) For 20MPH use only 1st gear. 3) For 35MPH use only 2nd. 4) For 45MPH use only 3rd gear.) If you are traveling highway speeds above 65MPH full automatic is OK.

    The above strategy keeps the RPM level around 3000. After the first year of driving I began to notice that full automatic in city driving would constantly dive into 3rd or 4th gear, clearly lugging the engine creating a jerkiness in the over drive gearing. With the engine seeking the lowest gear at the first opportunity, I also noticed dramatically rougher idle. The rough idle appeared to go away after driving a long highway trip where RPM tended to remain above 3000 for long periods.

    I believe there are two things going on with the RX-8 AT. The engines simply need to run at least at 3000RPM to keep everything clean and clear. Second, the electronics have a bit of fuzzy logic which will attempts to over optimize at low RPM speeds, producing more idle vibrations. The fuzzy logic controller remembers ten of thousands of previous gear shift behaviors, so it takes a while for the electronics to be retrained to new behaviors. Or just re-flash the PCM.
  • mdw1000mdw1000 Posts: 171
    It is also widely considered to be a good idea to run a rotary to redline fairly frequently to prevent carbon build-up (and I believe to get the apex seals lubed up a bit more). I try to redline mine at least once every day that I drive it.

    Just make sure it is really warmed up before you do this. At the very least don't drive it hard until the coolant temp gauge has reached the normal range. I also have an aftermarket oil temp gauge installed, and the oil doesn't get above 120 degrees until a few minutes after the coolant temp reaches the normal level on the gauge. I'm not sure at what temp the oil is safe to run hard, but I wait until that needle moves some.
  • vkatvkat Posts: 3
    I got my car about a year ago , used with 70k miles ... yea ok , get it out , everyone says WOW you got 70k out of your RX-8?? well i did find out it did have a new engine put in just before i got it , it now has about 85k miles and still has the same problem as when i bought it ... this is it... it runs just fine (except the intermate vibrating while stopped) and out of the blue it loses power .... rattles (like a BAD spark knock) at high RPM and if i stop while its doing this it will die and not start up for about 10-20 minutes ... Ive had it to several dealers with more the several different stores ... what ive found that helps is this ... use either 1/2 bottle of trans fluid per tank of gas or add some marvel mystery oil to the gas , and DO NOT use gas with any ethonal and ony use 93 otc...

    Just wondering if anyone else is in the same boat as me . I love my car but cant find anyone to find out whats wrong with it , that is if there is anything wrong with it ... mabey thats just the way the car is :(
  • can u get it to a shop to check your fuel trims when it has it's fit?does it ever set a lite?
  • vkatvkat Posts: 3
    ive had it in the shop more times i can count and they cant find anything wrong with it ... since i started useing the trans fluid or marvel mystery oil ... as well as making sure it warmed up before driving (wasting tons of gas) and reving it to 4k before turning it off --- it has not died on me , however it still stumbles and studders when i stop (like it wants to die but hasnt) and its only did the rattle at high rmp a couple times . I have an after market warranty on it for 2 more years that cover almost everything on it but no one can find the problem ... the only light that has came on is coded the "secondary shutter was stuck" but that was only once and it would cost 1200 bucks to replace the intake (you cant just replace that valve)
    If someone can offer any info that would be awesome , i just want my baby to run right :P
  • boof1boof1 Posts: 2
    I purchased my 04 RX8 in July 04 with 1,500 miles. I now have 189,000 miles. I was out of warranty within one year of owning the car. I have had the same starting issues like everyone else from day one. Back then Mazda never explained why the car wouldn't start, they would just fix it. Mazda would fix the stalling issues by changing out the plugs, starter and battery. As an Rx8 owner for 4 years now I obviously know how to get the car started in the event that my wife forgets and moves the car in the driveway. (How could she forget?) The big problem I have been having since about 120,000 miles is the stalling while driving. Regularly I drive without stopping at about 80 mph for 170 miles early in the morning when it is not hot out. Typically as soon as I get off at the ramp and arrive at the first red light, the car will stall out as I try to pull away when it turns green. If it doesn't stall it will at least bog as I get it up to speed. Mazda doesn't have a reasonable answer. The dealership said that the engine needs to be taken apart and cleaned because of carbon buildup in the engine. No guarantee though. Carbon buildup would be typical of a little old lady who drives only two and from the bank at low speeds. How could carbon be built up in a car that is going 80 mph for two straight hours? I spoke to a representative higher up than the dealership. He said He "called around" and that no one from Mazda had heard of an 04 RX8 having more than 85,000 miles. He said that they have no history with such a high mileage car to even know what the problem could be, if it's not carbon buildup. I have asked numerous mechanics. They all look at me like I'm crazy, or make some wacky diagnosis, that the problem is a throttle position sensor. Does anyone have an alternative answer? Other issues you low mileage guys can expect: The glue in the sun visors melting and coming apart. Tail lenses filling up with water. Driver/pasenger door locks freezing up. Major oil seal leaks front and rear. Gps toggle switches (I'm on my 3rd one). I realize this is a high mileage car, but it still is only 4 years old.
  • fedlawmanfedlawman Posts: 3,118
    Maybe the O2 sensor(s)? With that many miles, that's my first thought...
  • boof1boof1 Posts: 2
    Yea O2 sensors were also changed, twice if I remember correctly. It's just insane that Mazda's only answer when all the changes do not work, is to change out the engine. That's fine if your under warranty, but who is going to pay for an engine swap, when there should be a reasonable fix. Crazy.
  • Try changing the air filter. Mazda uses platinum spark plugs. replace them with (NGK laser iridium spark plugs) this should solve your problem. if the car still don't start check the fuel pump fuse! Open the hood to the right of the air filter is the fuse box there are two blue fuses on the bottom it's the one to the right.
  • I've sold several over the years, and it seems to be that the harder they're run, the btter the rotary motor does. They are certainly very sensitive, anyone remember MG, triumph, etc?? They need to be warmed fully when run, good gas is a must, and the rotary is a high RPM motor by design, the harder I've run mine, the better they've been. And I"m with the prior post, 3000+ RPM seems to help too
  • You might have to replace the IAC motor ( idle air control = DEALER ITEM) that's what keeps the idle steady when your stopped. After about 60.000 miles it starts to fail, also replace the coils and spark plugs. All that might cost you about $1200 at the dealer!
  • If you go over to the rx-8 owners club forums, you'll see that many people have 100k, 150k and even 200k on their rx-8s (that's a lot of miles for three and four yer old cars), with few or no problems.

    The common element: They all bought manuals, and drive them hard and fast, the way the rotary was meant to be utilized.

    The best thing you can do to a rotary is redline it. The worst thing you can do is lug it. If you're spending most of your time above 4000 RPM, your 8 will thank you.

    Make sure you redline it a couple times a day.
  • johnrvwjohnrvw Posts: 2
    I have just purchased a used 2004 Mazda RX-8 with 88,000 miles. I am having an issue where, while driving the car the check engine light and the TCS/DSC Indicator light will come on. When it does the the car will stall - mind you this is while driving down the freeway doing 60+.
    Can you help me trouble shoot this?
  • johnrvwjohnrvw Posts: 2
    Drove it to my nearest Mazda dealer to have checked.
    Throttle Control valve and gasket needs to be replaced. ($436 just for the parts)
  • jjerryva20jjerryva20 Posts: 4
    Hey,
    The same thing happen to my mazda rx-8.I have only 27,000 mile.
    Like when I came to a stop light the car tendes to bog and then pick up speed and then it stops.i took it the the dealership and the clean the carbon out and it will run good for awhile and start doing it again ..In a week I will take it back to the dealer and get it check out again its a never ending story.the is a problem in the motor and someting is going on with it
  • shady7shady7 Posts: 1
    I tried to start my RX8 and it sounded like the solenoid was clicking but the engine did not turn, is this a common fault and is there anything i can do ? help please.
  • Hey,
    There is a problem with the stock starter. and dealer replace my starter with a high torque starter from mazda is your car still under warranty and does you car wont start when its cold.
    let me know
  • freddyrx8freddyrx8 Posts: 11
    When you turn the key and you hear a clicking sound more than likely the battery is dead, try charging or replace the battery. But if everything works like the head lights and radio and you still hear the clicking sound then (it's possibly the starter?) (NOTE: If your gonna replace the battery you will have to take the car to a mechanic so they could re flash the computer.)
  • hesusehesuse Posts: 1
    Hi there,
    my name is Gary and i am about to purchase a used '04 RX8. i am getting scared though of all these customer reviews with all these horror stories about flooding engines and broken this and broken that and A/C not keeping the cabin cool enough. I just read your post about how you have to keep the car above 4000rpm most of the time. So, does this mean I have to drive the car fast all the time or can i just drive in lower gears? Because if I start getting a lot of speeding tickets my wife will kill me. LOL.
    I only work 7 miles from home and it isn't a "fast" road. so i can't speed on it, plus cops are always patrolling the road. Any suggestions as to what i should do? I really want this car but I don't want it in the shop all the time like all these other idiots! LOL

    So, again, would it be ok to ride it in lower gears for that higher RPM?

    Also, is it true...you shouldn't turn the car on and then turn it right back off? you should let it warm up a bit? what about winters? is it hard to start if it has been sitting in my parking lot at work for 3-4 hours in 25 degree weather?

    thank you for ANY advice you can give me!
    if you want, you can email me at [email protected] with anything you have to offer for advice. i want to keep this car pristine!

    Gary
  • yes it your starter is you car is out of warrenty?
    If you disconnect the battey and reinstall a new battery auto matic you computer will reset itself..and then out have to do thid
    1) turn on the ingition turn your wheel clockwise all the way and then turn it counterclock wise and that should reset you steering

    let me know okay
  • lth1954lth1954 Posts: 1
    I have a 04 RX-8 - 72,000 miles and Mazda just replaced the engine. Got the car back and the car stalled every time you came to a stop once it warmed up.

    Took Jeff Haas Mazda some time to trouble shoot, but here was the problem - the rubber hoses to the automatic transmission were weak and when they got hot, they would basically close up when coming to a halt and the torque converter would not have full pressure - the car would go from 800 RPM to 400 RPM because it was still trying to go a little and then die.

    New hoses - problem solved. The way to trouble shoot according to the dealership was to watch the engine temperature and the transmission fluid temperature. Once the hose started to collapse - the transmission got hotter - and when you stopped, the fluid did not go through the lines as it should - causing the engine to labor and then quit.

    Mazda covered all of the repairs under warranty - at least for this situation right after a new engine.

    Hope this helps others!
  • ok get this i have a 04 AT 8 it was parked in the morning went to leave later that night and it wont start all the lights and radio work, tried jumping it nothing still motor turnes when trying to start but it seems like theres either no spark or maybe no fuel, but it has a full tank of gas plus i checked and replaced almost all the fuses get back at me if you know whats up

    mike
  • Try and check your ignition coils thats most time the problem they will go first before the plugs and wires
  • freddyrx8freddyrx8 Posts: 11
    Thanks i all ready knew about turning the wheel clockwise then counter clock wise and you have to turn the car off then back on again to get the DSC light to go off but when i disconnected the battery and reconnected it the idol went very low when i took it to the dealer they said they re flashed the computer to get the idol back to normal. I find that hard to believe but thats what the dealer said. Thanks again for your advise.
  • rx8girlrx8girl Posts: 5
    Did your motor ever "flutter" or vibrate real hard prior to this? Mine did the same thing randomly . . . if it did, I hope its under warrenty, because you need a new motor. Sorry.
  • Ok. I bought a used 04 with 54,000. It is beautiful, silver, GT with all the bells and whistles. It had a vibration above 50, so they said that I needed to replace motor mounts and rear drive shaft. After much screaming...the dealership replaced them. No charge,,,2 weeks down time, still has the same exact vibration. Now, last Sat. it lost power on the freeway, bogged down, and sounded horrible. Had it towed to dealership. They informed me today that I needed new ignition coils, wasn't sparking properly,and air filter was "really" dirty. (bought this car 4 months ago FROM dealership). After agreeing to pay $330 to fix these problems, I get the next call that I need a new engine. Which they will cover since its under Mazda warrenty. But what else should I ask them to check before I accept it? The converter? Hoses? What else goes out with this problem...and why? Any guidance would be apreiciated! Thanks
  • rx8girlrx8girl Posts: 5
    Yikes! Sorry to hear that. Yet again. . .my 05 RX-8 did the same thing. (Sorry everyone. . .you will probably get tired of me saying that. . .) Make sure they replace the solenoid valves. It is a common thing to need to replace the coils and spark plug cables also. That is because the oil is used at the same rate as the gas. The rotary requires a lot of attention. Don't just take it for a quick run to the grocery store, you have to heat it up before you turn it off.
  • freddyrx8freddyrx8 Posts: 11
    No actually the engine was very quiet and running smooth the problem was when i was driving and i suddenly stopped the car then it would stall, but if i braked slowly the car stayed on. The dealer fixed the problem when they replaced the spark plugs,coils and iac sensor.
  • we just bought a mazda 323 in excellent shape ,, got her on ther road and have one problem .. you have toaintain a full tank of of gas or it will stall going around a right hand corner ,,, and suggestions plz help ,,
  • freddyrx8freddyrx8 Posts: 11
    You might have to replace the fuel pressure regulator and, or your fuel injectors. (It also could be your fuel pump)
  • cheri3737cheri3737 Posts: 1
    Help.... is the 2009 RX8 a good car to drive 15min to and from work daily. I'm concerned about the rotary motor and the stalling issues. The dealership says no problem but I know nothing about cars.
  • rx8girlrx8girl Posts: 5
    the stalling issues are normally in the 2005 RX-8's. Driving it for 15 mins depends on where you live, but as long as the motor is warmed up before you turn it off it will be fine to drive. Just be sure to put premium gas in it.
  • t007mt007m Posts: 1
    My son has one of these things (RX8).

    I've been trying top help him with the flooding problem. He knows all the tricks to shutting it off but I have an idea. It seems like the fuel is still being injected when the car is shut off.

    Do you think that putting a fuel shutoff valve in line with the fuel pump might eliminate the problems of flooding? Here's how it would work. Instead of shutting the car off with the ignition/start key, turn off the fuel to the car off and that would result in burning off any fuel left in the system. Then..................after the engine stops, turn off the ignition key. What do you guys think?
  • I have the same problem, full tank or it is going to stall as soon as release the accelerator ( mine is Manual Transmission) last time I had stalling problem and when I full the tank, I did not stall from that moment and I thought a miracle happened and now when my tank is half it stall again.

    steventerri what part did you change or anybody please and suggestion.

    plus, my AC is running with no stop, on technical booklet says it case stalling too,
    any idea and suggestion please,

    Thanks,
  • Is there a definite starting procedure for a flooded RX-8?
  • it is probably flooded,this car seems to easily do that,pull out fuel pump fuse and proceed to try starting,push gas pedal all the way then let off a bit repeat this proscess until starts will take a little while,when starts put fuse back in
  • frustrated with this problem! Any help to get the car started? Stalled on the top level of a parking garage. Has been sitting for a week!!
Sign In or Register to comment.