Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet (Geo) Prizm

1353638404147

Comments

  • There is no sound or noise and the engine will decrease instantly and then not increase over 30. so i have to turn it off for about 15 minutes then it usually will start running ok for a while but this happens frequently and i have had several mechanics look it over and drive it when its acting up and their all dumb founded as to whats wrong.
  • uraspazuraspaz Posts: 3
    I have a 94 prizm, 1.6L auto. recently I have noticed a noise around 2200rpm coming from the valve area, I was wondering if there are any common issues with the valves/spring/cams/ect.
  • uraspazuraspaz Posts: 3
    check out ebay. I saw one, but I dont need one. they are fairly cheap I think.
  • uraspazuraspaz Posts: 3
    If you dont have an emissions check where you live, look for a test pipe, and just bolt it in place.
  • I will look in to it & get back to you. It could be flakey CPU. This is basiclly a 95 Toyota Corolla. You may ask same question on a Toyota web site or let a Toyota Mech... look at it.
  • Just turned 300,000 miles.
  • my shifter cables bound up, anyone know where i can buy a new set? i don't really want to pay the $700 for parts i keep getting quoted
  • lsilsi Posts: 2
    Trying to find Rims for a 93 Geo Prism Lsi (standard stock Black) (in NC)
  • onedayoneday Posts: 1
    crayala & catfish,

    i am having a very similar problem with my '94 geo prizm(140k miles), and suspect some kind of wierd electric problem.

    i had the districutor replaced (which turned out to be bad), had a wire foul going to the fuel pump(replaced), replaced the fuel pump, replaced the fuel filter; everything checks out on the computer. a mechanic at one point thought the Idle Air Control was bad, but cleaned it out and then said that it was working good, and should continue to.

    it also had trouble starting, and now it starts only intermittently. when i try to start it now it's like this: i turn it to the ON position and the beeping lowers in tone and the lights dim, then when i go to start it it either just clicks or does a wierd, rapid-clicking buzz-type-noise. and then when it does actually start, it has your same kind of symptoms: stalls at stops sometimes, sometimes lacks power going uphill (until finally something seems to click and it gains all of it's power), has trouble accelerating from being stopped (sometimes it helps to put it into the L(ow) gear at first, then switch up as i gain speed.

    this car is driving me crazy, and i cannot for the life of me figure out what's wrong with it. cursed be the day i bought it, for all the money i've put into it, and only got 6 months of driving.

    ...help?
  • i used to own a 95 prism then after 3 yrs of no problem i decided to upgrade and trade it for a 1998 camaro ss. camaro still running strong then my 18 yr old son been shopping for his first car and to my suprise he take home a 1996 prism lsi same color as my 95 and in good condition. i totaly forgot how reliable and great gas per mile (put 23 dollars for a full tank ....travel almost 280 miles till it need a refill thats about 35 miles or more per gallon.
  • Anyone know how I go about unlocking the center console of my mom's '94 Prizm? I heard there is supposed to be some kind of code to enter, but I haven't a clue as to what to do.
  • alternator..... as wierd as it sounds thats ur problem :sick:
  • a prizm is a toyota carrolla in disguise......... damn good cars minimal maint. ive had 3 (on the third)

    sold my other two to family who needed them.... 1 of them has over 350,000 miles on it and is still running strong..... metros are very reliable and excellent on gas but not as big as the P's ........ my personal pref. is the prizm metro just to small for me other wise both great cars and well worth the money
  • mremtmremt Posts: 1
    :confuse: I recently shut off my 97 prizm but the starter continued until it burned up. I just put a new starter in went to hook the Batt/cables up and the starter took off again. What would possibly cause this?
  • n51hjn51hj Posts: 3
    I've got a '99 with 100K that I just replaced the engine with one with 30K out of a wreck. The swap went well and the engine starts and runs well except for missing badly above 3000 RPM. I've checked all the vacuum lines and put some new gas in it but to no avail.
    Any ideas?

    Thanks in advance,
    Steve near Chicago
  • n51hjn51hj Posts: 3
    I've got a '99 with 97K that I just swapped a 30K motor in due to a broken connecting rod. It starts and runs well but has a significant miss at 3100 RPM to the point that it won't accelerate farther. I also get an intermittent "engine lite" while it's missing.
    Any ideas?
    Also, it has a grinding noise from the front right wheel area when I turn left. A wheel bearing, I assume....
    Thanks in advance,

    Steve near Chicago
  • I have a 1990 Prizm. It has a crack in the exhaust manifold between the #2 and #3 cylinders. I would like to replace it with a header. Does anyone know what header will fit? Or what yr Toyota headers will fit this car? Thanks
  • I have a 1990 Prizm. It has a crack in the exhaust manifold between the #2 and #3 cylinders. I would like to replace it with a header. Does anyone know what header will fit? Or what yr Toyota headers will fit this car? Thanks
  • Did you find the cause for this problem my car is doing the same thing
  • I think it a common problem with these cars. Judging by the amount of exhaust manifolds on Ebay and reading some of the Prizm forums. I think a header for a 1990 Toyota Corolla will work, but I would like to know before I spend $160.00 on one.
  • I am working on my 1995 prism. Great car, but its getting a little expensive to repair. I have to replace the left front wheel sensor for the abs. The sensor split into two pieces . I am having trouble with determining which is the best(or the only) way to remove the piece stuck in the spindle. Any ideas would be greatly appreciated.,
  • Below the master cylinder. You have to get to the bottom line (under the filter) from the tire well
  • I replaced the rear struts on my 95 prism.Cost of the mounts where $65 each Struts cost $70. Yes it is possible for the mounts to break b4 the struts go bad. Problem is, you have to take the struts off to get to the mounts.So its kinda of a catch 22 situation. If you have to replace the mounts you should replace the struts too.
  • I have the 94 prism lx had the same problem when i got it , I took out the clutch sensor and direct wired it, I havent had a problem since, Have a great day , and good luck , Sherri
  • My aunt bought this car for me back in October as my previous car died. She had a good friend of hers, a mechanic, check it over thoroughly before I brought it home. It's great on gas and seems mechanically sound except for one little noise and I'm concerned about the cause.

    Whenever I pull out of a parked position (I never hear this noise at any other time, even while turning), I hear what sounds like a "ping" or something. It's hard to tell which side of the car this is on.

    Like I said, the only time I hear this noise is when I pull out of a parked position, never while the car is in motion. I noticed the other day that after I pulled out of a parking spot at a local store, the noise was more pronounced and I'm wondering if it's because the parking lot is steep, and the car was parked on a decline (front end down).

    What could be the cause of this noise? I hope it's not going to be costly to repair, and I've only had this car for a couple of months. My aunt made sure it was mechanically sound before I brought it home, and I just took it for an oil change at Walmart yesterday. I didn't mention the problem to them because basically, all they do there is tire work and oil changes. They never said they noticed anything out of the ordinary.

    What could this be? Please advise. Thanks!
  • n51hjn51hj Posts: 3
    '99 Prizm;
    97,000 mi.
    30,000 mi. on replacement engine
    automatic transmission
    A/C, AM/FM/CD, pwr locks, rear window defrost, new battery, recent tires, coolant system flush, cruise control, good paint, NO RUST, some spares

    Located in north Chicago suburbs (Wadsworth 60083)
    $4000 obo

    Steve
    847-336-8352
    727gs@db3broadband.com
  • I have a Geo Prizm 1997 and almost 5 times a days when i press the Brakes to stop in a red light the card turn off. Then i have to turn it on again..

    Can anyone give me a suggetion on what could it be?

    Thankss
  • veenveen Posts: 2
    I recently had new tires put on my '01 Prizm. When I picked up the car I was told my shocks were starting to weaken & that someday soon I'd need new shocks. The price quoted was $1600 because "they're hard to get to." Does this sound remotely right to anyone? Has anyone else had this problem with their Prizm? I can't imagine paying $1600 for shocks when I happen to know the parts themselves are very reasonably priced.
  • I have a 97 geo prizm 1.6L 5sp std.
    I have had an engine knock for a while and im not sure what it is. If I am idleing or am driving in first gear it sounds fine, but in second through fifth gear it starts to tick and its relative to the amount of torque and RPM. The mechnic I took it to for $40 narrowed it to something under the timing belt cover. They didnt go any further and I didnt want to pay for it. Does anyone have any idea what the problem could be?

    Thanks
Sign In or Register to comment.