-June 2024 Special Lease Deals-

2024 Chevy Blazer EV lease from Bayway Auto Group Click here

2024 Jeep Grand Cherokee lease from Mark Dodge Click here

2025 Ram 1500 Factory Order Discounts from Mark Dodge Click here
Options

GMC Jimmy Heating and Air Conditioning Problems

2»

Comments

  • Options
    stupidgtsstupidgts Member Posts: 1
    Anyone have any suggestions as to where I could find a new compressor for a decent price? I think mine is about to kick the bucket. Air only blows COOL when RPM's are raised to around 2500. Also, there is a lot of rattling when the clutch engages. Thanks for any advise! :D
  • Options
    repairdogrepairdog Member Posts: 948
    Most auto stores or online at like gmpartsdirect or rockauto but unless you have al the equipment to evac and test the system plus change the dryer it will probably get contamimated. I let the AC shop do all mine - yes but $700 range.
  • Options
    britamerbritamer Member Posts: 1
    How do you remove the evaporator in a 97 Jimmy. One of the bolts is inside the passenger fender and looks almost impossible to reach. Dealer wants over $1000 to replace. Many thanks.
  • Options
    bmath72bmath72 Member Posts: 4
    Is there a way to check the A/C Compressor Relay to see if it is any good? How do I check the connectors to make sure power is getting through to the components? I took my 95 Jimmy to the shop to get the A/C checked out, and they told me it still had 30%. But they wanted to charge me $85hr to troubleshoot the problem. I want to do everything I can myself before I take it in and pay the big bucks.
  • Options
    johnpaultenjohnpaulten Member Posts: 4
    :sick: a/c blower will not shut off when ignition is off
  • Options
    johnpaultenjohnpaulten Member Posts: 4
    any idea when fan motor(a/c) wont stop running even when
    ignition is off/ 2003 avalanche
  • Options
    vicedetectivevicedetective Member Posts: 2
    Hello all, okay I have a 96 GMC Jimmy with just the normal climate control. Just the red and blue for hot and cold type. I was having a problem with getting any real cold air from the A/C and was told that it was the air door acutator. I bought the part, its a small part. What is the best way to attack this project. First do I have to remove the dash 100%, and where is this part exactly. I have read some say yes on the days others say no just get behind the glove box, but the glove box is attached to the dashboard or am I missing something here. I took the glove box door off to see. Please help, I have a little one on the way and live in the dessert so I need the AC in the wifes truck, thanks!
  • Options
    rpducros2rpducros2 Member Posts: 3
  • Options
    rtitonertitone Member Posts: 1
    A/C ON BLOWS AIR FRONT AND BACK, BACK COLD FRONT NOT,
    WHERE DO I START, THANKS
  • Options
    jflo520jflo520 Member Posts: 5
    I have a 98 Jimmy and sometimes the heater will blow only cold air. It was working fine last night, but when I used it this morning the air was cold while I was idling. It warmed up once I got going, but started blowing cold again after about 10 minutes. Can anyone give me an idea what might be causing this?
  • Options
    jarettjarett Member Posts: 1
    jflo520,

    I also have a 98 Jimmy with the exact same problem. It has been like this for 3 winters and no one has been able to explain, or fix, the problem. Can you please copy me if you find out how to correct this. Thanks.
  • Options
    goodyguygoodyguy Member Posts: 10
    Air only comes out through defrost vents no matter where switch is turned. can not get air to come out of the dash or floor vents!
    Ac works and heater works but will only come out through defrost vents.

    Could it be the control unit? or What?

    Please help.

    Goodyguy~
  • Options
    lilly9lilly9 Member Posts: 1
    I have a 98 Jimmy and recently had radiator and water pump changed- coold air blows in when going up hills- any ideas??
  • Options
    smitty36smitty36 Member Posts: 2
    I have a1998 Jimmy SLE, same problem, no heat or AC from the floor.GM garage told me it was a shutter door and required removal of dash to replace. Repair costs 3 years ago were $800.00. I opte not to have it replaced. Hope this helps.
  • Options
    mwolf9000mwolf9000 Member Posts: 29
    You might not have enough coolant in your radiator. And you could check the fuse for the 4wd in the fuse box by the driver door. That's a start.
  • Options
    emilewskiemilewski Member Posts: 1
    hey, drogersgolf
    I'm having the same problem with my heat, if you get any suggestions that work let me know please. thank you.
  • Options
    drogersgolfdrogersgolf Member Posts: 2
    I put 1 gallon of anti-freeze in the radiator and my heat starting working right away. Thank you for the suggestion and easy fix.
  • Options
    nljewellnljewell Member Posts: 21
    A few yrs. ago I was out of state and my alternator took a crap. Had it replaced and ever since my rpm's will surge up alittle when my heat is on. Any ideas?
  • Options
    JManBrodyJManBrody Member Posts: 2
    I just fixed this problem on my Jimmy. The vacuum line on what I believe is called the vacuum return (little black ball attached to the inner hood, lower right corner) was disconnected. It was very easy to fix, I just looked for a small rubber hose (1/4 " O.D.) that wasn't hooked up to anything and attached it to the nozzle on the little black ball. Now I get hot or cold from any vent I select.
  • Options
    JManBrodyJManBrody Member Posts: 2
    I guess I should have been a little more clear about the problem and the fix. The problem is that there is no vacuum pressure to control the vent selector (its not an electrical control).
    The fix: typically when this happens it is simply a vacuum line that has disconnected; the problem with these vacuum lines is that they are very easy to remove from the connector nozzles, they're just like the tubing you use for fish tank air pumps.
    Another reason could be that the vacuum lines are cracked, you should be able to tell by feeling the rubber, if it is not supple and feels hard or brittle it might be time to replace the lines. Should be easy enough, just buy a few yards of vacuum line tubing and replace each line one by one, cutting each to the proper length and reconnect.
  • Options
    nljewellnljewell Member Posts: 21
    My 99 Jimmy (4.3 Vortec) has been hesitating when first taking off from a stop only when engine is cold. I have replaced plugs and wires, cap and rotor, egr valve, fuel filter, had my fuel pressure and cat convertor tested (both good), and I just replaced my temp. sending unit. Before I was running at about 165 degrees, now I'm getting about 190 degrees after adding coolant that was lost after taking old unit out. Is that normal temp? And I think I added more coolant than I needed in resevoir, is that ok or should I take some out?
    And a little tip if you're replacing your temp. sending unit, use a wrench to tighten new one, I used a socket to get old one out and i broke the wire connector off.
  • Options
    nljewellnljewell Member Posts: 21
    Just drove my Jimmy for the first time since changing my temp. sending unit. It's Thursday night and I haven't drove it since Sunday night. It took off great with no hesitation. Finally. Cheap and easy part to replace too. The gallon of Dex-Cool was just a couple $ cheaper than the part itself. Hope this helps someone in the future.
  • Options
    c3tucker1c3tucker1 Member Posts: 1
    So myg/f's 99 jimmy had the heatercore replaced before winter. Now that summer is here the ac seems to have stopped working. The air doesnt blow warm like its outside air, it blows HOT like the heat is on...any ideas?
  • Options
    rdumerrdumer Member Posts: 2
    I've read everyone's problems and comments on this issue, but I still NEED help! My 98 Jimmy only blows HOT air, not just outside temp air, but HOT air. We did
    the 'reset' procedure, removed the BAT RDO fuze waited 10 secs, replaced it, put
    the key in on position and waited >1 mins for the ECC to reset, BUT it didn't fix it. When we push the 'a/c' button on the climate control panel, the light goes on and the compressor under the hood kicks in, AND the lines to/from the compressor at COLD, but the air blowing in the car is HOT.

    Originally I took to a 'shop' and they suggested replaced the Climate control panel (I have been trying to located a used one, b/c the new GM ones are $300) but I can't find one, plus reading the posts some people have done this with NO success.

    Since the compressor feels COLD, I think there is freon...and the blower buttons
    seem to be acting correctly (actually the reset 'might' have allowed the blower to
    respond..not sure at this point if that changed or its just our imagination, hoping the 'reset' did something!)

    Should our next step be check the 'doors' in the area beside/behind the glove box?
    to see if they are stuck?

    I read about a potimenter (sp?) is that the same thing as the actuator doors?

    This is my daughter's car, limited money, so we don't want to spend a forture on
    mechanic bills..
    ANY SUGGESTIONS ARE APPRECIATED!!!!
  • Options
    rbaumgrasrbaumgras Member Posts: 3
    Because the Main Gear in the Blend Motor has cracked and is now not turning the heat/cold door to the Cold position. 3 fixes: Buy a new Blend motor, takes about 5mins to replace. Buy a new Blend Motor Gear, will take about 30mins to fix. Repair current gear with Epoxy, takes about 30mins and 12hrs for the glue to set up strong enough to use it.

    http://wiki.answers.com/Q/Why_would_your_98_GMC_Jimmy_blow_hot_air_even_when_the- _temperature_gauge_is_set_to_cold

    Hope this helps. Have not checked my Jimmy yet but I have the same problem. Will check it out tomorrow but this sounds like the real fix.
  • Options
    ziggysandersonziggysanderson Member Posts: 4
    Greetings,
    On a 2000 GMC Jimmy I have recently discovered that my "no heat blowing" issue is due to the fact that my a/c compressor is running as soon as I turn on ANY of the temp controls. Once I removed the fuse for the A/C compressor, the temperature controls will blow hot/cold as per the control setting, with/without using climate control. Any idea why my a/c is continuing cool/run when the settings are for heat and the A/C is not even turned on via the switch?
    Thanks in advance.
  • Options
    anothercup1anothercup1 Member Posts: 1
    I just had this same problem on my 2000 gmc jimmy. The air coming out of the vents was always super cold or sometimes super hot. Took it to a mechanic to look at and he said it was the heater door actuator. Cost would be 4 hours labor (have to take the dashboard apart) and a $80 part. Ended up doing myself and found the new part for $47 and if you have small enough hands you can do it without removing dash.
    On mine it is located behind glove box, just drop glove box down and let it hang. Behind it you will find the vent selector control, its round and has a single wire leading to it, take the wire off and pop the control up and move it to the side. Just behind that and up a little is the heater actuator. Two nuts in front and left side that you can take off with a ratchet. It is a tight space, but if you just get screws to turn a little you can do the rest with your finger and ratchet piece. Then pop off bad actuator and turn the knob that actuator sat on to the center position so it matches your new parts position. Put the actuator on, put the nuts back on and connect wires, put selector control back and your done.
    I had this problem for a few years and struggled every season beacuse heat/ac wouldn't switch back and forth. This fixed the problem.
  • Options
    ziggysandersonziggysanderson Member Posts: 4
    Thanks a lot the for reply, I had a feeling it was due to the heat actuater but I wasn't able to locate it but that should be a problem now... cheers!

    Ian
  • Options
    heidenreich1heidenreich1 Member Posts: 2
    I changed thermostat even though temp was ok
    changed cap as it was leaking. Flushed block
    and heater core with garden hose, both had full
    flow. I'm stumped. Any advise out there on what
    next to check. This vehicle also has temp. control.
    Thanks for the help.
  • Options
    smagzillasmagzilla Member Posts: 1
    ok 98 gmc jimmy slt. i have some reoccurring heating problems and every year it seems the mechanic has to backflush the heating coil and replaces the thermostat. i know i can get the stat locally and would like to just change it. need to know where the stat is??? ive read a dif model was under the air intake/throttle. is that the right spot? i also have pumps at work available to backflush the coil. any other pictures or advice. im not real good at cars but hvac i know.
  • Options
    ziggysandersonziggysanderson Member Posts: 4
    That sounds like your blend door motor is the problem. I have replaced it in troubleshooting my heater issues. On the climate control models this motor is located up behind your glove box. It can be replaced without removing the dash but takes a little patience to get it in. Cost me 80 bucks for one.
  • Options
    jminingjmining Member Posts: 1
    I have a 1996 GMC Jimmy. I read that the problem is that there is no vacuum pressure to control the vent selector (its not an electrical control). The fix: typically when this happens it is simply a vacuum line that has disconnected; the problem with these vacuum lines is that they are very easy to remove from the connector nozzles, they're just like the tubing you use for fish tank air pumps.
    Another reason could be that the vacuum lines are cracked, you should be able to tell by feeling the rubber, if it is not supple and feels hard or brittle it might be time to replace the lines. Should be easy enough, just buy a few yards of vacuum line tubing and replace each line one by one, cutting each to the proper length and reconnect
    Does anyone else agree with this assessment of the problem?
  • Options
    gyakegyake Member Posts: 2
    edited July 2010
    re: #81 ziggysanderson, by anothercup1 ...you were right on. I did exactly what you said and problem is fixed, no more clicking sound, no more blowing hot air, and the a/c is working great. the plastic gear was broken in the cold /hot air door actuator. saved me hundreds of $$$ .gmc mechanics cculdn't even figure it out. I see there are a lot of people with the same problem. hope they read this. thanks again guys!
  • Options
    sidrvr89sidrvr89 Member Posts: 3
    so when i cycle through ac max,norm, ac blend, vent,blend, defrost it wont change. just blows through the defrost and floor. i was reading some where else and i think it might be the blend door accuator (i think thats what it was called. also when everything is off and im driving down the road i get air still coming through. would that be because its the vents are stuck open?

    i have a late model 95 Jimmy 4x4
  • Options
    reluskiereluskie Member Posts: 1
    The air on my Jimmy is only blowing out the front vents. The temperature is correct and I the air/defrost work - I can hear the compressor kick in when I flip it to defrost - but the air only blows out the front vents. I can move the control to all the positions but it's stuck blowing on the front vents. Any suggestions.
  • Options
    buzzedbuzzed Member Posts: 1
    where are these vacuum lines located? How do you find and get to them?
  • Options
    scott7201scott7201 Member Posts: 1
    Also check your HVAC fuse (30amp) onnthe drivers side ebgine compartment.Those small fuses are hard to spot so pull it out to check or use a circuit tester.
  • Options
    ebaugesebauges Member Posts: 1
    Looking for anothercup1. Would like to know where he bought his air blend motor for his jimmy.
  • Options
    kingstonsman53kingstonsman53 Member Posts: 44
    I can fill up my air condition system but only lasts a couple weeks or mor then goes empty. Replaced compressor and all oil seals. Cant find out where its leaking .maybe it's the evaporator under the dash compartment or in the coil nest to the radiator. How can I get this checked. Would appreciate any suggestions.
  • Options
    ula72650ula72650 Member Posts: 1
    After adding Freon to my 2000 Jimmy my compressor kicks on and off all the time even with I don't run my ac. I have the climate control setting but I didn't run my ac but one time before all the freon was gone. It only took about a week maybe 2 weeks at most and I didn't have any freon left. We put more freon in and put in some stop leak with it and it did the same thing. Can anyone tell me how to go about having this fixed. Thanks for all the help.
  • Options
    eeareear Member Posts: 1
    I have a 1996 Jimmy. After replacing the stereo in my dash today, I noticed the climate control has no effect on the temperature of the vented air. Switching from defrost to dash to floor works as expected, just the temperature is stuck on heat. I suspect I did something in the dash when replacing the stereo, I would be surprised if the heat actuator went out at the exact same time I was moving things around.
  • Options
    mpastormpastor Member Posts: 1
    edited March 2012
    Blend door keeps moving from hot to cold, tried replacing blend door actuator, and the unit in the dash, tried to rest the computer as well, still doing the same thing. Any suggestions would be greatly appreciated... Thanks
  • Options
    tysailor24tysailor24 Member Posts: 2
    I'm having issues with the air conditioning/heating system. When I have on AC or MAX AC, I get hardly any air from the ports above the stereo. However, I get decent flow from the vents at the windshield...like I have it turned on Defrost. Anybody know what the problem could be?
  • Options
    gmcustsvcgmcustsvc Member Posts: 4,252
    tysailor24,
    Thank you for taking the time to post your concerns. I apologize for your frustrations. I would recommend speaking with the dealer. They are in the best position to diagnosis your vehicle. Please let me know how things go at the dealer.
    Christina
    GM Customer Service
  • Options
    vvailvvail Member Posts: 1
    My 97 Jimmy blower won't turn off with key and with key off windows still work. I replaced the ign switch and still the same. Key off, ign switch unpluged fan and windows still work no other light are on and nothing else works
  • Options
    dkarasdkaras Member Posts: 1
    My 2001 jimmy has ice cold air in the morning and when I drive for about 20 minutes it starts getting warm if I stop for 5 to 10 minutes and restart will not get cold I leave it overnight and next morning it is ice cold this happens every day same thing ice cold in morning and that 20 minutes later warm any ideas.
  • Options
    ddoug449ddoug449 Member Posts: 2
    On my 1997 jimmy my air condition compressor keep coming on even when I cut on my heat you can hear the compressor clutch turn on and off,and also do the clutch suppose to keep clicking off and on. :confuse:
  • Options
    jhillyjhilly Member Posts: 1
    edited January 2013
    2000 Jimmy. My ac started blowing only cold air. I had some guy in front of autozone (?....seemed logical at the time) change the thermostat, flush the radiator, and add antifreeze (green?). The heat worked for a couple days, but when i was at a light the engine would shake and the lights would flicker. Car stopped a couple of times, but started right back on ignition. The heat eventually stopped again. I took it to a proper shop and he added antifreeze (said i needed a different brand/color?) and said i had a leak he could fix and to bring it back a couple days later. The new antifreeze worked. Heat came back and the shaking and flickering stopped. But in those couple of days the heat stopped again (shaking and flickering hasn't returned). I took it upon myself to add antifreeze until i could get back to shop. Some antifreeze worked (prestone 5050) some didn't (Peak). But it leaks after the car is running for a few minutes, not when i initially put it in. A gallon usually lasts for about an hour. Furthermore now the car overheats and smokes after about twenty minutes on the road. Lastly, i hear a gurgling sound behind the dash.

    Just left it at the shop. Mechanic says i need to have the gaskets replaced for $500. Does this sound right? Is the price right? Just dropped $500 on catalytic converter replacement. wondering if repair is worth it or should i cut my losses.
  • Options
    noshow88noshow88 Member Posts: 1
    Wont blow hot air on defrost/heater cycle.
  • Options
    Colin RogersColin Rogers Member Posts: 1
    I have a 1997 GMC Jimmy and there is absolutely no air hot or cold coming from vents? plz hlp
Sign In or Register to comment.