Nissan Quest/Mercury Villager Electrical Problems



  • 68hotrod68hotrod Member Posts: 2
    bought car  new 2000 leftover in 2001 3 time brought car back to dealer for head light going out  3 times they said  they fixed something   last time was 2005  still having same problem spoke to regional supervisor  will not do anything  what do i do next they  want $ 350 to repair donot want to pay i  feel it should of been corrected the first 3 times
  • stil29stil29 Member Posts: 1
    Had the same issue. After putting the key in and out 6 times actually start the car instead of just acc. Then push any button on the transmitter. No problems now. Good luck. :D
  • xmasxmas Member Posts: 2
    My nissan quest se 07 has had an internal failure in speedometer and advised I had to replace insturment cluster. Total cost @575.00. Since I have 59,000 miles it is not covered under waranty. I called nissan customer service to complain. I am waiting to hear back from regional director. Has anyone had this problem? I thought speedometers lasted alot longer than that.
  • zgrabozgrabo Member Posts: 2
    I have exactly the same problem with my headlights and daytime running lights.
    Just wondering how you managed to fix it ?
  • zgrabozgrabo Member Posts: 2
    I have the same proble as fitzgerald posted about year ago (2007).
    The daytime running lights come on sometimes and goes off some times? Also my dashboard high beams light says its "on" all the time when i turn my headlights on when clearly there not on. Any comments???
    Just wondering "fitzgerald" how you manged to fix it?
  • junebug1701junebug1701 Member Posts: 31
    The Canadian Villager/Quest has a daytime running light module mounted on or near the passenger side strut mount under the hood. I have heard that if you take the module apart and touch up the solder joints it may fix the problem. Seems this board suffers from cold solder joints that eventually fail. Go to:

    For lots of great information on this problem.

  • efitzgeraldefitzgerald Member Posts: 62
    Hi I sold my villager as i refused to put any more good cash for bad worn vehicle.
  • freedmlfreedml Member Posts: 43
    did you ever figure this out? I have the same problem.
  • efitzgeraldefitzgerald Member Posts: 62
    I sold my 98 villager and bought a 07 altima it..good car
  • dcracraftdcracraft Member Posts: 1
    My wifes van stalled and will not start. I replaced the coil, had the igniton control module test and even replaced the coil to dist. cap wire. Van still wouldn't start. So off came the dist. cap. Rotor and cap are maybe a month old. When we turn the motor over the rotor does not turn. If I grab the rotor, I can't turn it. Feels normal like. :)

    My question is, does the timing belt have anything to do with the distributor turning, or does the dist. get ran by the camshaft or something else?

    It seems to me that if the distributor wouldn't turn by turning over the motor, I would be able to turn the rotor really easy.

    Any ideas? I know I'm gonna have to replace the distributor... :(
  • jedftjedft Member Posts: 4
    I have the same problem, just happened yesterday. You figure it out yet? If not I'll let you know when/if I do.
  • efitzgeraldefitzgerald Member Posts: 62
    Yah, I drove my 10 year old high kilometer van which I bought new 10 years ago into a dealer and got $500 towards a 07 Altima. last I heard my van is a cube, awaiting for reincarnation. hope this helps. fitzgerald
  • thecarphotoguythecarphotoguy Member Posts: 1
    I've posted a "Thank You" to the McGavock Nissan Website who fixed my wife's 95 Nissan Quest. They cleaned out a bunch of PET HAIR that had gotten into the steering column and CLOGGED THE KEY MECHANISM! She'd come out after a long, hard day at work but was unable to get the ignition key to turn and had to walk home in the Texas Heat (I'm in another area of Texas). The Nissan Dealer had the van towed in, fixing the "hairy problem"! The tow company evidently snapped the transmission selector cable so the dealership didn't charge my wife for any of the work or the towing! I was very happy for the honesty and care they took with my wife. Some shops might fib to a women, who is alone, about the cause of a vehicle's problems, but McGavock wasn't playing that game so their Service Department gets my whole harted recommendation, especially for taking care of a unaccompanied woman!! As far as keeping hair out of an ignition key mechanism, I'd guess I'd suggest not having pets on your lap while driving or sitting in the driver's seat and keeping the floors, seats and dash area vacumed (but its just my guess)!
  • denzildenzil Member Posts: 1
    The windshield washer low fluid warning light is on in my 2002 Villager Estate with electronic dash even though I've made sure the resevoir is filled to the top. I've pulled fuses to reset it and have done the 3+ start cycles to reset it with no luck. Has anyone else had this problem and found a soultion?
  • jedftjedft Member Posts: 4
    A piece of black electrical tape over the light will fix you right up :). But seriously, there's probably a sensor in the bottom of the tank that has gone bad or is gunked up.
  • abakaabaka Member Posts: 2
    I have 1997 Mercury Villager and I like this van.
    I have some experience (mechanical) of this van and I would like to share this with others. After a traffic jam ( about an one hour or so) the van hesistated to accelerate to a high speed and the next day SE (service engine) light was on and the "code reading(ODBCII)" showed to change the Oxygen sensor I did it, and changing O2 sensor did nothing for SE and this time reading is knock sensor. I did nothing van was running good for a month or so WITH SE LIGHT ON untill the starting problem showed up.

    One day morning van starting in a sluggish mode the engine accelaration was not stable (up and down). Accelaration controlled by fuel supply and the throttle etc .I changed the fuel filter and the fuel presure ok now I left with TPS.
    I check the TPS (throttle position snesor) when the throttle fully open 0.9 K ohm (should be .4 to .5 K) then fully closed 3.2k ohm( Ishould be 4k)I adust the fully closed to .5k and able to achive 3.2K closed . Next morning It was very difficult to start the van finally did start by warming up the engine with the electric outlet(block heater). Next day I readjust the TPS high (closed Throttle) almost 4K and the may be 1K for the fully open . Now the van starts smooth and runs good .
    I have to change the TPS soon untill then I am running the van. It is better to check the TPS in the Mercury villager van although the reading gives other indications like knock sensor etc. by the way replacing the knock sensor is very expensive so before doing so check the TPS for any fault.
  • jedftjedft Member Posts: 4
    I'm not sure what all years it was a problem, but you may want to check your distributor. The shaft bearing can slowly go bad in them which causes all kinds of weird ODBII codes (especailly knock sensor) and intermittant problems with acceleration.

    BTW I'm pretty sure the knock sensor was put where it is just to keep mechanics in business ;)
  • abakaabaka Member Posts: 2
    I have no problem of running, only problem is strating early in the morning.
    Vehicle shake, hessitate and start with smoke

  • rogerlee1rogerlee1 Member Posts: 2
    My uncle couldn't get the dome lights to go out, so he used a pocket knife to pop out the bulb, but he shorted something and the door locks started locking and unlocking like a security alarm. Now there's no inside dash or dome lights, not use of electric door locks....what's up???
  • julliejullie Member Posts: 1
    when drive for a little bet when i turn off my car will not start back up. it at little the batter is dead but it is not it will not start untill the next morning. but it does the same thing. help please
  • efv921efv921 Member Posts: 2
    Check that you didn't break the gas bypass switch located in your drivers side footwell just underneath the fusebox.
  • rogerlee1rogerlee1 Member Posts: 2
    I own a 1999 Mercury Villager. The interior lights, including dashlights won't go off unless I remove the fuse. I've bypassed all door switches one at a time, and all check out fine. Also, the keyless remote won't lock or unlock the doors. When I push a button on the remote, the outside lights flash, but that's all. If anyone has any advice for a poor boy please reply. Thanks
  • nzamnzam Member Posts: 2
    You know your timing belt is broke if when you turn over the car, and the cam shaft does not turn, it is either broke in half or some of the teeth have broken off of the belt. In either case you need a new belt. If you keep trying to start the car, and your valves in the head are in the down position your going to smash them and then you will need a new valve job as well.
  • stov24stov24 Member Posts: 1
    I just purchased a 00 Nissan Quest with 85k miles. There is one issue I have been unable to figure out. Everything is great except some of the electrical (i.e. wipers, radio, lighter, etc) only work when the car is off. If the engine is running they receive no power. Any thoughts on how to correct? Thanks so much!!
  • rockmobilerockmobile Member Posts: 115
    edited August 2010
    Looks like something is backwards, but 85k miles on a 2000 Quest sounds really, really good.
    Go to Nissanhelp and under Knowledgebase find Service Manuals where you can download two manuals per day. The electrical manual is a most.
    Good luck.
  • canyonsvocanyonsvo Member Posts: 23
    I can almost guarantee that the ignition switch is at fault. With the car started, turn on your wipers and radio and jiggle the key up/down, forward and aft. I'll wager that your lights and wipers will work when you do that.
  • fam54childfam54child Member Posts: 2
    I have a 1999 Mercury Villager. This morning it cranked up just fine. I went to church and when i got ready to leave again it started just fine. However not maybe 20 minutes later i pulled into the bank, turned everything off, went inside for about 2-3 minutes came out and it wouldnt start. I tried to jump start it and still nothing. what should I check next?
  • rockmobilerockmobile Member Posts: 115
    If you have been unable to start it up by now, start looking at the ignition wires and then the distributor.
  • canyonsvocanyonsvo Member Posts: 23
    More info. needed to help. What happens when you turn the key? Does the car crank over but just not start? If it is a hot start problem, the distributor is often the culprit in these vehicles. Also, a broken timing belt could be the cause.
  • docwudocwu Member Posts: 3
    While changing the battery in my 2002 Mercury Villager, I reversed polarity and blew the 140A ALT fusible link. Both the fusible link and the battery were replaced and all appeared well (alarm triggered, interior lights came on when door was opened etc.), until I attempted to crank the engine. All of the familiar signs that the car is fine are there (lights come on, fuel gauge moves, A/C blows etc.) the engine merely won't crank. I have a feeling that the factory installed security system is not allowing the car to start, but unlike an after-market alarms, there does not appear to be a valet reset button/switch under the dash. Any ideas as to either reset the alarm or could it be something entirely different and I am chasing the wrong culprit?
    Thank you in advance for any and all help.

  • jedftjedft Member Posts: 4
    Wow, epic fail on the reverse polarity. You're lucky you didnt get hurt. Anyway, there's only about 100 things that could be the cause. May have fried something in the control computer, alarm, starter, ignition coil, misc. wires up under the dash, other fuses in the fuse box, etc. etc. What happens when you turn the key? Are there any clicks from under the hood? Does it "do" anything?
  • docwudocwu Member Posts: 3
    Yes, luckily the battery stayed intact and I was not injured/maimed or worse. I know, EPIC fail, I have kicked my own behind enough that at this point the steel toe imprint will have to be surgically removed...
    Regardless, No clicks i.e. starter, merely all the usual lights in the dash come on as though were I to turn the key fully to engage the starter, nothing... I have checked every fuse possible, both inside the cabin and under the hood. The reason I thought that it would have to do with the security, is because a friend of mine had a similar experience, but he had a Viper alarm system, which has a reset toggle/button under the dash and when he clicked/depressed the apparatus to reset the system, the vehicle started.
  • jshb61jshb61 Member Posts: 1
    I have the same problem with my 1995 mercury villager what did you do to solve the problem?
  • docwudocwu Member Posts: 3
    It was both the starter and the main fuse (in the fuse box under the hood, 2 screws to undo and it will pull up and out)... the radio fuse as well, but that does certainly not have anything to do with the running of the vehicle...

    Hope this helps
  • retired8retired8 Member Posts: 15
    My 2001 Villager has both front and rear washers inop. Both wipers work fine, fuses good. I can't find any reference to a relay. The low fluid light is on with the tank full. The washers worked fine with the low fluid light on for over a year. They both just stopped recently. No noise in the engine compartment when the the washer switches are activated. I read everything in the Read Only section and am sure the problem is in the section under the wheel well dust cover. My question is, are there two pumps and are they both located at the bottom of the washer fluid tank? Auto parts store shows two different pumps, but no location. Or, is one pump located in the tail gate. My Haynes manuel doesn't tell me this info. Thanks for any discussion. I hope this is in the correct forum; the search didn't turn up much new about the washers. I'm ready to rip into it, just want to confirm what I think I know??
  • lilblkshplilblkshp Member Posts: 2
    some other guy was working on it and he couldnt get it running for two months so they bring it to me. i check spark, got it. i check fuel, have everything but injector pulse. so i spray starter fluid and still wont run so i check timing, its right. so i set it tdc and pull dist cap, way off. so i set the dist to number one with eng at tdc. spray starter fluid and runs like a champ. when i first got the van i notice alot of grass and leaves under hood like critter nesting. pull intake and voila, critter chewed up injector wire. seperate injector wires and unplug all non essential sensors and pulse comes back. repair wire with wire laying around( not sure if it has to be certain kind of wire) but pulse goes away? switched pcm with known good pcm from another van, even put pcm from this van in other and it works. pulled harness in engine bay and checked continuity and thats fine. its got me kinda baffled????????
  • averic04averic04 Member Posts: 3
    Hello All, whenever i'm on the throttle (doesn't matter full or slight) or hit a bump on the road the interior lights come on. It's been doing this for a while now. Whenever the lights come on the Door Ajar light on the dashboard panel lights up. I finally found it was the passenger side sliding door that was causing it. I've looked everywhere and asked quite a few people for help and advice but no once seems to know how to fix this. At this time, just to keep the lights from coming on during night driving, I took out the fuse to the interior lights. Btw this also stops the moon roof hatch from working. Anyone have any ideas or similar problems?
  • rockmobilerockmobile Member Posts: 115
    What year is your van?
  • averic04averic04 Member Posts: 3
  • rockmobilerockmobile Member Posts: 115
    These lights are controlled by something called 'Smart Entrance Control Unit'. Since you have narrowed it down to the passenger side door, I would be looking at the push button switch sitting opposite the door, at the bottom.

    It looks like it is held by a single screw, so it should be easy to remove - I have never done it.
    Your problem may be a switch or a misaligned door.
  • averic04averic04 Member Posts: 3
    Thanks, I'll give that a try and see how it goes.
  • pat_ncpat_nc Member Posts: 2
    Hi...I am very new to this forum ..Thanks you for important tips and sharing info.
    I have a Nissan Quest 94 regularly maintained ...Battery is just 2 yrs old , shows 12 volts..
    I came home yesterday (outside temp was 65 )...I put van in Park and Suddenly all the lights gone.
    When i open the door , door lights didnt turn ON...Usually the seat belt comes off by itself once i open door. It didnt
    So i tried to start Van..No sound No clicking nothing...Wht might be wrong..?? is there any kill switch or something...??

    All I know was brake fluid had gone below min level and brake light was ON...
    I drove like that for 6 miles...during that once ABS sign also lit up; just for 2 seconds. Then its gone. To be specific I happen to drive almost 4 miles after that ABS light disappeared...Thank god the van reached home But Now its not starting at ll..Wht could be the proble....?? pls help
    Appreciate your tips...
  • rainman020973rainman020973 Member Posts: 1
    I have a 2004 quest that I have been haviung problems with. It started a few months ago where the radio would go on and off as driving. Power was on but audio went out. It was iintermittent so the dealer could not locate problem. Soon after that, my airbag light came on and now flashes constantly.. Also, my cruise control does not work. All of this is leading me to believe an electrical problem... Any ideas on what all of these have in common???
  • pluiplui Member Posts: 5
    I requested the same problems to my villager,99.
    After I ran it more than five miles when the engine was cold, it started hesitated, idle dropped, and died on signal light.
    I had 3 mechanics to work on my vehicle, and replaced fuel pump, fuel gasket, spark plug, distributor cap and rotor. Also, the intake manifold was clean.
    I met someone last week who worked on his 94 villager and recommended to replace the modual on the distributor.
    I wish to have your opinion soon.

    Kindly Regards,

  • smile100smile100 Member Posts: 20
    I used to have a '91 Ford Escort whose radio was dead for 3 years. Once I couldn't start my car and changed the ignition lock cylinder, the radio was back to live. You may have similar cause.
  • dtownfbdtownfb Member Posts: 2,918
    Check your ECM. It's located under the hood on the passenger side jsut underneath the plastic sill. THis model year has issues with the ECM rusting. It's not well protected from the rain and can rust out.
  • susiechuckiesusiechuckie Member Posts: 1
    My battery was dead we recharged it and now the auto windows and door locks don't work. We checked the fuse and took the cables off the battery for a few hours and still don't work. Is there a reset button ?
  • mrs_martinmrs_martin Member Posts: 2
    i have a 96 nissan quest and my husband is trying to fix it but we have no clue how to test the TPS and if there is any way to bench test it. what it is suppose to be and all the mechanical mumbo jumbo.
    is there any advice i can get??
  • mrs_martinmrs_martin Member Posts: 2
    we need help on my van i need to know how to test the TPS sensor. does any one know how to do so. we burn through a lot more gas then when we bought this van.. please we really need help..
  • rockmobilerockmobile Member Posts: 115
    I have a 99 Quest, so I can't help you. Try this other forum for some help: villagerquest.
Sign In or Register to comment.