Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

1982 Mercedes Benz

arakali_varakali_v Posts: 1
edited April 2014 in Mercedes-Benz
I have 1982 Mercedes Benz 300SD Turbo automatic transmission. The car runs smoothly. But after it warms up the car shakes when I stop at traffic light. When I shift to neutral the vibration is reduced. The vibrations increases when AC is turned on. Any one has any suggestion to fix the problem

Comments

  • burdawgburdawg Posts: 1,524
    I'm not a diesel expert, but it sounds like the idle control isn't working properly, or the idle is set to low.
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    Possibly, but probably the idle is only the symptom, not the disease.

    I would say you have one or more bad injectors that are "spitting" at idle, that is, sending an uneven or erratic spray. You might try a heavy-duty injector cleaner (from a repair shop, not something off the self at Grand Auto)....something really NASTY that you wouldn't dare touch much less spill on the car. Along with that HD cleaner, I'd add a fuel conditioner and also service all your filters if you have not done so.

    If none of this works, it's injector time I think. DO NOT attempt to adjust the idle by turning screws this way and that. You could upset the entire injection pump timing.
This discussion has been closed.